Previous 1 40 41 42 43 44 Next 953 Replies Latest reply: Mar 31, 2016 8:28 AM by Barbara Smits Go to original post
  • GwendolynR Level 1 Level 1

    Moveslink causes my back-up drive to eject itself as well.


    Whaddya know. I updated my Moveslink software yesterday after a year hiatus, and after ejecting my USB dongle and leaving Moveslink running, my backup drive ejected itself.


    It has ejected mid-way through each back-up since then, but quitting Moveslink has fixed the issue. Thanks for posting that!!

  • MrElvey Level 1 Level 1

    I've discovered what I think is the underlying reason for many of the folks reporting similar problems to this thread.


    By the way, I bet that I can predict the GUIDs of the drives/docks/cases you're having trouble with! 


    I bet that if you look in System Profiler, you'll find the GUID 0x30E002E0454647 !


    What are the odds?  I shouldn't be able to predict them; theyr'e supposed to be unique, after all, but google that number and you'll see that a great many devices all use that GUID.  Mac OS seems to rely on them to be unique, and has fits when they aren't. 


    I haven't found a total solution yet, but in the meantime,


    Running this in Terminal can help:

    sudo kextload /System/Library/Extensions/IOFireWireFamily.kext/Contents/PlugIns/AppleFWOHCI.k ext/


    sometime it helps to run this first to unload before loading the kext (kernel extension):

    sudo kextunload /System/Library/Extensions/IOFireWireFamily.kext/Contents/PlugIns/AppleFWOHCI.k ext/ 

    enter your password if/when prompted, of course.


    I found information on how to change a Time Machine's records of the UUID of a drive it backs up, but not of a drive/dock/enclosure itself.  Think I'm close?

  • MrElvey Level 1 Level 1

    Oh and in Disk Utility, you'll find the GUID displayed in base 10: "Connection ID 13757101839304263".

  • William Boyd, Jr. Level 6 Level 6

    MrElvey wrote:


    Oh and in Disk Utility, you'll find the GUID displayed in base 10: "Connection ID 13757101839304263".

    What are you doing to display that value?


    By the way, don't confuse "GUID", a type of "partition map scheme" that applies to a disk, with "Volume UUID", a value assigned to a volume.

  • vgm106 Level 1 Level 1

    These are the behaviors with my seagate expansion 3TB usb 3.0 drive under

    Macbook white late 2006: Will eject whenever I put my mac to sleep. Tried almost everything, simply couldn't fix it.

    and Macbook Air 13" mid 2012 : Speed increases owing to new USB 3.0 ports. Still ejected but stopped when i unchecked "Put hard disks to sleep.." in Energy Saver prefs. Started ejecting when my mac was sleeping overnight. Duration of the sleep seems to affect it.


    Quite problematic. Couldn't get anything to solve after almost a year. Will get back if I fix it.

  • capercaillie Level 1 Level 1

    I appear to have stopped my time machine back up disk from ejecting itself by unplugging my USB printer.


    Not really a "fix", but at least I can backup now. Hoping (vainly?) for a proper fix with an operating system update.


    The following didn't work for me:

    turning off "Put hard disks to sleep when possible" in system preferences

    using Onyx to repair permissions etc.


    I'm running Lion on a Mac Pro which never goes to sleep.

  • tingotanca Level 1 Level 1

    Earlier in this thread I've posted my personal experience suggesting that it's what I called "strong" and "weak" cable connections that under certain hardware and possibly software (system) configurations might determine whether a drive would get ejected or not. While I did experience the issue on the same machine with some, but not all, USB sticks, it's primarily Firewire drives that have been my concern – and that I've managed to stabilize by using shorter cable connections.


    However, here's something curious I've run into today, with a no-frills Brand X 80 Gb USB hard drive that came with a used 2007 MacBook Pro I bought a few weeks ago. The previous owner used it as a Time Machine backup drive, but I had no use for it. Back when I got it it was mounting perfectly well, but today it just wouldn't mount. I then tried plugging it instead in the external keyboard attached to my MBP 2011, no better luck. But plugged directly in the MBP (that's the one I'd originally had ejection problems with), it almost immediately was ejected with the usual warning. Same thing when I plugged it in one of the Cinema Display's USB ports. However, when plugged in my MBP 2010, which has never had any problems with ejecting either Firewire or USB devices, this USB drive stayedd put. So far, then, same pattern as earlier.


    While I was fuddling with the drive I realized that the short (60cm) cable's plug (a standard rectangular elongated Type A plug) was sitting rather loosely in the drive. Thinking that this might be the cause of a flimsy connection, I reversed the cable (contrary to many similar devices, in this case it's identical to the one at the computer end, i.e. it isn't one of those small slightly trapezoidal Mini-A plugs), but offhand the connection seemed just as loose. Yet – lo and behold – when I plugged it in the MBP 2011, it didn't budge one iota. I was able to have it scanned by Spotlight and to unmount it and mount it again manually several times: it didn't self-eject one single time.


    It appears then that a cable's plugs have just as much to say (strange, isn't it?) when it comes to determining whether the cable will hold a connection or not. My advice to all, then, if you have that option (with plugs that are the same at both ends): try reversing the cable and see if that helps before trying anything else.

  • S_Y_C Level 1 Level 1

    Guys, I've bought the latest Mac Book Pro retina display, running Montain Lion and I do have the same issue with my external hard drive (brand: Rock mobile disk).


    What is curious is that I've been able to run Time Machine once, drop few folders and suddenly today I am not able to transfer anything; my external hdd ejects itself randomly especially while I'm transferring files.


    I've made 3 partitions: TimeMachine (starting first every time I turn on the disc), Personal, Profess...


    Could it be something related to the 2 partitions trying to mount while Time Machine is getting running?


    I've tryed both USB ports and always the same issue.


    Any idea?

  • capercaillie Level 1 Level 1

    Good to know Mountain Lion won't fix it.


    I don't have any partitions on my back up drive, and still have this problem.


    With no other USB devices connected (except my keyboard), my back up drive is able to make it through an incremental back-up at least. Although it still ejects itself randomly about 4-5 times a day.

  • macjansson Level 1 Level 1

    My WD discs worked fine after uppgrading the firmware and running Lion. When I installed Mountain Lion the random ejection of discs starded again.

  • MrElvey Level 1 Level 1

    William Boyd, Jr. wrote:


    MrElvey wrote:


    Oh and in Disk Utility, you'll find the GUID displayed in base 10: "Connection ID 13757101839304263".

    1)What are you doing to display that value?


    2)By the way, don't confuse "GUID", a type of "partition map scheme" that applies to a disk, with "Volume UUID", a value assigned to a volume.



    1)Umm.. I'm using Disk Utility.  I just click on the drive, and it's displayed.  Why do you ask?



    2)It says "GUID 0x30E002E0454647" in the System Profiler UI (after I clicked on 'FireWire').  Why do you tell me not to confuse those things/think I might have?

  • William Boyd, Jr. Level 6 Level 6

    MrElvey wrote:


    1)Umm.. I'm using Disk Utility.  I just click on the drive, and it's displayed.  Why do you ask?

    Apparently I've never looked at the bottom of the Disk Utility panel when I had a FireWire drive selected.  I see now what you describe.

    2)It says "GUID 0x30E002E0454647" in the System Profiler UI (after I clicked on 'FireWire').  Why do you tell me not to confuse those things/think I might have?

    It's clever of you to have realized that 13757101839304263 in decimal is the same thing as 30E002E0454647 in hex.


    When you mentioned GUID I took that as a reference to "GUID Partition Table", which might be displayed as the "Partition Map Scheme".


    According to Wikipedia, "The term GUID typically refers to various implementations of the Universally unique identifier (UUID) standard."


    One other point: The "GUID" value you see in Disk Utility and in System Profiler is that of the drive.  I don't believe that Time Machine is concerned with that.  Instead, I believe it's concerned with the UUID values of volumes.  Disk Utiity won't show you those.

  • Orangegodd Level 1 Level 1

    I was just going to reply to Richard E Cooke after trawling trough 32 pages of this thread when I came across your response! Admitedly your post was a year ago but it is the closest I personally have come to finding an answer to my problem. Did you manage a fix at all?


    My drive has a -01 model number AND WD Smartware installed which may be the problem. But how can I remove the Smartware software if the drive doesn't stay mounted for longer than 30 secs?



    See text below originally intended as reply to Richard E Cooke based on his observations but still relevant I think for other users.


    I have a four months old WD 1Tb My Passport SE drive and  It has since yesterday started ejecting itself within 30 secs of mounting on my MBP. There is therefore insufficient time to run any of the suggested fixes in this enormous thread ie,  a) run any utilities on it- (Disk Utility to verify disk & repair permissions etc or Onyx) or b) stop Spotlight indexing the  drive via System Prefs or remove the Smartware software installed on it


    The problem is not Time Machine related - I don't use it.


    It is not OS version related as it happens on two different MBP's using Leopard 10.5.8 & Snow Leopard 10.6.8


    The problem is not 'Sleep' related as it ejects instantaneously while machine is awake without touching the drive.


    The problem is not heat-related. It has been left overnight and on re-connect instantly ejects.


    The problem is not cable related as I have swapped it out with a cable from an identical WD 1Tb My Passport SE Drive that has been verified to not have this eject problem on either of the MBP's


    Solutions I have managed to try include un-ticking 'Send disk to sleep' in System Preferences

    Only solution havent tried is using a USB Y cable or powered USB hub.


    One last thing. I added some memory yesterday to the MBP, but I can't imagine that this would have affected the drive as the problem exists on 2 different machines- pure coincidence i think.


    Okay, here's the info from the System Profiler app before everything went bad. It may help.


    Capacity:          931.48 GB

      Removable Media:          Yes

      Detachable Drive:          Yes

      BSD Name:          disk1

      Product ID:          0x0740

      Vendor ID:          0x1058  (Western Digital Technologies, Inc.)

      Version:          10.03

      Serial Number:          *****

      Speed:          Up to 480 Mb/sec

      Manufacturer:          Western Digital

      Location ID:          0xfa200000

      Current Available (mA):          500

      Current Required (mA):          500

      Mac OS 9 Drivers:          No

      Partition Map Type:          GPT (GUID Partition Table)

      S.M.A.R.T. status:          Not Supported



      Capacity:          931.16 GB

      Available:          15.7 GB

      Writable:          Yes

      File System:          Journaled HFS+

      BSD Name:          disk1s2

      Mount Point:          /Volumes/MyPassport 1


    <Edited By Host>

  • Macondray Steiger Level 1 Level 1

    I have a brand new (late 2012) Mac mini which is randomly disconnecting then reconnecting to two different external HDDs.  Both HDDs (one is USB 3) worked perfectly with my mid 2011 MacBook Air previously.


    Any suggestions?

  • fei por Level 1 Level 1

    Sadly, NO.


    I seem to have trouble with powering back on after sleep ("snake on screen"), disconnecting with my backup drive and more recently, freezeout.


    Taking my time I only updated my MBP to Mountain Lion and since then my system just comes to a stop in the middle of whichever app I am using be it Mail, Excel, Word, etc. The beach ball spins endlessly and often the MBP fan works like fury.


    The only thing I can do is power off and then power on again - several times a day!


    I wish that Apple would look after existing users rather than try to launch products in every segment of the market - I guess every new CEO wants to mark his reign. But look what happened to Apple in it's previous non-Steve era?


    More than likely we have seen the best of Apple.

Previous 1 40 41 42 43 44 Next