Previous 1 41 42 43 44 45 Next 951 Replies Latest reply: Jan 19, 2016 6:47 AM by jhp03c Go to original post
  • elevenmedia Level 1 (0 points)

    Try a powered USB hub. It worked for both my 27" iMac and my MacMini. They were both doing it when I tried to move over 100gigs over. This is even if the drive is powered. While it maybe powered, the connection to the mac isn't and that is where the mac shuts down the connection (from what I have read)


    I also saw issues when a drive was being spotlighted, but not sure if that was a cause. The USB hub fixed the problem so I looked no further

  • Tziolas0912 Level 1 (0 points)

    Know this is not possible for some but THIS WAS DRIVING ME INSANE!! Just upgraded to Mountain Lion and problem is solved for me.  Just a heads up.   Please tell me this is not a sales ploy to get people to upgrade.  Sheesh.  Works though so party on

  • brian273 Level 1 (5 points)

    Macondray Steiger, this problem has afflicted many people's machines for ages now. Sadly Apple Inc. is not interested. If you look at past posts about the problem you will notice that there are some solutions that work for some people (and usually temporarily) but not for everyone. The real problem, it would see, remain undiagnosed.

  • Macondray Steiger Level 1 (0 points)

    Hi Brian,


    Yes, I kinda see that.  I used a MacPro (and a couple of Mac towers before that) comericially and since drives were internal never had these issues.  I've retired and downsized so sold most of my equipment, and started using a wonderful MacBook Air hooked up to external drives and 27" display.  I had absolutely no disconnect issues with the Air.


    Since giving up on waiting for either a Matrox or Belkin Thunderbolt hub, I decided to buy Apple's new Mac mini and now use it as my main computer & hub.  It's with the mini that I'm having these disconnect issues.  I'm using the same HDDs, one through a powered USB 2 hub, and the other USB 3 dual external HDD plugged directly into one of the USB 3 ports on the mini.  Both drives exhibit these disconnects.


    After my post I researched more and see that this is an ongoing issue for many.


    Since I'm sure my issue isn't related to my equipment or cable issues, and since Apple apparently hasn't yet come up with a solution, I've just decided to ignore it... though if I were still working commercially I'd be pretty annoyed.


    Many thanks for taking the time to post!


    Best wishes,  Mac

  • fei por Level 1 (20 points)

    A crying shame that Apple seems to be falling down on support while charging on to introduce ever more items of hardware - falling into the old Wintel trap?


    This disk drive ejecting (rejecting?) problem the issues with waking from sleep, wireless glitches and my and many others' systems that freeze for no apparent reason under 10.8.2 are issues they appear to have ignored.

  • Jeff Posten Level 1 (5 points)

    Just upgraded to Mountain Lion based on recently posted success, and unfortunately, I wasn't as lucky.  Still isn't working...

  • Macondray Steiger Level 1 (0 points)



    Called Apple, and since Mini is new qualified for AppleCare.  They tried a couple of things unsuccessfully and then set up an appointment at my local Apple store.


    In my experience, our local Apple store people are wonderful but not so knowledgeable so I thought I'd try a couple of more things befoe my appointment tomorrow.


    I think I may have found my work around...


    Connecting my external USB 3 drive through my powered USB 2 hub seems to elimintate problems... as someone suggested earlier.  Since USB 3 is of limited advantage over USB 2, I've just decided to leave it connected this way... and called AppleCare back to update my file, and ask them to cancel my appointment.


    I'll report back if this fixed my problem, but so far everything seems fine, with no unexpected external HDD disconnects.


    The problem may be Apple's new Mac mini USB 3 interface, OR it could easily be the USB interface of my external HDD.


    Thanks for everyone's help!

  • Jeff Posten Level 1 (5 points)

    Unfortunately, this doesn't explain or fix the Firewire 800 problems... but glad you got yours straightened out.

  • db247365 Level 1 (0 points)

    After opening my drive up and putting it in a new enclosure I've never had the problem again. These consumer HDD companies use $9 enclosures on these $100-$200 drives. I'm sure there's a legitimate osx issue here from the evidence I've seen, but I'd bet maybe half the reported cases are caused by defective enclosures. You can get an enclosure at a local computer store for about $20 that's way better than the ones they use. If the drive isn't working right, get adventurous, give it a shot!


    From what I've seen as of late Apple doesn't care about the individual customer anymore. We are cattle, nothing more then a number. They care about numbers, profits, math. They have become less and less customer centric. I guess 'think different' is just a cool thing to say when you're an outsider...

  • BelleBuice Level 1 (0 points)

    This just started happening to me about an hour ago and it's driving me insane! 

    What powered USB hub did you purchase?  I have an IMac OS X version 10.6.8 and using a WD My Book external hard drive.

    At first I thought about spending $19 to contact apple support but luckily I tried googling it first and came across this thread.  I wonder how much they have profited concerning this issue...

  • Macondray Steiger Level 1 (0 points)

    Hi Belle Buice,


    Funny that you should ask right now... since I just (minutes ago) removed my new 7-port 3.0 hub, and went back to a trusty D-Link 7-port USB 2.0 hub.


    I bought a "Pluggable 7-port USB 3.0 Hub" from Amazon a week ago to try it out, based on their very positive customer feedback.  I received it quickly... but immediately had problems.  It disconnected and reconnected my external HDDs several times, but then seemed to settle down and work OK with both my external 2.0 and 3.0 HDDs.  My main complaint was that it wasn't shutting down my external HDDs when I shut down my PC ("late 2012 Mac mini".)  Pluggable customer service is excellent, and incuded an initial email asking for my feedback based on my Amazon order.  They have been helpful working with me to to resolve this problem (including sending me a free replacement hub, asap.)  They are definitely aware of the technical problems relating to USB 3.0/Apple, and very interested in figuring this out.


    For me the final straw was when today the new hub started randomly connecting and disconnecting again, and this... combined with my original complaint of it not shutting down my external HDDs... led me to decide to return it to Amazon.


    PLEASE NOTE that this disconnecting problem is the whole reason that I bought a 3.0 hub in the first place, since my 3.0 HDD was connecting/disconnecting even when plugged directly into my Mac mini.... I don't believe this is a hub problem, but an Apple/3.0 problem.


    I hope this information is helpful?


    Best wishes,


    Mac Steiger

    Steiger Graphics

  • Washington Irving Level 1 (0 points)

    The spontaneous eject issue has just started happening to me with each of two identical new external 1TB LaCie Little Big Disk Thunderbolt HDDs - connected to a 2011 MBP running OSX 10.8.1.


    I haven't got much to add to the above thread, except that having the two identical drives and cables - each suffering from the problem, suggests that it's unlikely to be a QC or unit-specific problem with any one drive or cable.


    Doesn't seem to be happening with my firewire 800 or USB 2.0 drives, only the thunderbolt ones.

  • db247365 Level 1 (0 points)

    It's definitely an issue with Apple's stepping down of the 3.0, something times out in the pipes and the disk self ejects. That combined with cheap enclosures creates a problem with multiple factors contributing. I should have mentioned that when I replaced the enclosure I replaced it with a 2.0 enclosure and have not had a single eject since. Also noted was that the cheap manufacturer hd enclosure had some thermal tape applied, a sign that the drive had failed initial inspection but was pushed through after applying a 'bandaid', quite literally.

  • tingotanca Level 1 (0 points)

    @Washington Irving


    This would definitely point to the hardware of specific Mac models rather than to system software or peripherals or whatnot, then. Mine is also a (early) 2011 MBP, and while I never have used the Thunderbolt port, I did experience the issue both with Firewire and USB connections until I found the workaround I've written about earlier on this thread. On the other hand, no disconnections have EVER has occurred with an early 2010 MBP in this same office, using the very same Firewire and USB peripherals.

  • Macondray Steiger Level 1 (0 points)



    Our issue with Apple USB 3.0 and external 3.0 Hub/drive enclosures has been SOLVED!  With excellent customer support from both Pluggable (3.0 hub) and Vantec (external 3.0 MX enclosure) the problem has been found...


    The Vantec MX enclosure shipped (Amazon) with a defective USB 3.0 cable (from the manufacturer, Vantec.)  Vantec suggested a replacement cable after all other (more complicated) solutions failed... and this was the problem!


    My apologies to Apple...

Previous 1 41 42 43 44 45 Next