Previous 1 43 44 45 46 47 Next 951 Replies Latest reply: Jan 19, 2016 6:47 AM by jhp03c Go to original post
  • barbara89 Level 1 (0 points)

    I have already done all these things and none of them work. I've tried different memory cards and the same thing happened so I think it's not the card. I've also tried on another mac and the same thing happened. I think it might be the card reader, I'm going to buy a new one tomorrow let's see if it works.


  • Ellen74 Level 1 (0 points)

    I  posted about this a while ago.


    On two of my Macs, every few months (often after travel, where I've had to eject/mount my external drive several times), the external drive starts to spontaneously eject.  First sporadically and then more frequently, until it's happening every few seconds.


    If I run all the items in the "Automation" panel in the free maintenance software, OnyX  ( the problem goes away for anywhere from 2 weeks to 6 months.  (Usually one spontaneous eject occurs on the first boot up after running OnyX. Then things fine for a long time.)


    Once, when I had more severe problems (freezes as well as disconnects), I had to run Diskwarrior on both the laptop and external drive.  However, most of the time Onyx alone fixes things.


    It won't solve everyone's problem, but it's worth a try.   Clearly on my computers, there is a software component to this issue.

  • Macbrush Level 1 (15 points)

    Its either USB power problem, or cable problem. I have had bad cables that came with LaCie drives which look perfectly good, also bad built-in cables. Cables that works in other OS doesn't necessary works in OS X.

  • iclick4u Level 1 (0 points)

    OK I just picked up my 1st MACBOOK and I have several external HDDs from several different mfgs.  When they are connected to any of the USB Ports they self eject while attempting to clone my OS X drive.  Doesn't seem to be a drive size issue as I have tried small drives as well as large ones.  Some have their own power supply and others do not.  I have tried every suggestion on multiple forums and nothing works.  This seems to be an issue with the way the OS powers down the USB port while a drive is connected.  I do not have any other USB devices connected at all and it will happen within about 5 minutes with any of the drives on any port as well as with any of several cables that I have.  Yet I can take any of the drives and connect them to a Windows PC and they will all format and function normally. 


    This issue is related to OS X and the way it controls the USB drives.  I have a friend that has an older Macbook and any of the drives work flawlessly on his machine.  I used his machine and cloned my drive perfectly.  But I can't use any external HDD with this so it is time for Apple to fix this problem since it has been an ongoing issue for years.


    I have been an IT professional since the beginning of PC's and the way I see this issue is that Apple has turned their backs to their customers for not fixing this ongoing problem.  Nearly 200,000 people have viewed this thread alone and there are other forums and threads on the web for this same issue.

  • tingotanca Level 1 (0 points)

    Excellent and timely synthesis of it all, thanks. So now let's all of us 663 posters + 200,000 viewers or so travel to that parallel reality where Apple recalls all the models and/or updates all the OS's where USB (and Firewire, remember) isn't implemented properly. Or let's help each other find the workarounds - seems to me like the only alternative in this reality.

  • OregonRob2 Level 1 (0 points)

    @iclick4u: Yes, exactly. Thank you.


    I originally posted to this thread (as OregonRob) over a year ago after having problems with multiple external portable USB drives from Western Digital on multiple MacBooks and MacBook Pros and having lost untold hours of work. For two decades I have generally been happy with Macs and more recently have found Time Machine to be a long overdue solution to the basic necessity to do frequent, complete and incremental backups. But Time Machine works only if there is a convenient way to always have an external hard drive connected—for example, an external portable USB drive.


    So no reliable workarounds are known? I have seen lots of ideas on this thread, but none appear to be definitive.


    So who at Apple do we need to contact to get a constructive response?

  • Washington Irving Level 1 (0 points)

    @iclick4u: Yep.  I have come to the same conclusion.  It's also bigger than USB - I and many others have the same issue with Thunderbolt, and others again have it with Firewire.  It doesn't seem to be the cables or the external devices, or the particular ports, which points right back to the latest Apple OS and/oor hardware.

  • Ellen74 Level 1 (0 points)

    This is an update to my Jan. 4th post.  


    This time, when the ejects started, I delayed a week or two (until they became continuous) before running OnyX.  The delay was a mistake.  OnyX ended the continuous ejects, but I had problems with less frequent ejects and Time Machine.  I tried to run Diskwarrior on the external drive and got error messages;  luckily "Repair Disk" in Disk Utility finally ran (after a few glitches) and fixed something.


    For the moment, all is perfect.  No ejects, and Time Machine is running smoothly.


    My new work around:  From now on I'm going to run OnyX (automation panel) on my laptops and also "repair" the external drive once per month, particularly if I've had to disconnect the external drive a few times, which seems to be the trigger.


    (By the way, I'm running Snow Leopard on a 2008 MacBook and 2010 MacBook Air. Happens on both.)


    I'm so lucky I've found a software fix, but no one should have to go through this!  If there isn't some other way to alert Apple to this thread, should those of us still under AppleCare call and mention it?  If several of us specifically mentioned this thread, do you think they'd take a look?


    Also, does anyone else think that disconnecting the external drive a few times  (properly ejecting it) triggers the problem soon after?  I'm good for months until I disconnect everything for travel.  Then a week or so later, the problem reappears.

  • tingotanca Level 1 (0 points)

    Not the latest, dear – this has been going on for years!

  • tingotanca Level 1 (0 points)

    Three MBPs here, 2007, 2010 and 2011. It's only been seen to happen on the 2011 one (with Snow Leopard). I use Onyx more or less regularly regularly, but I can't tell whether it would change anything or not, given that I've found my own hardware (cable) fix and I don't have this kind of hassle anymore, as posted here way back when. As for the Apple Care, I hope it's easier for others: with no Apple store anywhere around, for me it means doing without my computer for at least a week while it's being sent back and forth.

  • dede2012 Level 1 (0 points)

    Ok, I haven't had the time to read every post here, so bear with me if it was already written, but here's what I found out.

    I had a dock station and bought a brand new Seagate 2TB 64mb cache 6gb/s SATA III.

    Put it in the dock station and formatted, started using it and soon enough I was having this eject problem, off and on continously to the point that it became impossible to work.


    That was on Lion 10.7.5, I tried to connect to a 10.6.8 Imac, same problem.


    To make a long story short, the problem is with the USB controller of the dock/external case you are using. Double check that your controller supports the hard drive you are trying to use.


    My dock was claimed as a Sata I, II compatible and I have fitted a Sata III drive. As soon as I tried to put a Sata II 2TB drive, the problem disappeared completely and never came back.


    So either use a Sata II drive or buy a USB case/dock station that is tested to be compatible with Sata III drives.


    Edit: some Sata III drives have also a jumper setting allowing drive to work as a Sata II (3gb/s max). I haven't tested it, but maybe that works too.


    Hope it helps.

  • iclick4u Level 1 (0 points)

    As I indicated in my post, I have tried several different drives and carriers.  It happens with any of them.  Makes no difference if they ar 2.0 or 3.0 and changing cables makes no difference.  This is an OS issue where it apparently powers down all of the USB ports at random when you try to send a large file or try to backup your internal drive etc.  I took my internal over to an older system and used it to clone and it worked with 3 different drives all of which that were ejected on the OS X machine. 


    There are over 600 posts here from users with this exact problem and if you search the web you will find several other forums as well.


    This is an issue that Apple is shurly aware of but has chosen to just leave their clients out to dry.

    This was the 1st and last Apple product I will ever buy.

  • billmobile Level 1 (0 points)

    dede2012 wrote:



    To make a long story short, the problem is with the USB controller of the dock/external case you are using. Double check that your controller supports the hard drive you are trying to use.




    Very much not true.

    I (as well as MANY other people posting in this and other forums) are not using any sort of dock or external controller. I have a direct connection to the USB port of my Macbook Pro. No other USB devices hooked up, and this HDD has been working perfectly, with no problem whatsoever, until the latest OS update.


    The problem is the new OS update. It is the only variable that a large, large majority of people experiencing this problem share.

    Ive tried updating the drives firmware.

    I tried using an externally-powered USB hub when the claim was that some HDDs were pulling too much power.

    I tried a non-external powered hub.

    I tried varying the port the HDD was plugged in to.

    I tried fixing permissions.

    I tried different cable.

    Ive never removed a HDD or thumb drive without ejecting it.


    I can no longer sync to iTunes, I can no longer use iTunes (my library is stored on the external HDD, it always has, it has NEVER created a problem before now, not on Panther, not on Tiger, not on Leopard, not on Snow Leopard, and not on Lion... until this update to 10.7.5 and the concurrant iTunes update), I can minimally use things on the drive itself. Minimally, because in the middle of performing some tasks, I get the "improperly ejected" message. The drive never ejects, it just becomes unusable. As it is, when I first click on the drive name, it is a solid 60+ seconds of the beachball as I wait for it to display the drive contents.


    Luckily, not all of my work files were on this drive (cant back up either!), but this IS costing me time and money. No work around (other than individuals tossing around ideas, which is great, but ultimatley ineffective).


    We need an actual response from Apple on this. Ive been a long time advocate of Apple, and preached that you are getting better quality with the higher sticker price... but Im starting to question my own sentiment. I really expected more from Apple.

  • tingotanca Level 1 (0 points)

    @billmobile: you are correct in your first sentence (not limited to external dock/case), but not in the second one – it's been going on for several versions of OSX, not just the new OS update. I, for one, am still using 10.6.8, and I'd still get it if it weren't for my "shorter cable fix". Which, sadly, doesn't seem to work in your case.

  • Mark Steven Yong Level 1 (25 points)

    @billmobile: my issues are with an external USB 3 WD My passport 750GB disk. It is only a fairly recent issue. I have another WD but only 500GB and that has no problems. My problem is that my iPhoto library is on the blessed thing.


    Additionally, (and this is really strange) before it disconnects itself, if I start up iPhoto, there's a pop-up box that tells me it can't read the disk or some other program is using it (or something like that). The Finder can read it easily enough. I have tried to Disk Warrior it thinking it may be the directory (the number of times it has improperly ejected itself) but right towards the end of rebuilding the directory, I get a message that there is insufficient memory error 2154. I run Disk Warrior off a disk so that shouldn't be an issue. Tried it on a MBA, a MBP and an iMac - same, same. Can anybody read anything into these pop-up messages that may lead to what the problem and possibly the solution may be?


    This is also a Windows issue from my Googling the matter, but they seem to have an easier time sorting it out. Apple really should pull their finger out on this and provide a response and solution as this is a wide-spread problem.

Previous 1 43 44 45 46 47 Next