Previous 1 44 45 46 47 48 Next 953 Replies Latest reply: Mar 31, 2016 8:28 AM by Barbara Smits Go to original post
  • Ellen74 Level 1 Level 1

    Last time around, I got the exact same memory error message from Disk Warrior, repeatedly.  [Had never, ever gotten that message  before -- I wondered if it was because the drive itself had started to fill up from time machine back ups....]


    I ran Onyx on both of my Macs (2010 MacBook Air and 2008 MacBook, Snow Leopard on both) and moved the external drive back and forth between them.  Finally, it stayed mounted on the 2008 MacBook just long enough for me to run Disk Repair in Disk Utility.  I ran it twice; it seemed to make repairs each time.  The drive has been fine since.


    I would keep running repairs on your Macs and keep trying to mount the external drive.  If on one of them you can keep it mounted just long enough to run Disk Repair, you may be back in business.

  • William Boyd, Jr. Level 6 Level 6

    billmobile wrote:


    I tried a non-external powered hub.

    What is that?

  • billmobile Level 1 Level 1

    It's a hub that draws its power from the USB port as opposed to an external source (wall plug or whatever).

  • tingotanca Level 1 Level 1

    I couldn't find that error code 2154 in any of the Mac errors listings I had:




    but then I think I remember that Apple had decided no that long ago to make their newer error codes listings inaccessible to common mortals (which seems confirmed by the relevant pages on their site).


    The only thing I found that might be relevant, if you're using  Disk Warrior is this one:



    Or possibly, if you have BootCamp, Parallels or such Windows installed and they're trying to access your self-ejecting drives:


  • userremoved Level 1 Level 1

    If anyone is interested, I used to have the "ejecting hard drive" issue on my MacBook Pro about 2 years ago - the issue, thankfully, hasn't happened since then. If it helps anyone, my equipment setup is as follows:


    2012 MacBook Pro 15" (was a 2011 MacBook Pro 13" originally)

    OS X 10.8.2 Mountain Lion (was OS X Snow Leopard originally)

    1 Satechi 12-Port powered USB Hub, Item model number: ST-UH12P

    1 WD My Book Essential 3TB USB 3.0 external hard drive, model number: WCAWZ2991990

    1 WD My Book Essentials 2TB USB 3.0 external hard drive, model number: WMAZA9008840

    1 Vantech Nexstar Firewire 800, USB 2.0, eSata hard drive dock, model number: NST-D100FBSU

    1 Seagate Barracuda 7200.12 1TB internal hard drive, model number: ST31000528AS.

    The Seagate internal drive is connected to the Vantech hard drive dock.

    The Vantech and the 2 WD external drives are connected via USB into the 12-Port Satechi powered hub.


    Like I said, I haven't had the "ejecting hard drive" issue for about 2 years now - I thought that the above information, about my setup, might be helpful.



  • userremoved Level 1 Level 1

    I forgot to mention that both WD external drives, as well as the Vantech drive dock, are powered and that the Satechi USB hub is USB 2.0.



  • Mark Steven Yong Level 1 Level 1

    Thanks Ellen74. I'll give that a go once I'm no longer quarantined with flu by my family :)

  • Mark Steven Yong Level 1 Level 1

    Hi tingotanca. Thank you for replying. The error code is com Disk Warrior.

  • Mark Steven Yong Level 1 Level 1

    Thanks for replying Michael. Anything you did differently at the time the self-eject stopped?

  • William Boyd, Jr. Level 6 Level 6

    Thanks dog the explanation.  I was trying to interpret "non-external powered hub" as "internal powered hub", but couldn't make any sense of that.


    Another way to describe that is "bus-powered hub".

  • MrElvey Level 1 Level 1

    billmobile wrote:


    dede2012 wrote:



    To make a long story short, the problem is with the USB controller of the dock/external case you are using. Double check that your controller supports the hard drive you are trying to use.




    Very much not true.

    I (as well as MANY other people posting in this and other forums) are not using any sort of dock or external controller. I have a direct connection to the USB port of my Macbook Pro. No other USB devices hooked up, and this HDD has been working perfectly, with no problem whatsoever, until the latest OS update.


    The problem is the new OS update. It is the only variable that a large, large majority of people experiencing this problem share.

    Ive tried updating the drives firmware.

    I tried using an externally-powered USB hub when the claim was that some HDDs were pulling too much power.

    I tried a non-external powered hub.

    I tried varying the port the HDD was plugged in to.

    I tried fixing permissions.

    I tried different cable.

    Ive never removed a HDD or thumb drive without ejecting it.


    ...As it is, when I first click on the drive name, it is a solid 60+ seconds of the beachball as I wait for it to display the drive contents.



    We need an actual response from Apple on this. Ive been a long time advocate of Apple, and preached that you are getting better quality with the higher sticker price... but Im starting to question my own sentiment. I really expected more from Apple.

    When I was trying to diagnose the disk drive ejecting itself problem I was having, Apple went so far as to REPLACE MY MOTHERBOARD in an effort to solve the problem.  So wouldn't call them unresponsive.


    You are very wrong to say that what dede2012 said is very much untrue.


    There are lots of folks who are getting this error simply because the actual hard drive inside the enclosure is dying.  If your HD takes 60 seconds to appear, you should be considering this possibility and acting accordingly.


    There are lots of folks who are getting this error simply because of a bad cable or bad hub - some of them have posted so to this thread.


    Just because many many folks re having disk drive ejecting itself problems doesn't mean they're all caused by the same thing, or all Apple's fault.  In my case, the problem, once diagnosed, clearly was primarily the fault of the hard drive enclosure manufacturer.  As was the case with dede-although the problem with the enclosures were different. And at least one other poster, IIRC, traced the problem to the enclosure.


    When you say you "have a direct connection to the USB port of my Macbook Pro" you may be mistaken, as you may not be considering what's inside the enclosure.  It's almost certainly a SATA drive, with a USB controller translating USB commands and data into SATA commands and data and vice versa, and there's a whole constelllation of enclosure manufacturers who didn't follow the USB controller manufacturer's instructions and created defective enclosures.


    If your hypothesis is that the vast majority of these problems are traceable to a particular OS version, that's a testable hypothesis.  It's easy to install an older OS or older version of an OS on a small partition, and a clean copy of the current OS on another, and do some testing to confirm or refute the hypothesis.

  • billmobile Level 1 Level 1

    I didn't think it was necessary to split hairs in regards to the "direct connection" comment, which I think everyone else understood to mean "connected to the USB port, not through a hub."

    Anything not soldered directly to the motherboard would not be "directly attached," but I suspect you understood what I meant.


    As for previous OS versions, I do not experience this issue on my MacMini or older MacBook (not Pro) running previous versions of the OS.


    I didn't mean my above post to offend anyone, but stand behind my feeling that dede2012's solution may have worked for him/her, but isn't THE solution (as there very well be multiple issues at play). Sorry for any misunderstandings.

  • agyu Level 1 Level 1



    I had the same problem with my Western Digital WD10000H1CS Black 1 TB which kept ejecting as I used for Time Machine backup. Since I changed the Sharing & Permissions to "Read & Write", it started behaving normally.

    I hope this could help to solve your problem.



  • Mad-Fragger Level 1 Level 1

    I found a solution that worked for me.


    I encountered this issue on an older Mac Book Pro after upgrading to Snow Lepord.  And also on a new Mac Mini running Mountain Lion using the same exact drive (an external USB 3.0 Western Digital My Passport drive).  Here are some of the behavior I've noted over the last 6 months:


    • The drive would auto-eject itself after a period of use while plugged into a USB port on my MacBook Pro.
    • The drive would not ever be recognized when plugged into the USB 3.0 port on my Mac Mini.
    • When plugging the drive into a powered USB 2.0 hub, it would operate normally, without any problems, on both the Mac Book Pro and Mac Mini.  Of course, it would operate much slower because of connecting via USB 2.0.


    I was using the powered hub as a work around, when the slow speed became intollerable because I was transfer many large video files. 


    MY SOLUTION: After upgrading the firmware on the hard drive and rebooting, the drive has been working very well.  I even enabled on the power save setting titled "Put hard disks to sleep when possible".  After putting the computer to sleep, waiting 10 seconds, and waking it up, the drive is still connected to the Mac. 


    I don't know if this solution will work for everyone, but I hope it helps some of you.  If you're running a Western Digital drive, you can download the firmware updater here.


    Good luck!!

  • MrElvey Level 1 Level 1



    Kudos for sharing another solution that is sure to work for some folks.




    You accuse me of hair splitting.  I'm amused.  I think the distinction between specifically saying there is a direct, controller-free connection, when really there's a connection with a controller in-between is pretty obviously significant, not hair-splitting, when the issue is sometimes caused by known common problems with such controllers, as is the case here.  But feel free to define your own reality, dude.  Sure, a view in which the lack of a USB hub makes it a direct connection is a useful simplified view in many cases.  It didn't occur to me that that's what you meant by direct.


    I think that assuming you know what the problem is and demanding Apple fix it instead of testing your hypothesis is stubborn and obstinate.  But feel free to define, or redefine, your own reality.


    Your hypothesis is that the vast majority of these problems are traceable to a particular OS version, that's a testable hypothesis.  It's easy to install an older OS or older version of an OS on a small partition, and a clean copy of the current OS on another, and do some testing to confirm or refute the hypothesis.  Assuming that the OS is to blame just because two other machines with different OSes don't have the problem is a huge assumption you seem unwilling to test.  If there's enough evidence in the 46 pages of this thread to make it clear that a bug in specfic versions of the OS produce this problem, I missed it; I may well not have read every post.

Previous 1 44 45 46 47 48 Next