Previous 1 45 46 47 48 49 Next 951 Replies Latest reply: Jan 19, 2016 6:47 AM by jhp03c Go to original post
  • billmobile Level 1 (0 points)

    I think you may be taking this all a bit too personal...

  • U.B. Level 1 (0 points)

    Hi Guys,

    I come here for time to time to see if anyone by some miracle have found a solution to this problem. As I see it right now, I do not see the help on horizon. You are all heading in the wrong direction. The USB is not the only connection that causes eject to happen. I do not expect you to read all the 47pg. on this topic, but let me remind you that people have the same issue on fire wire connection, too. No matter what I use, USB cable with hub, no hub, FW hub, no hub, different cables… - one one of my newer HD's is ejecting itself. One day it mounts itself on and few days later is gone, and repeats like this for the last 2 years while going to all the OS upgrades. Data is there intact, I can manually turn it on, but again few days later ejects. I also have one G-Tech HD 500GB and a LaCie 2TB they are both working properly, except that one of the G-Tech 1TB is ejecting.


    - USB is not the reason since the same happens with FW.

    - Hub is not a problem - the same thing happens with hub or without.

    - Cables are not the reason since I tried different ones especially using the ones that I know that are working on my other HD's.

    - Software drive of the HD is not the problem, since I have 2 HD of the same brand (one ejects the other one does not).

    - Running disk utilities does not solve the problem either (Yes, I have used and run all kinds of disk utilities from OnyX to DiskWarrior to TechTool Pro - no differance)


    2 Possibilities:

    - newer HD's added something in their hardware that causes this.


    - There is a conflict with Apple's OS.

  • tingotanca Level 1 (0 points)

    Excellent synthesis. I wish others could give you those Like things, or whatever, so that your post comes out as the first one people read when accessing this thread. 't would save lots of time for all new visitors.


    Now, just one question, only because that's what has worked for me (but I'm aware that it's only a workaround): when trying different cables (Firewire, I assume), have you tried different lengths?

  • U.B. Level 1 (0 points)

    Thanks tingotanca for a Like. We are here to help each other and to untangle these cables and thoughts.


    You are asking a good question. Well, I did so many different combinations that I'm not so sure if those cables were all the same length, who can remember. But I do know that one FW cable that is woking well on one of my HDs, that the same cable is not working with this other HD. That should eliminate the length theory and it should not be about the cables.


    I did suggest that the problem is either the newer element that they put in HD's hardware or OS. However, now I'm thinking loud realising that it should not be just OS for the same reason as cable. Why the OS would allow two of my HD not to eject but the third HD to ejects. So, I believe that the problem is with newer HD's and that OS does not know how to handle it.

  • Will Nielsen Level 1 (0 points)

    It is really quite unbeliveable that this OS Error has not been resolved by Apple in FIVE YEARS (Sep 9, 2009 until today). That's three renditions of the Mac OS. Beautiful design needs to be inside and out or its polished junk.


    I'm losing Time Machine backups because of this. It's potentially not simply an inconvenience.

  • the1nigel Level 1 (0 points)



    I just installed OSX 10.8.2 because I wanted to run two back-up discs with Time Machine (one at work, one at home). Now I'm finding my USB-powered back-up disc is spontaneously ejecting, disrupting the back-up and leaving me with the message...


    "The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off."


    I know there has been a lot of response to this issue, but can someone tell me if there is a simple answer to resolve this problem?



  • Will Nielsen Level 1 (0 points)

    Given that Apple has't resolved this recurring problem in FIVE YEARS @the1nigel,I wouln't get your hopes up.

  • the1nigel Level 1 (0 points)

    OK Will,


    So is it related specifically to Time Machine, because the drive works fine when I drag and drop files to and from it?

  • SUCKA FREE Level 1 (0 points)

    I was having this problem on my mac mini with an 512Gb OCZ SSD installed as a second HD and the problem was 2 things that were the cause that OCZ sent to me was 1. Firmware update 2. was thermomitor update.  Now everything works perfect !!!

  • Will Nielsen Level 1 (0 points)

    My drive works fine when used as a HDD, non-timemachine drive. It's a 1 TB Seagate external drive that I've used on at least three versions of MacOS.

  • jarown Level 1 (0 points)

    Hi all,


    The spreadsheet with "Self ejecting external harddrives on OSX" was emptied by someone/something, but I've restored it to the last correct version again.


    Feel free to add your failing drive: hU2c&hl=nl&authkey=CKPC_okO



  • hschneider Level 1 (0 points)

    I had the same issue with a 2 TB Western Digital Passport drive on and iMac 2012 running Mac OSX 10.8.3.


    The drive never survived sleep mode. I did change the cable, reformatted the drive, updated firmware, installed and uninstalled the WD turbo driver etc. No way ...




    I formatted the drive with

    HFS+ Journaled FS (case insensitive) ENCRYPTED


    I tested several times sleep & wakeup and the drive was still there !


    Can anyone test and confirm this as a 100% working solution ?




    -- Harald

  • Komidua Level 1 (0 points)

    I had this problem of ML, Lion and Snow Leopard randomly ejecting my WD 1TB USB hard drive.  After days of troubleshooting, I connected my drive to a Windows 7 PC and did a disk check (scandisk).  Windows did its thing and all is good on ML again.  Just a possible solution if your drive is in FAT/MS-DOS format.

  • zedzedmoon Level 1 (0 points)

    Just to add another voice here for this issue.


    MBP2012 (late) using a 4-port powered USB hub with 3 external drives connected to it (1.5Tb HD - self built cage, 1Tb HD - iOmega, and a 320G SSD - self built), the 4th port is used for a number of different things (cameras, USB controller keyboard etc). The second internal USB port has a USB audio interface plugged in to it. All of the drives have external power.


    Any combination of ports produces this issue, however the best combination is to have all the drives plugged into the hub, but only use 2 at any one time. My small drive is a system backup for time machine, and exhibits the worst disconnecting behaviour, the other two follow but not as frequently. OSX will not even pick up the drives if I have them plugged into both the hub and the internal port, i.e. 2 in the hub and other in spare port. I can only use the drives with them all connected to the hub.


    My first thought is that I am using a USB2 hub, so considering getting a USB3 one. Secondly, one of the cages is USB3 capable (the 1.5Tb one).


    Apart from restricting how many drives I have powered up at any one time I have found no other solution, different hubs (I've tried 5) produce exactly the same behaviour. I am going to try the KEXT hack next.

  • par333 Level 1 (0 points)

    I just bought my first MBP, having used PC for the last 12 years.


    Right away, my 2 TB Seagate starts to self-eject, randomy.


    I cannot recall self eject ever happening on the Windows platform.


    Is Apple going to fix this?

Previous 1 45 46 47 48 49 Next