Skip navigation

Disk Drive ejecting itself

292611 Views 907 Replies Latest reply: Mar 27, 2014 7:57 AM by Pauleduc RSS
  • nobullguy Calculating status...
    Currently Being Moderated
    Jul 29, 2013 12:05 PM (in response to GeneSchmidt)

    Today I was working with Lacie 1TB drives on a brand new MBA 13".

    It kept ejecting this disk that has been perfectly working for half a year 4 times in a row.

    How can they say there is nothing wrong with these Macs?

    I don't get it and I don't understand this policy of ignoring all the people in this forum.

    Let's hope...

    bolz

  • GeneSchmidt Calculating status...
    Currently Being Moderated
    Aug 1, 2013 6:19 AM (in response to nobullguy)

    I took my MacBook Pro Retina to a local authorized service center.  They replaced the logic board.  Pluged in the hard drive and in 30 min it ejected.

  • rlhagemann Calculating status...
    Currently Being Moderated
    Aug 7, 2013 12:20 PM (in response to judithnewman)

    Add me to the list.  I've had no issues since getting my Seagate 2TB drive.  I have however had issues with a SD card ejecting in the middle of transfer.  I was transfering from a card reader and not the camera as it tends to be faster.   When it ejected by itself it also removed every file except about 6 off the card.  Luckily it wasn't an important shoot so I didn't fall over with a heart attack.  I recently got a Nikon D800 and this card is brand new.  I had one previous shoot with this card that had been reformated (in camera) after the shoot.  I think what happened was when the computer screen when to sleep mode it ejected the card.  I'm not sure as I was in another room when it happened.  Luckly for $40 I was able to download some software and recover the images.  They have some weird missing pixels and I'm not sure if that is from post processing (most likely) or due to them being recovered.   Anyway I hope they come out with a cure soon as I have some important shoots coming up and I'll be nervous as heck with this looming over me.  I've been a MAC user since 2008 and have never had any issues before. 

  • par333 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 7, 2013 12:29 PM (in response to rlhagemann)

    Based on the time interval of this problem, I doubt if any fix is forthcoming.

     

    I got tired of having my MBP act like an ejectaholic and bought a thunderbolt dock. 

     

    Problem was fixed with the dock.  I now use the USB ports for my external keyboard and mouse.

  • billmobile Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 8, 2013 3:32 PM (in response to judithnewman)

    I'm anxious to see how the people who have bought drives and are "having no problems" will fare long term. My drive worked perfectly for more than six months before it started ejecting.

     

    The same goes with docks, powered hubs, non-powered hubs, drive firmware updates.. I've tried them, and it will often work for a short time before starting the ejecting over again. So good luck to you guys, but don't hold your breath.

     

    Since Apple seems to refuse to admit that it is Apple hardware at fault, and seems to want to push blame to the external drives, does anyone know of any external drives that Apple endorses? I will buy one from the Apple store and start exchanging it on a weekly basis if so. As long as I have the ability to say that THEY told me to buy this one to avoid the problem, so I can demand that they exchange it (over and over again) or fix the problem for all of us who are suffering.

     

    Just a thought...

  • par333 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 8, 2013 4:11 PM (in response to billmobile)

    I do not recall reading any problems with thunderbird interface of external hard drives.  This is the reason I went with a tbird dock.

     

    Perhaps I will be proven wrong ... time will tell.

  • riker82 Calculating status...
    Currently Being Moderated
    Aug 8, 2013 11:22 PM (in response to par333)

    This is my history:

     

    Macmini mid 2010 and MacBook Pro 15 late 2010... Both of them use to eject my USB 3.0 hard drive (a stupid WD My Book Live 3TB).... Now they have stopped to doing that... What is changed?

     

    Both of them have SSD disks as boot drive. One month ago, the drive into the MacMini stopped working and I replaced it with its original drive.

    Starting from that moment, the WD stops ejecting. Now my question is: can the ssd drive be the cause of this issue? Do you also have SSD boot disk as me?

     

     

    Since a colleague of mine has a similar issue with video graphic module that Mountain Lion use to load "too fast" due to SSD speediness (this is what apple care guy told him), I'm start to thinking that apple some problem with this kind of technology!  In fact, every time he boot it, he's also to log off and logon in Mountain Lion in order to allow to the OS to load correctly the driver....

     

     

    Really strange....

  • hschneider Calculating status...
    Currently Being Moderated
    Aug 9, 2013 2:44 AM (in response to riker82)

    Yes, I have a SSD in my iMac, which had the same problem with WD drives.

  • Pauleduc Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 9, 2013 5:55 AM (in response to judithnewman)

    For a long time now, I have been plagued by this problem.. Generally when I attached one if those Western Digital 1 TB portable HDs to my iMac.  The drives I have are the latest USB 3.0 drives.

     

    Yesterday, when I was backing up my ASUS G53SW notebook PC to one of these WD 1 TB drives, it kept ejecting during the copy process.. Very annoying as I had to constantly restart.

     

    Soooo, this ejecting problem does not seem to be limited to Mac systems!

  • GeneSchmidt Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 15, 2013 11:56 AM (in response to judithnewman)

    I've sent back my third WD Mybook Thunderbolt Duo 4T drive because of this issue.  Apple level 2 support had me run a logger of some kind and stop it when the drive ejected itself.  I did that and sent the file to Apple support.  They said the problem was with the RAID software in the drive.  No solution is available.  I ordered a LaCie 4T Thunderbolt drive and have not had a problem in the last week.

     

    Gene

  • Apollo Reyes1 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 28, 2013 11:49 AM (in response to judithnewman)

    I have an iMac 27 -  bought about a week ago. I have 3 pieces of Seagate 3TB USB3 and one WD 1TB USB2 - all together 4 external HDs . . . and yes I have the same recurring random ejects - mostly on the 2 newer Seagate 3TB USB3 . . . I came across this file from Seagate for a firmware update : Backup Plus firmware update tool for Mac OS: http://www.seagate.com/support/downloads/item/backup-plus-mac-firmware-updater- master-dl/

     

    -Has anyone tried this yet ?  I will when I get home later . . . but if anyone has success off of this update, please do tell

     

    Cheers,

    Apollo

  • Apollo Reyes1 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 29, 2013 11:56 AM (in response to Apollo Reyes1)

    still having the same problems after updating firmware . . .

  • K3mike Calculating status...
    Currently Being Moderated
    Sep 2, 2013 9:27 PM (in response to par333)

    Right now, I'm using Carbon Copy Cloner to clone the HDD that came with my Late 2011 MBP, (running OS X 10.8.4) onto a new Crucial M500 960GB SSD.  I've got the SSD docked in a brand new Seagate Thunderbolt Adapter, connected with an Apple Tbolt cable to my MBP.  All the connections are solid.

     

    The SSD has self-ejected no less than 10 times so far.  I have turned off WiFi and disabled any program that runs at startup, thinking that something was changing the information on the drive.  As I type, it just happened again...

     

    Each time it happens, messages pop up saying "CCC aborted the task because the destination volume disappeared.  Please reconnect the volume and try the task again".  AND "The disk was not ejected properly.  If possible, always eject a disk before unplugging it or turning it off."  AND "The backup task was aborted because the destination volume's mountpoint changed.  Try the task again.  Avoid making any changes to the source and destination volumes during the backup task."  (It just happened again.)

     

    Fortunately, each time I have to restart the task, the cloning software moves very quickly through the data it has already transfered.  That gives me hope that sometime tonight I'll be finished with this project...

     

    Bottom line - It happens with Thunderbolt equipment as well.

  • par333 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 2, 2013 10:02 PM (in response to K3mike)

    Not true ...

     

    bottom line -  it happens with SSD (until proved otherwise)

1 ... 50 51 52 53 54 ... 61 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (23)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.