Previous 1 52 53 54 55 56 Next 953 Replies Latest reply: Mar 31, 2016 8:28 AM by Barbara Smits Go to original post
  • Chewbeedoo Level 1 Level 1



    Here I have the issue

    MacAIr 11" mid 2012, thunderbolt screen (the first one)

    LG USB drive


    When the drive is connected to the screen it self ejects

    Whe the drive is connected to the mac (which is still connected to the screen) it never self ejects


    I wonder where is the problem


    VERY annoying bug BTW

  • Allan Eckert Level 9 Level 9

    You really should start your own thread rather then  posting it on page 54 of thread so that it gets the attention it deserves.



  • brian273 Level 1 Level 1

    New OS X 10.8.5 says it solves issue of ejecting external disks. Curiously it's described as a problem that occurs when the machine goes to sleep? Hmmm, could Apple have (yet again) ignored all the posts here?

  • MrElvey Level 1 Level 1

    Yeah, I just noticed that:


    • "Fixes an issue that may cause external drives to be ejected after the computer goes to sleep"


    from  OS X Mountain Lion 10.8.5 Supplemental Update, as can be seen and downloaded using Software Update or at:



    for me the problem does most often occur when the machine goes to sleep, so I'm hopeful the fraction of problems this fixes will be significant, and include mine.

  • U.B. Level 1 Level 1

    I have just bought a Fantom G-Force Quad HD 4TB and connected it to my 10.8.5 MacBook Pro via firewire in hope of being different then other HDs that eject themselves. Nice quality, quiet drive.

    Copied 600 GB to it, all in once. No problems. Three days later the famous ejecting message appeared. Then… something new happened. Few moments later the drive reappeared and mounted itself. Now it sits on my desktop for the last 24h. That was before this new update.


    My last hope of getting rid of this message appearing again is to do this new supplemental upgrade. After this, I'm giving up on trying.

    Either Apple resolves this problem or their reputation is demaged in my book.

    Thanks for sharing!

  • Allan Eckert Level 9 Level 9

    brian273 wrote:


    New OS X 10.8.5 says it solves issue of ejecting external disks. Curiously it's described as a problem that occurs when the machine goes to sleep? Hmmm, could Apple have (yet again) ignored all the posts here?

    Apple says they don't read these forums for problem so it seems quite likely.



  • par333 Level 1 Level 1

    They may not read the posts here but they sure as **** are listening to consumer complaints filed at their stores.

  • chrisCTMini Level 1 Level 1

    FWIW, I am having the same issue. I connected an external HD that had been connected to a windows machine without issue and it started to disconnect as soon as I connected it to the mac. I tried changing cables, but that didn't work. One powered USB port did work, however the copy time was going to be 3 days (250gb of files). Another Powered USB port produced the dreaded eject issue.


    So I pulled the drive out of its enclosure and connected it using a SATA to USB adapter. First time out, it wouldn't read, the second time it read but ejected.


    Finally, I tried something else. The disk has 2 partitions, one containing the files, the second containing a backup of my PS3. I ejected the partition containing the ps3 backup, leaving the one I need mounted. So far, 50gig of files copied with no ejecting.


    I haven't seen a whole lot of discussion on this thread around the format of the drives. In my case, both partitions are formatted with NTFS.


    I should also mention that when the drive was in the enclosure, NTFS-3g would show an error something to the effect of the drive didn't respond within 15 seconds and was going to be ejected. That problem disappeared when I pulled the drive out of the enclosure.


    So, multiple partitions formatted with NTFS perhaps an issue? I have 2 other drives connected to the same computer via a dock, both Mac formatted, and no issues at all.


    53 gig copied and counting...???

  • benc.academie Level 1 Level 1

    No problems so far since the update. Copied from an to the drive and it seems to be solved. About time I might add!

  • chrisCTMini Level 1 Level 1

    Ok, I was successful in copying 250gb of info off the partition I needed, took about 2 hours without ejecting. I then, just for the fun of it, ejected that partition and remounted both partitions (again for those unfamiliar with my situation, 1 partition is about 420gb, NTFS, the second about  80gb, formatted FAT32. Sure enough, after no more than 5 minutes, both partitions ejected by themselves.


    I then remounted both again, and immediately ejected the larger (NTFS) partition, leaving the smaller (FAT32) partition mounted. Sure enough, it ejected within 5 minutes.


    I've since remounted just the larger NTFS partition and am going to set it up for use with Time Machine, I'll report back what happens.


    Could be an isolated issue with my drive and this particluar partition, but it doesn't seem the update has universally solved the issue.

  • robcal3 Level 1 Level 1

    Per my earlier post, I suddenly started getting the dread improper disk ejection message on two new iMacs in our house which had both been happily tootling along with their Thunderbolt-connected external harddrives, one a LaCie and the other a Buffalo.


    With one iMac, before I hunkered down to apply some of the more complex suggested fixes,I decided to first try a couple of the less elegant "tire- kicking " solutions which I thought had little chance of succeeding.  Lo and behold! By using a USB 3 connector, instead of a Thunderbolt, the problem, to my surprise, disappeared.  When I tried the same thing on the second Mac, no such luck. 


    I had guessed that it was more than a coincidence that the self-ejection issue appeared on both of the Macs in my house immediately after downloading an OS fix several days ago.  So, when I noticed that the most recent OS update stated that it was intended to solve this problem, I immediated downloaded it.  Then, I reconnected the Thunderbolt cables from both Macs to each of their external harddrives-- and no more dread self-ejection messages!  Hope the OS update solved this problem for most or all of you guys.

  • chrisCTMini Level 1 Level 1

    To close the loop on my situation, when I tried to set up the larger partition to use for time machine, it told me it needed to reformat, which I said ok. Unfortunately for me, it also tried to format the smaller fat32 partition as well, erasing that! The only backup to my now dead ps3 was on that partition. Oh well.


    The drive is now partitioned as one drive and set up as part of a raid 0 array for temporary use for time machine until my new drive arrives and no ejection issues.


    In my case, it would appear the fat32 partition was the issue.


    Hope this helps others.

  • brian273 Level 1 Level 1

    Haven't had any issues so far with my 500 gig Freecom Toughdrive! Fingers crossed it lasts. But I still dread travelling to another country because for some reason I tend to have issues on returning. Some of the solutions suggested here have worked but only for a while. Or they work until I travel. I shall post an update after Denmark in a few weeks i.e. if I still haven't had any reccurence of the old problem before going away.

  • chrisCTMini Level 1 Level 1

    Yep, day 3 with the same hard drive (repartitioned and reformatted) connected (part of a RAID 0 array) and still no issues. 2TB drive arrives today (I hope).

  • Montag451 Level 1 Level 1

    benc.academie wrote:


    No problems so far since the update. Copied from an to the drive and it seems to be solved. About time I might add!

    Wish I could be as lucky. I installed the update and still see the drive unmount at some point during sleep. Been testing this for about three months with no solution that I can find. Posted my specifc issue here:

Previous 1 52 53 54 55 56 Next