1 53 54 55 56 57 Previous Next 925 Replies Latest reply: Jul 6, 2014 1:20 PM by willhowe Go to original post
  • 810. Re: Disk Drive ejecting itself
    Apollo Reyes1 Level 1 Level 1 (5 points)

    saw this entry in one of the Seagate's forum . . .

     

    http://forums.seagate.com/t5/Backup-Plus-and-Seagate-Slim/Backup-Plus-Not-Recogn ized-After-Mac-Restart/td-p/199025

     

     

    Re: Backup Plus Not Recognized After Mac Restart

     

     

    Apple provided the following solution:

     

    Under /System/Library/Extensions/ - delete the file "Seagate Storage Driver.kext"

     

     

    After  removing this Seagate storage extension from my Library, the iMac now  automatically mounts the Backup Plus drive after shutdown or restart.

     

     

    See  if it helps somehow . . . I've tried it and re-started my iMac . . .  noticed that my Seagate Drive icons have changed to generic ones . . .  but so far so good . . .

  • 811. Re: Disk Drive ejecting itself
    chrisCTMini Level 1 Level 1 (0 points)

    Well, back to sqaure one! My new Seagage 2TB External expansion drive is self ejecting now. I have no idea why, but its happened twice, both times while trying to back up with Time Machine. My computer is not set to go to sleep at all, and I have the latest OS installed. This really *****!!

  • 812. Re: Disk Drive ejecting itself
    chrisCTMini Level 1 Level 1 (0 points)

    I contacted Seagate Tech support who immediately confirmed that they knew this was an issue with their drives, and confirmed that the issue was indeed that the drive firmware was programmed for the drive to "sleep" after 15 minutes. On the Windows side, there is a program you can download to change that, but no such program exists on the mac. Fortunately for me, I am running VMWare Fusion on my mac, so installed the windows version and changed the settings, hoping it would "carry over" when I plugged it back into the mac. Unfortunately, overnight, the drive ejected itself.

     

    They then (in a seperate email) pointed me  to the Seagate Diagnostic Tools for mac. When I got home from work, the drive was still mounted, but I tried the tools anyway, but it didn't recognize the drive.

     

    They then pointed me to a supplemental update for apple 10.8.5, here: http://support.apple.com/kb/DL1686

     

    I ran this and installed and will see what happens.

     

    I also found a small, cheap program called "Mountain" which indicates it too can help withthis problem, plus make mounting and dismounting drives easier. At $1.99, I figured it couldn't hurt so I downloaded it as well.

  • 813. Re: Disk Drive ejecting itself
    Montag451 Level 1 Level 1 (5 points)

    I wanted to note an odd development with other external drives. My wife's external iPhoto/iTunes drive attached to her air was ejecting iteslf, so I started testing it on my own Macbook Pro. I wasn't able to identify what the issue was, so we purchased a new external drive for her. I then started to notice that the old external drive began unmounting itself from my Macbook Pro. Then my Drobo started to exhibit the same behavior.

     

    In order to ensure nothing happens to the data on my Drobo, I've unplugged it entirely from my Macbook Pro.

     

    I've installed the supplemental update with no change. This is seriously worrying me, and I've done enough testing at this point that the only way I could think to fix it would be either a full format and reinstall of the computer or buying a different Mac. Here's my testing post, for reference: https://discussions.apple.com/message/23297333#23297333

  • 814. Re: Disk Drive ejecting itself
    Ivan Robertovich Level 1 Level 1 (30 points)

    Same here.  I tried my trick of deleting time machine preferences, and that didn't work this time.

     

    I booted the mac into safe mode (hold shift at chime) and it works fine for the moment (it is preparing a backup without ejecting drive).

     

    Who knows if this will work after restarting in normal mode.

     

    I'm looking now at some legacy hp kexts and wondering if they aren't the problem...  Or if there aren't some kext issues we all aren't experiencing.   My other imac does not have this issue so it has to be something in the hardware pulling of different drivers and extensions causing this.  (I think)

  • 815. Re: Disk Drive ejecting itself
    Ivan Robertovich Level 1 Level 1 (30 points)

    Yes.  I can confirm that a regular time machine back up ran fine while the mac was in safe boot.  Ugh.  Now what?  How do you figure this out?

  • 816. Re: Disk Drive ejecting itself
    Ivan Robertovich Level 1 Level 1 (30 points)

    Time machine works without ejecting the WD mybook external when the mac is in safe boot.

     

    Taking it back to normal boot causes it to eject.  There are no WD drivers installed, the only kexts are printer kexts, hp and canon.

     

    It has to be something loaded in normal boot that isn't loaded in safe boot, but it don't know how to eliminate the cause.

  • 817. Re: Disk Drive ejecting itself
    chrisCTMini Level 1 Level 1 (0 points)

    Well, it seems none of the solutions worked! I came home today after 3 days of flawless performance, only to discover the disc had once again ejected itself. Checking the console log confirmed this happened right as Time Machine was trying to do a small, incremental back-up. Reporting all sorts of messages about not conecting to the drive or something and that is disconnected. All right at the time that Time Machine tried to do its thing!

     

    Since plugged it back in and it ran the same back up no problems at all!

  • 818. Re: Disk Drive ejecting itself
    Ellen74 Level 1 Level 1 (0 points)

    I hope folks are at least trying a software maintenance/repair fix.  I know it hasn't worked for many, but it's been solving this problem for me repeatedly for over 2 years. (I have a GTech external drive.)

     

    When I get the spontaneous ejects, these days (somewhat different from my earlier posts) I do 2 things: on my computer, I run everything in the "Automation" panel of the free OnyX software (http://www.titanium.free.fr); then I run Disk Utility's repair on my external drive.  If there are a lot of issues with the external drive, I run it twice.  After that, I'm good for 4 to 6 months.  Problems tend to recur after I've traveled and repeatedly disconnected the external drive.

     

    [A tip:  If you can't get the external drive to mount at all, try another computer.  Once, when I let things progress too far (i.e., from sporadic ejects to ejects every second), I couldn't mount the drive on my MacBook Air long enough to run Disk Utility.  Luckily it stayed mounted slightly longer on an old 2008 MacBook, so I ran it there.  I think this points to a hardware issue as well, as both computers had identical software, identically maintained/repaired, but the older Mac was faintly more tolerant of whatever ailed the external drive.] 

     

    I have also tried hardware voodoo, blowing in the ends of the USB cable. Two times it seemed to help, but I won't vouch for it. : ).

  • 819. Re: Disk Drive ejecting itself
    U.B. Level 1 Level 1 (0 points)

    My brand new Fantom drive (with Supplemental Update installed) now ejects itself, too.

     

    If we read the whole 55pg. of this discussion, we can conclude and I suggest that we do not concentrate on any specific HD model, since the problem effects WD, Seagate, LaCie, Fantom, GTech, Time Machine…. Also, effects all connection types Firewire, USB, Thunderbolt… No sleeping app can resolve this problem either since in my case, my Fantom HD ejects itself without my Mac or HD going to sleep.

     

    Lets focus on a common problem because the individual solutions are not the root of this issue.

     

    2 possibilities are clear:

    1. Mac OS is the problem that effects only new HDs. (I have my older LaCie on the same Mac without any ejection. Also, a drive that is ejected on a Mac does not eject itself on a PC).

    2. New HDs are problems since those HD makers either added a new component or started formatting their drives without adapting the newer OS upgrades.

     

    Sorry, but without addressing these 2 options we will all waste our time focusing on the wrong things.

     

    We can start elimination proces by listing our Mac devices that we connect to these drives. Lets understand if the problem is present on the older or/newes Macs.

     

    My Mac is:

    MacBook Pro - Early 2009 - 2.93 GHz Intel Core 2 Duo

  • 820. Re: Disk Drive ejecting itself
    Basman Level 1 Level 1 (0 points)

    You are correct in part.  However, PC drive ejection IS a problem also.  As long as USB and Firewire drives continue to work so haphazardly, it is better to concentrate on the Wireless or ethernet network attached storage solutions.  This works well with third party NAS boxes, although trying this with an Airport and ist's USB drive is also pathetic.  The NAS solution is going mobile and more choices are available all the time. 

     

    Your listing idea seems reasonable at first glance and it has in fact been tried by at least one previous poster.  But I submit there are to many other variables in the mix to make this an effective method; i.e. what other devices are present, what software is installed, what OS patches are installed, and even what particular month the iMac (or whatever) was built. 

     

    Lastly, typical external HD drive assemblies involve several manufacturers.  The one who slaps their logo on it may not even be one of them.  The drive mechanism inside is just one manufacturer.  For example, LaCie does not actuyally make hard drive; they only assemble them into a box of their design.  If you open one up you will find someone else's name on the bare drive mechanism inside.  In the old days that was Maxtor.

     

    Even if you can open up your proprietsary enclosure (not always so easy) and identify the internal drive mechanism's manufacturer, you are still not out of the woods.  For example, a Seagate Barracuda 1 TB (current single platter design) may have a part number and version number that is exactly the same as another drive bought six months later, but despite that they can still be different; e.g. one may have a 32 MB cache and a later one a 64 Mb cache.  Sometimes you don't even know a dealer (e.g. Egghead) will send until it is in your hands!  The dealers are in the same boat, because they stock with whatever the whoesale distributors have in hand.  If Seagate decides to change the cache sizeon their HD controller boards (or whoever supplies those to them does) and there is no change in the part numberm, who is going to be able to tell ahead of time?

     

    The USB-SATA, Firewire-SATA, or Thuderbold-SATA bridge board that is integral to any external hard drive enclosure is another manufacturer involved with their production.  These too can vary even with the same brand of enclosure, depending exactly when it was made.  For example, Addonics, a Taiwanese manufacturer of HD controllers, enclosures, and interface adapters, has put out several verions of its Zebra box.  They all look the same from the outside, but they can differ in subtle ways on the inside.  One of several Zebras I have dismounts with regularity from my PC USB port, the others do not; all have the same version of Seagate Barracuda drives - go figure!  Even Addonics itself buys most of their chipsets from yet another manufacturer, notably Silicon Image, which you will find in the guts of many drive interfaces provided by many manufacturers.  Those chipsets also undergo periodic changes.

     

    Add to that the other uncontrolled variables of flaky cables and connectors.  I have had to solder USB ports onto Mac logic boards because of bad or bent contacts; that also caused randon disconnects before the fix.  Perhaps dipping them in Holy Water might work on those USB connectors!  Not recommended for your Mac logic board, however.  ;o)

     

    Try, try the NAS.  You will like it, you will see!

  • 821. Re: Disk Drive ejecting itself
    chrisCTMini Level 1 Level 1 (0 points)

    FWIW, my computer is a mid 2011 Mac Mini (bought just before the newer mac mini (with USB3.0) was released. The drive in question is a 2TB Seagate Expansion Drive 3.0, just purchased.

     

    Also connected to the same computer is a SATA drive bay with 2 500gb internal Wester Digital Drives in them.

     

    My computer was left along all weekend this past weekend (we were away), so the only thing that was running was Time Machine, doing its usual back ups. The drive was still mounted when I got back.

     

    In my case I can't rule out that one (or more) of the files that TIme Machine was trying to back up some how "hung" and that caused the drive to eject. As I mentioned in my earlier post, there was an a message in the log just before the drive ejected stated something didn't respond for 5000 miliseconds.

     

    Considering the seemingly rarity of this issue for me now, I'm not going to be too concerned about it, other than to "manually" back up my important files onto another disk every now and then, something which has been part of my back up strategy anyway as I try to keep that back up drive stored somewhere either off-site or at least in a different room in the house.

  • 822. Re: Disk Drive ejecting itself
    Basman Level 1 Level 1 (0 points)

    Perhaps this rise in problems is due to the fact that there are only a handful of HD manufacturers left.  ANother example of end users being poorly served by global manufactuing cabals run amok.  Western Digital and Seagate are the main ones, with Toshiba (which owns the Fujitsu brand) still hanging in.  Western Digital bought out the Hitachi HD division a few years ago; it now controls over half the planet's HD supply.  Seagate likewise acquired the Samsung HD division.  Not surprisingly, HD warranty periods dropped precipitously after the consolidation;   Barracudas that previously had a 5 year period now come with one year, sometimes two when provided by the store (e.g. Egghead).  Nowadays a five year warranty only comes with the high performance versions of consumer grade drives or you have to buy Enterprise (aka server grade) mechanisms to get the better quality and warranty.

  • 823. Re: Disk Drive ejecting itself
    par333 Level 1 Level 1 (0 points)

    Why is that these drives probably do not self eject in a PC?

     

    If you are going to assign blame, then Apple OS gets the lion's share.

  • 824. Re: Disk Drive ejecting itself
    Basman Level 1 Level 1 (0 points)

    They do self eject in some PCs, although perhaps not your particular one.  See for example: http://en.community.dell.com/owners-club/alienware/f/3746/t/19451350.aspx

     

    Sound familiar?!!!

1 53 54 55 56 57 Previous Next