Previous 1 54 55 56 57 58 Next 951 Replies Latest reply: Jan 19, 2016 6:47 AM by jhp03c Go to original post
  • par333 Level 1 (0 points)

    I'm just saying that I have used Hitachi, Samsung, Western external drives (capacity 750Gb,1 and 2 Tb) on my PC running XP (and now running 7) and I have NEVER had a self-eject problem.


    My Macbook pro started to eject these drives (USB) from the get go.


    It would be foolish of me to blame the drives and not Mac OS.

  • chrisCTMini Level 1 (0 points)

    I agree with Par333 on this. I had one disc plugged into a PC for months without so much as a blip, the minute I plugged it into my Mac, it started ejecting. In that case I narrowed it down to a partition on the drive the mac didn't like, but none the less, the MAC had the issue, not the PC and not the drive. The partition in question was used to back up a PS3, which also saw, and was able to "mount" and "use" that partition without issue.


    The tech support person at Seagate that I talked to, without hesitation, blamed the issue on the case they use and the firmware being designed to power down after 15 minutes of inactivity, and that the Mac didn't know how to handle that (actually, it handles it exactly the way it should, telling you the drive was ejected improperly...which, in essence, it is). My guess is that the other external drives have similar "features" designed for the PC user and not the mac user.

  • U.B. Level 1 (0 points)


    I think we should go back to basics and make things more simple. 56g. and we are as lost as ever.

    My idea is for us to use some methods of disqualification. Its too complicated for everyone to be going into the HD's internal mechanism and read whose name is on the drive.


    I guess its too early to tell if Mavericks made any difference...


    In meanwhile, everyone can chip in and continue the list - then we can see what components are on the longer list, which ones are not and hope that the list can tell us something. If you guys are willing to go through the process of elimination lets do it.

  • U.B. Level 1 (0 points)

    Components involved in "drive ejecting itself" problem:


    - Early 2009 MacBook Pro - 2.93 GHz Intel Core 2 Duo - OS 10.8.5 - Fantom FAGF4000QU3 4TB QUAD - FW and USB connection


    - mid 2011 Mac Mini - 2TB Seagate Expansion Drive 3.0 - SATA connection

  • Ivan Robertovich Level 1 (30 points)



    Please try what I reported above:  start your Mac in safe boot mode and see if the drive stays connected.  Mine did. The, when I went back to normal boot, the problem came back 


    What that means is the one of the extensions or processes that are excluded in safe boot is causing the eject problem.


    I'd like to know if the same thing happens for you. Thanks.

  • Elidesuma Level 1 (0 points)

    Upgraded to Mavricks 10.9 and external HardDrive still disconnecting. OWC enclosure with WD caviarblue 500gb, Tried FW 800, Usb, and switching off «put hard disk to sleep». Also tried «SleeplessHD» but not working. This is an Archive Disk and really anoying to have to swith it on and off all the time to make it mount.



  • U.B. Level 1 (0 points)

    @ IVAN

    Right now I'm short on time to check your suggestion, but as soon as I get some spare moment I will do the safe boot.

    If anyone else would try it right away, please leave us a report.

    In any case, these external drives are ejecting themselves sometimes 3 days after mounting them, sometimes even 10 days after so whatever we try it may take some time to conclude the result.


    Also, I tried at some point to connect my same problematic HD to a newer MacBook Pro (late 2011) and it did NOT eject. Mind you that is my partner's MacBook Pro so I could not leave the HD attached to it for a longer time, but I can try it soon again for longer.


    Sad news that Mavricks does not fix this either.

  • U.B. Level 1 (0 points)

    Components involved in "drive ejecting itself" problem:


    - Early 2009 MacBook Pro - 2.93 GHz Intel Core 2 Duo - OS 10.8.5 - Fantom FAGF4000QU3 4TB QUAD - FW and USB connection


    - mid 2011 Mac Mini - 2TB Seagate Expansion Drive 3.0 - SATA connection


    - Mavricks 10.9 - WD caviarblue 500gb - FW 800 and USB connection

  • chrisCTMini Level 1 (0 points)

    Ok, so my drive ejected again last night. I checked the log, and very similar thing from before. It has successfully completed several incremental backups but then Time Machine tried to back up, got hung up on a file and disconnected the drive. But here is the wierd thing:


    It got hung up on 6 files that were zero (0) kb in size and on a drive that holds my Itunes Media.


    Wait, it gets stranger...


    At the same time, Itunes was telling me it had an upgrade available. I plugged the drive back in (leaving the Itunes message up) and sure enough, within a few seconds, the drive ejected again. I then selected "updgrade itunes later", replugged in the drive, and so far, everything is fine.


    One other thing I noticed in the log is that it keeps referring to a drive by name (D2P2) that no long is on my computer, and in fact was one of the older drives that was causing issues earlier. I checked disk utility and no drives of that name exist. I'm also getting an error message in the log that seems to indicate the drive is trying to re-mount when it has already been mounted.


    In the mean time, my internal drives, connected to the docking station, are humming along just fine...

  • Apollo116 Level 1 (0 points)

    If anyone was using an external hardrive with a pc and reformatted it..the only format that worked for me was the M DOS FAT32..the Extended journaled formats will just keep ejecting..


    I Successfully just transfered over 100 Gb without any hiccups...

  • Rikardio Level 1 (0 points)

    Apollo116 is your hard drive still working properly? Can you say is fixed?



  • Level 1 (0 points)

    I haven't gone through all the responses but I noticed one related to Spotlight Search Indexing. This gave me a clue.


    My iMac froze during a shoot and since then, the CF card that was in at the time would eject every time I connected it. This made it impossible to get photos off the card -- a very serious critical bug.


    Luckily, I also have a MacBookPro so I've been using the MBP to unload the CF to then copying the files off the network to my iMac to work on. Serendipitously, because I already had folders named NikonD800, I changed the name of the folder right on the CF card before transfering the folder over. When I plugged the CF in, the card didn't eject. It hasn't unmounted for the past 10 minutes (it used to unmount within 30 seconds).


    I think this indeed has to do with Spotlight Indexing. Short term solution: rename your spontaneously unmounting drives.

  • Rikardio Level 1 (0 points)

    I think we nailed it.


    Go to system preferences then go to Spotlight and click in Privacy. Add your problematic hard drive and it´s done. Enjoy.


    It´s been 33 hrs since last unwanted ejection.

  • jcs2305 Level 1 (0 points)

    I can't get the drive to stay mounted long enough to choose in spotlight. When I connect my drive it shows in finder.. I get the spinning progress indicator for about a minute then BOOM I get the message " Disk Not Ejected Properly". 



    I am currently using WD MyBook 3TB with mid 2011 Mac Mini. 2.3ghz i5  8gb RAM. On Mavericks OSX 10.9



    I also tried Onyx, but get a message saying I am unable to run the program?  I am beside myself.. I already replaced one of these WD 3TB drives after about 2 mos of use earlier this year. Out of nowhere it would not mount and it would give an error when I tried to use tech tools or disk utility. I can't remeber the exact error, but WD replaced no questions asked.

  • Basman Level 1 (0 points)

    The point being made in my previous post was not that everyone needs to open up their external hard drive mechanisms.  The point being made was that trying to make a list of hard drives that "work" is a futile endeavour.  There are just too many things different between various Macs, software installations, and slight changes in the guts of various external drives for a white listing approach to work reliably to identify external dirives that will not dismount without permission.  One person's success with a particular drive and enclosure does not necessarily mean another is going to have the same joy.  Until Apple admits that there is a problem (don't hold your breath!) and gives us a fix, my approach is to either try to get lucky or abandon USB/FireWIre/Thuderbolt and get a third party NAS to provide external storage.  Success is not measured in hours of up time.  A reliable storage medium must stay up and running for weeks, if not months, to be of some use to people trying to set up a serious backup solution.  It is unfortunate that the evidence has shown that this cannot be kept simple - or this particular thread would long ago have been marked as solved.  It doesn't help, of course, that the Snow Leopard OS that this thread was supposed to be about has morphed into all Mac OS versions that have followed it.  The fact that these problems have persisted though three major upgrades of the OS is not encouraging to say the least - scandalous is more like it.

Previous 1 54 55 56 57 58 Next