Previous 1 55 56 57 58 59 Next 938 Replies Latest reply: Feb 26, 2015 2:39 AM by Cali Xenon Go to original post
  • Ellen74 Level 1 Level 1 (0 points)

    jcs2305 -- is this the message you're getting with OnyX?

    http://www.titanium.free.fr/viewtopic.php?f=8&t=1628

     

    Will the drive mount on another Mac long enough to run the Disk Utility repair on it?  If so, run it twice (may take a long time).  See if that helps when you reconnect to your MacMini.

     

    What happens if you try to start up in safe mode? (Shut down. Wait 10 sec. Press power button. Immediately after tone, press shift key. Release shift key when see apple logo and spinning gear.)

  • enandjay Level 1 Level 1 (0 points)

    I spent several hours reading all the posts and trying several fixes. Nothing really worked out. So this is a short summary of all the ideas and posts which have been made before. Currently I'm absolutely unsure which of the components is the main cause of this problem.

     

    Mac OS X: might be an issue

    USB 3.0 on a USB 2.0 port: no (works perfect with several other devices)

    Controller of the enclosure (Jmicron): might be

    Discs in the enclosure (Seagate): might be

     

    I'm using:

    Mac Mini mid 2011 (no USB 3.0)

    OS is 10.9 but it also occurred in 10.8

    I have a working 1TB WD USB 3.0 external drive which never ejects

    I have a external case with 5 Seagate Surveillance, 7200rpm, 64MB, 3TB, SATA-3, 24/7

    The external drive has a JMicron USB to ATA/ATAPI Bridge

     

    The only thing which has worked 2 times in months was unplugging the whole enclosure (also power). Wait several days. Plugging it in again. Wait and don't use the drive for reading or writing data and hope it is not ejected. After 1 or 2 days you can use it and it might work.

     

    I tried already the following points, all didn't work out (tested by coping 4 files with a total size of 5.4 GB and the drive was always ejected after 300MB to 1.7 GB).

     

    Remove vendors driver to use Aples native one
    https://discussions.apple.com/thread/2151621?start=780&tstart=0

    --> Didn't work <--

     

     

    open a DMG and a text file in it
    https://discussions.apple.com/thread/2151621?start=750&tstart=0
    --> Didn't work <--

     

    Use USB 2 cable

    --> Didn't work <--

     

    Unload the driver

    https://discussions.apple.com/thread/2151621?start=615&tstart=0


    sudo kextload /System/Library/Extensions/IOFireWireFamily.kext/Contents/PlugIns/AppleFWOHCI.k ext/

    sudo kextunload /System/Library/Extensions/IOFireWireFamily.kext/Contents/PlugIns/AppleFWOHCI.k ext/

    --> Didn't work <--

     

    Backup Plus firmware update tool for Mac OS

    http://www.seagate.com/support/downloads/item/backup-plus-mac-firmware-updater-m aster-dl/

    the 5 single drives are Seagate, but not the enclosure so this didn't work

    --> Didn't work <--


    S.M.A.R.T. for USB and FireWire Drives

    https://www.macupdate.com/app/mac/47045/s.m.a.r.t.-for-usb-and-firewire-drives

    Now I see the SMART status but the drive is ejected any way

    --> Didn't work <--


    Disable Spotlight

    https://discussions.apple.com/thread/2151621?start=825&tstart=0

    --> Didn't work <--


    use USB 2.0 extension 

    https://discussions.apple.com/thread/2151621?start=825&tstart=0

    --> Didn't work <--


    exchange USB 3.0 driver

    really crazy idea as the mac mini mid 2011 I'm using has no USB 3.0

    --> Didn't work <--

    Tool: Kextbeast

    http://tonymacx86.blogspot.ch/2010/08/kextbeast-simple-kext-installer.html

    Driver extension

    http://sourceforge.net/projects/genericusbxhci/files/

    http://www.insanelymac.com/forum/topic/286860-genericusbxhci-usb-30-driver-for-o s-x-with-source/page-2

  • chrisCTMini Level 1 Level 1 (0 points)

    Enandjay, is it possible you simply have a bad drive? Have you tried it on another computer, PC or Mac? My seagate drive auto powered down after 15 minutes, causing part if the issue. Seagate rep pointed me to right place to disable it. Turning off spotlight fixed rest.

  • jcs2305 Level 1 Level 1 (0 points)

    @Ellen74. No I am unable to get the drive to mount long enough to do anything. When I connect I see it in finder and desktop. If I open finder and go to my drive it doesn't show any of my content. Down in the bottom right corner I get the spinning circle like it's thinking. Then after a minute I get the disk ejected improperly message.

     

    I have the witless keyboard and for some reason I can't get into safe mode. Seems like the keyboard is in and recognizing the shift key too late for safe mode. Guess I need to find a USB keyboard to try again.  Since I posted however I was able to hook the drive up to an older vista machine and a windows 7 machine at work and it didn't work on either of those. Was stuck in a loop. Connect try and install drivers disconnect, then reconnects itself and tried drivers again.

     

    I also have read several forums discussing the My book 3tb specifically. I have found that the USB board on these go bad and replacing it may be the key to getting my data back. This was only a fix for the self ejecting problem. If there are bad sectors or anything malfunctioning with the drive itself chalk it up to a bad drive. The board replacement will not work.

  • chrisCTMini Level 1 Level 1 (0 points)

    jcs2305, if the drive has a bad board (I'm assuming you mean the board for the enclosure), I'd suggest buying a dock like this and pull the drive out of the enclosure.

     

    I've had one of these for nearly a year and they work great!

     

    http://www.newegg.com/Product/Product.aspx?gclid=CPau7MC-3boCFW_NOgodPCcACg&Item =N82E16817153071R&nm_mc=KNC-GoogleAdwords&cm_mmc=KNC-GoogleAdwords-_-pla-_-Exter nal+Enclosures-_-N82E16817153071R&ef_id=UkrbAgAABGYPM7qO:20131111194039:s

     

    The other option is to buy a USB to SATA adapter such as the one below (which will also for older IDE drives as well). Also have one like it and they work pretty well, but aren't as "permanent" a solution.

     

    http://www.newegg.com/Product/Product.aspx?Item=N82E16812156102

     

    My personal assessment of this whole situaiton is the problem is with the enclosures and not the drives inside them. I've finally gotten mine working, but next time I need a drive, I'm just going to buy an internal drive and swap it out into my dock.

  • Basman Level 1 Level 1 (0 points)

    Enclosures are a problem - especially the MyBook variety - I have ripped apart more than one of them to recover perfectly good drives;  LaCie boxes too.  But if you suggest a replacement caddy/dock, then check the capacities carefully.  The NewEgg product is only good for up to 2 TB.  Not going to help our friend jcs2305 with his 3 TB drive.  They look a lot like another one sold under the NewerTech brand: the Voyager (I suggested that one in an earlier post a long time ago in this thread) will handle up to 4 TB.  These are available from OWC, which has supplied Mac users reliably for many years.  Another plus - the more expensive model Q has USB 2/3, Firewire 800, and eSATA ports.  I have two of their somewhat older model - they are solid - well worth the $70 each that I paid.  And yes, they are bootable on multiple machines:  from my SnowLeapard Intel Mini all the way back to the ancient G4 Cube and Graphite G3 iMac.  Of course, you can't keep compatibility up forever - 10 TB drives will be out next year!  ;o)  Here is a link:

    http://eshop.macsales.com/shop/NewerTech/Voyager/Hard_Drive_Dock

  • chrisCTMini Level 1 Level 1 (0 points)

    Thanks Basman, well spotted there.

  • jcs2305 Level 1 Level 1 (0 points)

    @Chris and Basman  Sorry I wasn't clear. I was talking about the Connector board that the usb and power connections go into.

     

    http://parts.com.hk/1/index.php?main_page=product_info&cPath=1_2_3&products_id=1 08#.Un8135GRJg0

  • Ellen74 Level 1 Level 1 (0 points)

    jcs2305 - Does the spinning ball start immediately or only after you click on the disk drive icon to see what's inside?   If the spinning ball does NOT start immediately, try this --  before mounting the drive, shut off time machine and open disk utility.  Mount the drive, quickly select it in disk utility and click repair (will take a very long time.  run it more than once).  I doubt it will work, but it can't hurt to try.

  • Basman Level 1 Level 1 (0 points)

    The connector board (aka adapter board) internal to any enclosure is exactly what the usual source of the problem with faullty enclosures is.  SOmetimes it can also be the power supply.  I have also seen problems with the thermal sensor WD often places on their drives in the MyBook enclosures, which will spin down your drive because it (wrongly) thinks it is too hot.  Unless you used WD Security to encrypt your MyBook, then you don't need to keep that drive in the MyBook enclosure (unless your new board got it working).  You can then still use the Voyager or something else.  If it is encrypted, then you are indeed stuck trying to get a connector board for your MyBook that works, assuming you want to keep the data that is on it.  You can still reformat it and recover use of it in a third party enclosure in any case.  As you may know, OPAL hardware encryptied (FDE) drives are NOT supported directly on Macs - the MyBook solution uses the connector board to handle the encryption - not ideal but better than nothing (if it is working like it is supposed to).

  • U.B. Level 1 Level 1 (0 points)

    @Ivan

    I did boot my Mac in safe mode and the drive stayed connected for 2 days, than it was ejected. But this is not unusual occurance since my drive would always stay mounted for 2-3 days no matter if the Mac was restarted in a normal or safe mode.

     

    Two days ago I upgraded my Mac to Mavericks. The drive did not eject itself yet. The next few days is crucial. Will see if this made the differance...

  • enandjay Level 1 Level 1 (0 points)

    Due to my experience the only solution is: don't buy stuff which is cheap only. In my case the not matching Jmicron controller was the issue. I use a eSATA Thunderbolt switch now and everything is working perfect.

     

    So yes enclosures and cheap and not compatible chipsets are issues.

  • U.B. Level 1 Level 1 (0 points)

    enandjay

    I do not blame you for not reading all these pages. I wouldn't if I did not have this problem either. But if you did, you would see that all kinds of drives (expensive and cheap) with all kinds of connections (usb, fw, thunderbolt...) are givning ejecting problem to people.

     

    By the way, my Fantom Drive started being ejected on Mavericks as well .

     

    Now, I will fw connect my drive to a newer MacBook Pro and let it sit there for a longer time to see if it makes differance.

  • AceNeerav Level 1 Level 1 (95 points)

    i have two macs at home both running mavericks. one is a mbp 2010 and other is a mbA 2013. i have a powered usb hub to which are connected my 3 usb portable hdds. every few hours, the drives eject and mount themself again on their own! this happens on both the machines.

     

    there doesn't seem to be any problem with the same hub on a windows machine!

  • AceNeerav Level 1 Level 1 (95 points)

    i hope my drives dont go nuts until the time apple fixes this issue!

Previous 1 55 56 57 58 59 Next