Previous 1 57 58 59 60 61 Next 940 Replies Latest reply: Apr 21, 2015 3:54 PM by Sasha_yu Go to original post
  • gentboy Level 1 Level 1 (0 points)

    Today I did some research and found something beyound my imagination.

     

    I still need the backup. So I want to find another solution. My solution is to create a AFP server on a raspberry Pi using natatalk. But raspberry pi is not enough to power the harddisk, so I connect the harddisk to a windows 7 and share it. The file system of the hard disk is NTFS. Then I mount the shared disk to raspberry Pi, and the Pi share the mounted disk via AFP. So the Mac was able to find the disk via raspberry Pi -> Windows 7 -> disk.

    And the time machine can find the disk too. And I start the backup.

    Guess what happened? The disk was ejected from windows side! Then remounted automatically just like in Mac!

    I tried and no problem to do file copying in the windows. But as long as I start the time machine backup. The disk was ejected FROM WINDOWS 7 immediately.

    This is totally...

    I need some sleep now. Maybe they are just illusions.


  • Allan Eckert Level 8 Level 8 (46,735 points)

    Apple recommends against using NAS for Time Machine.

     

    I would personally test the daylights out of that configuration before I would trust backing my data up to it.

     

    One area that I would be sure to test is the databases from applications that use them to store their data; such as Aperture, iPhoto, iTunes and Full Cut.

     

    Allan

  • Basman Level 1 Level 1 (0 points)

    This last comment is of some interest, since the NAS solution seems to work well with Retrospect and Carbon Copy Cloner (to images).  I have not tried it with TimeMachine.

     

    Apple has the following article about Time Machine on Snow Leopard:

    http://support.apple.com/kb/PH11171

    That article shows time machine does back up to at least some NAS boxes that support afp.  Nothing about it not being recommended.

     

    Can you show us where your reported recommendations against a NAS are to be found?  If not, did you hear this from an Apple support tech?

  • gentboy Level 1 Level 1 (0 points)

    I tried with another WD usb hard drive which works well for years. And magic happened again. The disk was ejected from windows.

  • gentboy Level 1 Level 1 (0 points)

    I can guess that the time machine back up may have some very special file operations that cause different disk eject itself from different OS

     

    NB: Also I use the original disk that come from the MBP and copy 13GB data with the same SATA/USB cable, without any problem.

  • TinMass Level 1 Level 1 (0 points)

    Has this problem been resolved ?

    59 pages of discussion and no solution !  Really........

  • Macbrush Level 1 Level 1 (15 points)

    I am an administrator of thousands of Macbook Pro, and dozens of Mac Pro / iMacs in an all Mac yr 1 - 13 school . As I mentioned before in this thread a long time ago, the most common cause of disk ejecting themselves was cable related, be it firewire, or USB. A cable works in Windows don't automatically means it would work on Mac, nor a perfectly good professional looking new OEM cable striaght from the box of a LaCie drive doesn't guaranttee anything. Its just by chance, but generally speaking the better quality feel and shorter the cable is, the better your chance.


    Once we figured this out, and started screening cables before we started distributing external drives to our users (with a tested cable) for Time Machine; we almost never heard this problem again.

     

    I believe that I have enough statistics data to support that most, if not all, disk ejecting problem in OS X is cable related.

  • gentboy Level 1 Level 1 (0 points)

    Could you provide a list of cables, disks, or enclosures those proved working with MAC OS?

    Thanks

  • gentboy Level 1 Level 1 (0 points)

    I just bought another disk enclosure and put the original MBP disk in. Now the eject itself not happen anymore.

    I think Macbrush is right. Should mainly blame the cable, disk or enclosure.

    My disk is the original MBP mid 2010 13' disk. The enclosure is from http://www.amazon.co.uk/gp/product/B003RIL0EM/ref=oh_details_o00_s00_i00.

  • doug_mac Level 1 Level 1 (0 points)

    A replacement cable seems to have solved the problem for me - so a big thanks to 'Macbrush'.

     

    http://uk.cellphoneshop.net/ - item CAB-USBMICROB - is the one I'm using if this helps anyone.

     

    I was using it for a card reader so gave it a try and all good so far. Now bought another to use with my card reader.

     

    Again if it helps, my drive is a WD Elements and I was using the original short cable that came with it when I had the issue.

  • Teren49 Level 1 Level 1 (0 points)

    Changing the USB cable has finally solved the problem for me. Thank you!

  • Lars Engel Level 1 Level 1 (5 points)

    No luck here with testing 2 other cables. What cables do you use (length, brand). What disk are you using?

  • Macbrush Level 1 Level 1 (15 points)

    I know its a pita, to be honest I found there is no absolute pattern, but generally the shorter the cable, the better your chance are. Many times we bought a bunch of cables with same brand and length, but always a few of them wouldn't work on OS X. However, I have some 4 ft USB cables that works, and some 1/2 ft don't. And I need to mention it again, OEM cables don't always work, in fact, most of us found out this problem the first time with OEM cables.

     

    I guess its the way OS X handle errors or power loading, which Windows and other OSes have a mechanism to correct (or recover from), but not OS X.

  • U.B. Level 1 Level 1 (0 points)

    Changing a cable is absolute wast of time.

     

    I have hooked 3 different HD’s on a same cable.

     

    First, I have used one firewire cable and one HD is being ejected and the other two HD’s do not eject.

     

    Second, I have used one usb cable and the same one HD is being ejected and the other two HD’s do not eject.

     

    It has nothing to do with the cables. The problem is either the specific HD or OS.

  • Lars Engel Level 1 Level 1 (5 points)

    I do agree on this theory:

     

    https://discussions.apple.com/message/24050472#24050472

     

    Would be interesting to know what hard drive models resp. enclosures people with this problem are using. Maybe they all have a certain controller chip in common? Of course not anyone wants to take a look into the enclosure, but one for each model should be sufficient.

     

    Starting a new discussion here, feel free to contribute with your failing drive:

     

    https://discussions.apple.com/thread/5943136

     

    Thanks!

Previous 1 57 58 59 60 61 Next