Previous 1 58 59 60 61 62 63 Next 940 Replies Latest reply: Apr 21, 2015 3:54 PM by Sasha_yu Go to original post
  • doug_mac Level 1 Level 1 (0 points)

    Clearly not a waste of time in my case ................

  • al509 Level 1 Level 1 (0 points)

    I just want to drop a note saying that  I have a WD drive for backups that constantly ejects itself and also a Vantec NexStar TX that is on a 4 ft USB cable as well as going through a USB hub and has never ejected. I have all my development dataabses on this drive and works just fine. The NexStar is 250GB

     

    The issue may be with inactivity, since the TX is constantly being used.

     

    I am currently on OS X 10.8.5 early 2013 latptop, if it matters.

     

    The WD drive also would disconect while being directly plugged into the computer. The USB hub is 2 weeks old.

     

    Al

  • Studio Palegolas Level 1 Level 1 (0 points)

    Seriously, I'd get the Thunderbolt version every time.. but when getting a pocket sized travel disk the price difference is just too big. I'm sure Apple is pushing for thunderbolt, but if they do they should have added four thunderbolt ports instead of 2 thunderbolt and 2 usb.

  • mail4500 Level 1 Level 1 (0 points)

    I have followed this thread for year and tried all sort of solutions. I have found one that works well for me. Try plugging in another Apple product into a spare USB slot permanently (e.g plug in you old unused ipod).  Itune will start automatically and keep it that way.

     

    Strangely enough, my Seagate USB2.0 external disk stopped ejecting from then on.

  • Macbrush Level 1 Level 1 (15 points)

    It is not OS specific, this problem existed since as long as I could remember using OS X. And for those saying it is not cable problem, you haven't tried enough cables. We had over 2000 Macs, and hundreds of external HDD to tested with. And we didn't see this problem anymore since Snow Leopard when we started screening cables, on 2000 Macs, not just 1 Mac, 2 Macs or 3 Macs. That's why I kept saying its cable related, and it is definitely cable related, at least in our 2000 Macs.

  • U.B. Level 1 Level 1 (0 points)

    Common people, if you really want to help then read the posts before you conclude.

     

    Macbrush,

    Let me ask you a simple question, if the cable is problem as you are saying, then how do you explain this:

    On a same USB cable I hook 2 of my HDs. One HD ejects and the other HD does not. How its possible that the same cable is a problem for one drive and not for both?

    Same thing applies to FireWire cable (both of my HDs I have FW and USB available). Used the same FireWire cable, One HD ejects and the other HD does not.

     

    Who would not wish that the cable is a problem. Now days, we all have at home 10 USB cables of all lengths. We try them and they work with all kinds of devices, except in a certain HD.

  • Macbrush Level 1 Level 1 (15 points)

    I can answer this very easily, because while we conducted experiments to solve the problem, we ran into the same situation. If a cable works on a HDD while not on another HDD, the solution is find another cable for the HDD that didn't work; simply speaking not all HDD is sensitive to the cable problem. You may call it a HDD problem, but I rather look at it as cable problem since finding a working cable is easier than finding a HDD that works with all cables.

     

    Did I mention that we did solve this problem once and for all, for THOUSANDS of Macs?

  • U.B. Level 1 Level 1 (0 points)

    Thanks Macbrush for trying to help, but my HD is still ejecting.

     

    You think that the problem is solved, I don’t. No one is crazy enough to buy 50 different cables and hope for the best that one works. The ones that come with HD do not make usable combo. So, please let us know what is that magic cable that works for all? I will be the first one to buy it happily.

     

    Personally, I have tried many USB and FW. I see that people used many thunderbolt as well. Problem continues.

     

    Problem is solved only when you can point out, not to what is causing the problem (that may be only the good starting point), but to a specific thing that cures the problem for us all.

    Isn’t it easier if for once and forever someone discovers what is in those problematic HDD that makes them to be ejected while being hooked with the same cable, on the same computer as other properly working HDD?

  • gentboy Level 1 Level 1 (0 points)

    I guess the power supply could be a possible reason. In my case I have:

    Disk A (MBP Original Disk)

    Disk B (New Crucial SSD)

    Cable A (the bad one)

    Cable B (the good one)

     

    At first I connect Cable A and Disk B to USB port and clone Disk A to Disk B. No problem and success.

    Then I swap the 2 Disks, connect Disk A to USB port with Cable A. And trying to do time machine backup to Disk A. Always eject.

    Then I bought Cable B. And connect Disk A to USB port with Cable B. And do time machine backup. Success.

    Note that with Cable A Disk A fail but Disk B success. But Disk A will success with Cable B. The major difference is Disk A is a HDD which uses 700-1000mA current(estimated). While Disk B, the SSD only uses ~450mA (marked on the disk).

     

    The power supply problem will be sensitive due to the cable. But different disk may require quite different power supply. And even for the same disk, especially the HDD, the power required maybe quite different due to different read/write operation. This makes the problem complex.

    So anybody above that have the problem that with same cable, some disk working but some not, I suggest if you can compare the required current of the HDD. Maybe that will explain.

  • al509 Level 1 Level 1 (0 points)

    I just purchased a 1.5 ft cord and did some backups this morning.

    The drive just ejected and came back on.

  • dcsang Level 1 Level 1 (0 points)

    I've had this problem since I switched to Mac back in early 2007 (Mac Pro) up to and including today (currently running a mid 2011 27" iMac).

     

    Recently I started investigating a problem I've had with my QNAP TS-220 NAS.  It's a simple 2-bay NAS in which I have 2 NAS spec'd Seagate drives; each 3TB.

     

    I also have an external HD connected to the NAS via eSATA.  The HD is a Seagate 2TB drive.

    I use this drive in order to back up data from the NAS via a weekly scheduled job.
    Ever since I've had this job set up, I would get a weekly error on the NAS and I would note that the backup job would not be complete.  I let this linger for some time. Not paying attention to it much since it was "only a backup job".

     

    But then I got to thinking about my continuing, agonizing, painful and frustrating Mac external HD situation and how the external HD would get "bumped" off for no particular reason, usually after sitting mounted for who knows how long.. sometimes days.. sometimes hours... - the External HD would still show as desktop icons and in the Finder but once you try to access the drive... I get to play with the dreaded beach ball until I forcefully eject (turning off the external HD) - as I said at the beginning of my post, this has gone on as long as I've owned a Mac.

     

    I started searching for compatibility issues with the NAS. My HD's inside were fine because I knew they were according to QNAPS listing. My external; after examining it, was a Seagate Green drive.  I had heard that the green drives were probably not the best to be using for lengthy use but for brief access.  I then checked the external HD attached to my iMac; it was also a Seagate Green drive.  I wonder if the Green drives are what the issue is here.

     

    I've searched through this entire thread and only one other individual actually mentions that this may be the reason for drives being kicked off (I searched the word "green"). I have a single 1TB WD Black drive that I will test out before spending any $$$ on new drives.  I can at least test it out to determine if the green drive is at issue with my QNAP job and, hopefully, that will translate over to the issue with the Mac.

     

    Cheers
    Dave

  • Ivan Robertovich Level 1 Level 1 (30 points)

    I found the culprits in my case...

     

    I've tried new HDDs, I've tried cables nothing worked until today.  I looked in the /Library/Extensions/ folder on the root of the drive and found old WD drivers:

     

    /Library/Extensions/WD1394_64HPDriver.kext

     

    and 3 others like it.

     

    I also downloaded the WD smartware tool and used the installer and uninstaller.

     

    ran cocktail to clear everything out, repair permissions, etc...

     

    restarted, connected the same drive that had been such a problem...

     

    no problems at all now.  Thank God.

     

    turns out that for me, these old drivers in the Library folder were causing the grief.

  • William Boyd, Jr. Level 6 Level 6 (10,515 points)

    Your experience gives one example of why Apple has been having such a hard time fixing this problem.

  • t3359 Level 1 Level 1 (0 points)

    No it doesn't.  They could at least look at log files and look at what the hardware is saying to debug the problem.  We here, without inside knowledge, are just randomly trying things.

  • William Boyd, Jr. Level 6 Level 6 (10,515 points)

    You're presuming that people have submitted log files for Apple to look at.  Has that actually happened?  You're also presuming that enough things are being logged to give a clue as to what the problem is.  Were those WD drivers logging anything?

     

    What I was trying to say is that there's such a wide variety of user environments that it's hard for Apple to characterize a particular problem.