Previous 1 59 60 61 62 63 64 Next 953 Replies Latest reply: Mar 31, 2016 8:28 AM by Barbara Smits Go to original post
  • t3359 Level 1 Level 1

    Oh please.  They have the resources.  If they wanted to correct this problem, they'd actively pursue it.

  • William Boyd, Jr. Level 6 Level 6

    t3359 wrote:


    They have the resources.

    Sure they have resources.  What they may not have is a Mac that demonstrates the problem.


    Is your Mac having the problem?  If so, are you volunteering to ship it to Apple so they will have a good test case?

  • t3359 Level 1 Level 1

    That's funny, because there are thousands and thousands of us that do.  What exactly is your point?  Did you defend Toyota's handling of the unintended accelleration problem in the same way?  I'm sure they didn't have a car that demonstrated that problem.  It's the manufacturer's mandate to figure these things out.

  • Ivan Robertovich Level 1 Level 1

    No...   I spoke too soon...   It just ejected later...


    What I want to know is why it does not eject in safe boot.


    That tells me something apple does is ganked up...  I've deleted all third party crap off the machine.


    At least time machine is running in safe boot

    No eject


    That means, for me, it's not the cable, it's not the hardware, it's something wrong with OS X

  • William Boyd, Jr. Level 6 Level 6

    Ivan Robertovich wrote:


    What I want to know is why it does not eject in safe boot.

    You may think you deleted all third party stuff, but the fact that it behaves as you'd wish in safe boot mode suggests that there's still something there.


    According to Apple's document on safe boot, "It loads only required kernel extensions."  I would guess it's one of those non-required extensions that's causing your problem.


    Try looking in /Library/Extensions for anything that didn't come with OS X.  I have nine files in there, all dated between 22 July to 31 August 2013.

    If nothing there looks odd, look in /System/Library/Extensions.  That folder will have many more files, so checking them will be a more-extensive task.


    Another thing you can do to investigate this problem is to use the kextstat command in a Terminal session.  According to its "man" page, kextstat "displays status of loaded kernel extensions (kexts)".


    Try this command in a Terminal session (where "l" is the lower-case letter "L"):


    kextstat -k -l > ~/Desktop/full.txt


    Reboot into safe mode, then run this command:


    kextstat -k -l > ~/Desktop/safe.txt


    After those two commands you'll have two files on your Mac's Desktop:

    - full.txt - All the kernel extentions loaded during a normal boot

    - safe.txt - All the kernel extensions loaded during a safe boot


    By comparing those you can narrow in on the extensions that might be causing you trouble.

  • Ivan Robertovich Level 1 Level 1

    thanks -- those are good instuctions for folks who need it.


    while I was in safe boot, I erased the time machine drive with disk utility and completed a full backup with time machine.


    I left it running over night and the disk stayed attached and hourly backups ran without incident.


    On a hunch, I restarted, even boldly leaving the previously ejecting disk attached...   previously in this thread I mentioned that before mavericks, I was able to cure the problem by deleting the time machine prefs.


    Well, it's in normal boot now and I keep hitting "backup now" and the disk is staying attached...  no ejects.


    I've insisted this was a probelm with the os software, and this further confirms it for me...   something goes haywire in time machine and totally ganks up the rest of the external drives.   that's a bug.

  • Ellen74 Level 1 Level 1

    For the less tech savvy, here's a software fix that works for me (previously posted in this thread):


    1.) On my computer, I clean things out by running everything in the "Automation" panel of the free OnyX software (


    2.) I then run Disk Utility's repair on my external drive.  If there seem to be a lot of problems, I run it twice.


    After that, I'm good for 3 to 6 months or more (have been doing some version of this this since the fall of 2011).  The trick is to run the above after just a few ejects.  Once things progress to continuous ejects, the fix may require finding another mac that will mount the drive long enough to start the disk repair.


    I know my procedure doesn't work for everyone.  Maybe sometimes the software fix is more complex or hardware is the culprit.  I do have a hard time believing that Apple staff have never experienced this.  I'm surprised there aren't official instructions for how to cope with it.

  • Pauleduc Level 1 Level 1

    I would be very interested in knowing if anyone is experiencing eject issues with the new Western Digital Thunderbolt portable hard drives.  According to their site, they are supposed to be compatible with Apple and Time Machine. 


  • Peruzzi Automotive Group Level 1 Level 1

    For what it's worth, I have a new 21.5" iMac running Maverics 10.9.2. I never saw this problem until I installed 10.9.2 yesterday. Anyway, I tried a couple ideas in this thread but what may have worked was by running Automation in OynX. It's only been a few hours but that's light years ahead of what I was dealing with yesterday.

  • innott Level 1 Level 1

    This issue with drive ejecting is connected to energy saver. It will disappear with changing some energy saver preferences, never let computer and display go to sleep at the same time.

  • Rick Borie Level 1 Level 1

    Peruzzi Automotive Group update... I'm the same person as Peruzzi Automotive Group above. Try this... download OnyX. Run Automation. Can't say it's a permanent fix, but I suggest doing this to at least get Time Machine running again. I'm only posting again because I just checked and Time Machine is still working!

  • dcsang Level 1 Level 1

    Actually, that doesn't work. Running a 2011 (mid) 27" iMac and I've changed the energy saver preferences; never letting it go to sleep, with the display sleeping at a different time - still gets ejected.


    Right now, I'm hoping switching from the "Green" drives to NAS based HDs is the answer.


    My earlier post on this topic (March 20th post) got fixed. How?  I reformatted the drive from the standard Mac OS Journaled format to FAT32.  Fancy that...



  • al509 Level 1 Level 1

    The drives I have issues with  are WD Passport drives. (For Mac)

    I have a 2.5 drive on a 4 ft cable (holding all of my development operating systems) and it's a Seagate

    sata 250G 7200 RPM


    Looks like a Momentus 7200.4.

    Enclosed in a NexStar TX case.


    Never has an issue

  • dcsang Level 1 Level 1

    I would suggest (RE: WD Passport drives) that if the drive is a "green" type of drive (i.e. the type that has a variable spin rate, variable power etc.) then this is the reason for the unexpected/unexplained ejects.


    The fact that this thread is now on it's 61st page and going on 5 years old tells you something about how seriously Apple takes such things.  And I guess that's understandable, because, after all, the external drives are not "Apple" branded so there's only so much they (Apple) can troubleshoot.

  • jarown Level 1 Level 1

    This would be a nice addition for the (not) "Self ejecting external harddrives on OSX"-list