12 Replies Latest reply: Dec 20, 2009 5:28 AM by cbojrab
garcohsf Level 1 (0 points)
I have an iPhone 3GS. I have been using a Mophie Juice Pack to charge it with good results. After the upgrade to 3.1, the Juice Pack no longer charges the iPhone. I get the dreaded message, "This accessory is not made to work with the iPhone." Of course it is made to use with the iPhone. Actually that's all it's made for.

Any thoughts?

Mac Mini, Mac OS X (10.6)
  • w7ox Level 4 (2,385 points)
    Try a Restore. You may have gotten a corrupt OS 3.1 install as I did the first time.

  • tuskhog03a Level 1 (0 points)
    I am having the same issue. I replaced the Mophie Air 2 times at the Apple Store to confirm I did not just have a defective device. My iPhone worked fine prior to upgrading to 3.1. I have since reloaded my iPhone 2 times to verify that I did not have a corrupted install of 3.1, but still did not resolve the issue.

    Current Issues:
    1. Cannot synch IPhone via the Mophie USB connector
    2. Cannot charge the iPhone via the Mophie USB connector, yet the Mophie battery will charge
    3. Cannot charge the iPhone via the Mophie. Flipping the Mophie switch between on/off does not change a thing. (There is no charging icon depicted on the iPhone)
    4. When waking iPhone up, the following message is depicted on the screen: "Charging is not supported with this accessory".

    I currently have a technical support ticket open with Mophie. If anyone else has experienced this and/or knows of a workaround, I would be interested.


  • Markie-Poo Level 1 (0 points)
    I also have a 3GS set into a Mophie Juice Pack Air. I have upgraded to 3.1 and everything seems to be working OK since the upgrade..

    However, I have gotten the same message but only if the Juicepack is very low, practically fully discharged. In my situation, it seems that the iPhone is detecting a lower voltage than is acceptable and it triggers the "This Accessory....." message. I also occasionally have trouble syncing through the Juicepack and it's cable if the Juicepack is near or fully discharged. Once I put a charge into the pack, everything is just fine. So I only sync with the Juicepack when it has at least a small charge in it.
  • rtln Level 2 (185 points)
    I just returned a Juice pack air because it wouldn't charge while plugged in (neither position of the switch mattered), wouldn't sync and wouldn't even charge my iPhone 3Gs from 50% before it gave me the "This accessory is not made to work with the iPhone" warning.

    I am also on 3.1

    Not impressed with this upgrade so far.
  • irbrenda Level 1 (10 points)
    I've been on 3.1 for a few days and today the Mophie decided to give me the message, "This accessory..." And my keyboard sounds will not work with the case on. I can charge though and use the Mophie; it's just no sounds work. Very annoyed.
  • Hugh Ashton Level 1 (5 points)
    I have exactly the same issues as irbrenda. I've tried rebooting, Restoring, everything I can think of. Right now I am using the phone without the Juice Air - it saves seeing the "This accessory..." message appearing all the time and gives me my speaker back (it appears that the phone sees the Mophie as an audio interface!).

    Message was edited by: Hugh Ashton
  • irbrenda Level 1 (10 points)
    Magically, after 1 frustrating day of oddball things happening with the Mophie, I used compressed air and blew out the connecting ports on the Mophie, for any dust or whatever, and the message never returned and so far I've been up running perfectly for 2 days. I had called Mophie support and complained about suddenly seeing that message after doing the 3.1 update over a week ago with no issues, and they told me the Mophie is defective and to fill out an RMA form and they'd replace the unit for free. I told them about the complaints since the 3.1 update and they said they've heard about problems with the Mophie message of "This accessory....". They said to just swap out the case.

    I also have another battery case by Tekkeon which has no issues with the 3.1 update.
  • Primaleph Level 1 (0 points)
    I have a FastMac Truepower iV external battery, and I am having the exact same issue with it. The folks at FastMac told me that this is a known issue, specifically with the iPhone 3GS with firmware 3.1.2 and all external battery packs. Apple, please take note and patch this issue in the next firmware release.
  • Velour44 Level 1 (0 points)
    The problem is the USB cord. The cord Mophie sends with the product is not adequate, I'm not sure why, but it is not. I've had two Mophie USB cords (they sent me a second one through an RMA process) and while I have trouble with the Mophie branded cords, other USB-Micro cables that I had ordered online to test this, work just fine. The cords I got online are also twice as long so they're more preferable anyway. I ordered them a few of them from some site I found through a google search: www.meritline.com.

    Hope this helps. It did for me. I'm running OSX 10.5.8 on a 2.4 GHz Intel Core 2 Due with 2 GB 667 DDR2 SDRAM. My iTunes version is 9.02 (25).

    Good luck, hope this helps!
  • Bob @ WV Level 1 (5 points)
    Sorry I don't know what to tell you. I got Iphone 3Gs and usingMophie Juice Pack Air with no problem... I am using version 3.1.2.
  • HongKongJohn Level 1 (0 points)
    Odd 3Gs recharge issues galore. My problem is somewhat similar and I believe it is an iPhone issue and not a juice pack issue. Fully charged iPhone, left on, over night (7 hours) and not used, still has reasonable battery power left in the morning, almost full in fact.

    Take the same fully charged iPhone and place it in the iPhone dock connected to the MacPro and the charging sign shows up. Turn the MacPro off overnight and in the morning the iPhone is dead, fully discharged.

    Take the same fully charged iPhone and seat in the fully charged JuicePack Air with the Juice Pack switched to charge the iPhone (green button) and 7 hours later both the JuicePack and the iPhone are dead, fully discharged.

    Repeat this process with the JuicePack switched RED, not charging and the iPhone will be fully discharged but not the Juice Pack 7 hours later. Yes, the Juice Pack will then start to charge the iPhone when switched to green.

    It would appear that when connected to any utility (JuicePack, Dock etc.) the iPhone will start to discharge when that power source dries up. It is as if the dried up power source is draining the power from the iPhone !
  • cbojrab Level 1 (0 points)
    I have a 3GS, my juicepack air works fine, but I ordered a juicepack as well (for longer battery life) and it will work for about 10 minutes, then the juice pack stops charging the iPhone and when I press the button to show the remaining charge no lights illuminate. I have tried detaching and reattaching it to the iPhone but nothing. If I connect the juicepack to a USB charging source, it immediately comes back to life and show a full charge. I returned the juicepack to Mophie, they exchanged it but the new one does the same thing