Previous 1 14 15 16 17 18 Next 288 Replies Latest reply: Jan 8, 2011 3:25 PM by UFGUY Go to original post
  • Aaronlh Level 1 Level 1 (10 points)
    Of course, now my phone will not mess up again. Does anyone have a log saved from the iPhone Configuration Utility that was running when this problem occurred? I can submit that on my bug if so.

    Specifically, sync with iTunes, open iPod, library states it is updating, library states it is empty.
  • CarlPenwarden Level 1 Level 1 (0 points)
    I am having the same problem. My main iTunes is a PC, Windows 7 Home Premium 64 bit with iTunes, 9.1.0.79. I have an iPhone 3G runing 3.1.3. iPod content syncs ok and shows up fine in the iTunes device window. But when I open the iPod on the iPhone it first says updating library and then comes back with No Content. I have restored the iPhone just to be sure. All Apps, Camera etc... are working and syncing fine.

    I have just upgraded to this PC, previously I was using Windows XP with iTunes and I had no issues.

    I am also running a 15" MacBookPro with OSX 10.6.2, but the PC is our main home media machine running iTunes and our full media library.

    Message was edited by: CarlPenwarden
  • mtwhite Level 1 Level 1 (0 points)
    Pretty sure this has to do with the Genius feature. My daughter turned it on just before I lost all of my music and got the No Content message. Turned off Genius and moved a few songs around and they all returned.
  • lolwutermelon Level 1 Level 1 (0 points)
    I love when people who don't read the entire thread post their 'fix.'

    The reason it fixed your problem is because it moved a few songs around. The library file is getting corrupted on the iPhone. It has nothing to do with the genius playlists. Syncing a few songs makes it rescan the library, rebuilding the file.
  • TheKackler Level 1 Level 1 (0 points)
    4/12/2010
    PC: Windows 7
    iTunes: 9.1.0.79
    iPod Touch: 3.1.3

    EVERY TIME iTunes updates, it screws something up...

    I've been having the 'no content' problem (since the last update) and it drives me crazy because I update my podcasts daily for my 40 minute drive to work. I get to the car and wham... 'no content'.

    i've tried deleting/reinstalling ipod drivers... sometimes it helps but not always.

    I had customized the names of my iPods (i have a few in the household) to tell them apart. I notice that the custom name of my iPod Touch was reset after the last update! I assumed it was a fluke, but the customized name NEVER came back. Luckily i had bought one song on via the iPod touch and a playlist was created with my custom name. I changed the iPod name back to my custom name and I haven't had a 'no content' problem since... It has only been a few days and a few syncs but it is reliable so far...

    Try renaming your unit... it won't hurt (I think).
  • NightAvatar Level 1 Level 1 (0 points)
    pyrrhus wrote:
    There is a very simple and temporary fix here that worked for me!
    http://ipod-magic.110mb.com/no-content.php

    Good luck, but please Apple, sort this out!


    Thanks so much for the tip! I just experienced this exact same problem (on newly upgraded iTunes 9.1.0.79) and was completely at a loss. Then I came across your post and it worked for me. Cheers!
  • chestnut_herdsman Level 1 Level 1 (0 points)
    As with all posters here I encountered the no content after sync issue. I used the delete & re-add a song trick a few times but since I switched off genius playlist I haven't had the problem again in months.

    Message was edited by: chestnut_herdsman
  • gryphyn Level 1 Level 1 (0 points)
    Have to disagree. Genius is (and has been off) and I still have the "No Content" problem.
  • Trent23544 Level 1 Level 1 (0 points)
    Apple is ******* disgusting. I Buy a new ipod touch, bring it home and try to sync music with it, and i am plagued by this irritating issue. What the **** is wrong with it? The audio is there and itunes knows that it is, but it doesn't recognize it in my ipod it just says "no content" after it says "updating music library" i find it absurd that any kind of firmware could pass verification tests and this not be an error that is found! Any fix? Then please tell me, i would be very grateful.

    - Trent.
  • Tasha0313 Level 1 Level 1 (0 points)
    wrotch wrote:
    So quick postscript. I loaded iTunes 9 on my laptop (virtually empty library).
    When I connected the iphone I could click on the iphone library and see the loaded content. When I unplugged and looked it is not showing up.

    So then I made as though I was going to synch content from this new library... and went all the way to the last dialog box where it asks you if you really want to erase the content.... and I said NO. Then I ejected the iphone... and low and behold... now I can see the content on the iPhone!!!! No idea what that process did... but for now it seems to have fixed the houdini and made my content re-appear.

    Just thought I would post in case someone else is in the same boat-- no content and away from their normal iTunes library.


    Thanks for posting this!!! I just had the same issue, I synchronized before I left home this morning heading to the airport. I got in my car and saw the "No Content" issue as I have seen once or twice before. In a panic I googled the issue, found this post, downloaded iTunes to my work laptop which I don't use for synchornizing my phone with & then connected my iPhone. VOILA! My music was there....

    Apple I realize that you're about to release yet another iPhone that most of us will go out and buy but c'mon now - you REALLY need to get this fixed.
  • McLovin_77 Level 1 Level 1 (0 points)
    I'd like to repost somebody's ad-hoc solution:

    http://discussions.apple.com/account.jspa

    This worked for me the first time I tried it, but it remains to be seen whether it's a permanent solution.

    I am shocked and appalled that this thread has existed since September 2009 and Apple has done nothing to fix this for us. This makes me want an Android for my next phone...just sayin'.
  • edwardaggie98 Level 1 Level 1 (0 points)
    I had the same problems, too, all of a sudden today. Mine would do "updating library" on the phone, and then say "no content." When I looked under the iPhone's list within iTunes, everything showed up - just not on the phone

    I tried some of the solutions in this thread (such as adding a space or other content in the lyrics field of a song), but this is what worked:

    I unticked the "sync podcasts" box under the Podcasts tab in the phone's menu in iTunes. Pressed Apply. After the sync, all my music was back on the phone but not podcasts (because I had told it not to sync them). Then, I just re-ticked the "sync podcasts" box and pressed Apply again, and it was all there!

    FWIW, I had an odd error this morning - the phone was in airplane mode with wifi off and bluetooth off ... but it gave me a warning that "this device is not compatible with this iphone" - even though it wasn't connected to anything! Wonder if that's related.
  • McLovin_77 Level 1 Level 1 (0 points)
    This hasn't been a problem since the new iPhone 4.0 update. Anybody else?
  • Mattazuma Level 1 Level 1 (0 points)
    Not fixed in iOS4. I got the "No Content" error today on my iPhone 3G.
  • wellthissucks Level 1 Level 1 (0 points)
    nope, not fixed. running 4.0 on a 3GS phone and the latest itunes... went to bed with about 7 gigs of music and woke up to no content. I'm really disheartened and upset that there appears to be NO fix for this...and I'm not even sure what I did wrong, as there was literally no interaction with the phone between when it was working and when it wasn't.
Previous 1 14 15 16 17 18 Next