Skip navigation
This discussion is archived

No Content in iPod part of iPhone after syncing with OS 3.1 and iTunes 9

166605 Views 288 Replies Latest reply: Jan 8, 2011 3:25 PM by UFGUY RSS
  • j.p.k. Calculating status...
    Got the "No Content" problem today, first time. iPhone 3G, iOS 4. Happily listening to an audio book on the way home from work last night, using the Bookmark app. Plugged in to recharge, did NOT sync, made one phone call, woke up, everything is gone.
    3G, iOS 4
  • wpoll Calculating status...
    Happened to me too - no content, apps won't install as 'are not signed for' (they are all free btw), and restore doesnt work. brilliant. oh and i would phone customer support, but oh no i have to pay. another triumph for Apple, well done.
  • wellthissucks Level 1 Level 1 (0 points)
    funny coincidence that the last three people to have this problem were from chicago (including myself)
  • wellthissucks Level 1 Level 1 (0 points)
    Ok this is REALLY bizarre, but I may have found a solution! I've been struggling with the "no content" error all week, I've reinstalled itunes twice, restored my iphone (3GS) at LEAST five times, and even had my phone completely replaced by a stumped genius bar worker after two unsuccessful appointments.

    What I've found is that when I sync my ipod while Zonealarm is running, it will appear as if it's syncing the music but I get the "no content" error after "updating library". Once I disable zonealarm and sync, it's gone and the music appears on my phone. Just tried this three times in a row, and each time I disable Zonealarm the music syncs perfectly.

    I've also found this solves ANOTHER problem I was experiencing, where downloaded apps (even free ones) would not be installed because they were "unsigned". Not sure if this is a permanent solution but if anyone else is running Zonealarm and finds that disabling it resyncs their library, please post!

    Message was edited by: wellthissucks
    Iphone 3GS, iOS 4, windows vista
  • wpoll Level 1 Level 1 (0 points)
    Bizarre but true!!! Worked a treat!!! Disabled Zonealarm, synced and everythings there!!!

    wellthissucks you are a genius!!!!!!!!!!
  • robinbtigger Calculating status...
    I recently developed this same problem after I upgraded to iOS 4. I have a PC running Vista and iTunes 9.2 with ZoneAlarm Pro installed. I read this thread from the start and tried one thing after another without success up to an including two restores to factory settings.

    Somewhere mid-thread someone said something about turning off ZoneAlarm and a couple other posters scoffed at the solution. ZoneAlarm caused a bunch of problems with my iOS upgrade so I thought I would see if turning ZoneAlarm off during syncing would help. It worked like a charm! My iphone synced and my iPod suddenly had content. I restarted ZoneAlarm, resynced and poof I had the "no content" bug again.

    I am currently working on figuring out why ZoneAlarm is blocking access to whatever iTunes needs to run properly. I uninstalled and reinstalled ZoneAlarm Pro with the default (automatic) settings and I am still having the problem. I will probably reinstall again and walk through the settings manually to see if I can pinpoint the blockage. If I can, I'll report back here. In the meantime I will have to turn off ZoneAlarm every time I sync. What a PITB.

    -- Robin
    iPhone, iOS 4
  • Swampthing Calculating status...
    Been having the same "no content" bug show up for awhile with my iPad 3G as well as my new iPhone 4. Tried every way imaginable, but the tip given earlier about updating the GENIUS playlists through the Store option and subsequent syncing DID WORK for me. Finally got my content back, and will have to remember to always update the GENIUS if the problem recurs in the future.
    Home PC, Windows 7
  • vertigo1972 Level 1 Level 1 (0 points)
    And now me too...

    iPhone 4 just updated to iOS 4.0.1 last night. After I did that I decided to 'Reset All Settings' as this was a suggestion for getting Facebook and other apps' Push Notifications to work (another issue...)

    I then discovered that this 'Reset All Settings' problem caused an issue with Passcode Lock, which defaulted to 'Immediately' with no alternative option. The fix for this was either a restore of the phone, or use the iPhone Configuration Utility. I took the iPhone Config Util option, for speed and out of curiousity.

    Then, after leaving for work this morning , I discover that the iPod app claims I have no content on the phone. It's definitely there going by the usage figures in settings (i.e. the space is being used), but there are no songs, podcasts etc.

    Going by the size of this thread, there really needs to be a proper fix for this. I'll try the full restore this evening to see if that sorts me out for now, though.
    iPhone 4, iOS 4
  • Swampthing Level 1 Level 1 (10 points)
    Problem has resurfaced on my iPhone 4, and the GENIUS solution described earlier now fails to fix the problem. Has APPLE addressed this issue anywhere yet? This is a MAJOR bug.
    Home PC, Windows 7
  • Landsblerg Calculating status...
    I've not had this problem until ios4 update. I'm also not running zonealarm, running trend micro, so might try this bug fix and see if trend is doing the same thing as ZA.

    This also seems to happen to me randomly I have not managed to track down a pattern. It doesn't happen all the time but the one time you don't get confirm that the sync worked, it stuffs up.
    iPhone 3G, iOS 4
  • Seanyseanysaeny Calculating status...
    I disabled my Zonealarm after getting the problem of not being able to restore my Iphone 3Gs( It completely stopped working) It restored fine after turning off Zonealarm and all my content as now returned. I will be turning off Zone alarm whenever I sync in future.

    I tried this step as my phine restored fine on my friends machine which was not running Zone alarm firewall. Laugh all you want people, but my iphine now works.
    HP 6735s, Vista is poor.
  • saschulte Calculating status...
    After 2 extended calls with AppleCare, a system restore, a trip to the Apple Store, and finally a phone replacement, the problem still occurred every time I connected my phone (iphone 4 v 4.01) to my computer. The workaround solution of changing a single file or playlist worked for me as it did for many here, but that is still annoying and not a long-term solution. Taking my cue from the post about ZoneAlarm (which I do not have), I changed the settings in Microsoft Security Essentials to exclude the location of itunes folder as well as the processes itunes.exe and ituneshelper.exe. After rebooting my computer the problem vanished and has not returned after repeated testing. I am not thrilled about weakening my computer's security, but it does fix this particular problem, at least for me.
    Dell Latitude E6500
  • netronin Level 1 Level 1 (0 points)
    Any update on this. It's been a recurring issues for me as well (workaround by modifying a single file) and really surprising Apple has not fixed it considering it seems to have been an issue for many years.
    iPhone 4, Windows 7
  • rfingonII Calculating status...
    After reading this entire 17 page thread and experiencing the "No content" issue after every sync now and three restores later, I thought I should add my experience with this issue. I am running Zone Alarm (ZA) Extreme (recently updated, v. 9.3.014.000), iTunes 9.2.1.5, iOS 4.0.2, and 6.6GB worth of music (over 1300 tunes). I have had this 3G 16GB iPhone since March 2009 without an issue until I recently updated to iOS 4 (which I do not think is the cause, however).

    I do think that ZA Extreme has something to do with my issue, as on my first attempt to restore the iPhone, I could not even get my restore to complete without receiving an error. Prior to the seventh attempt to restore my iPhone, I turned off ZA. Voila, my phone was restored with no errors, and my library was back. But since then, every sync (ZA was running) gave me "NO content" when running the iPod app. Ultra frustrating! I have not yet tried re-syncing with ZA turned off, and I am reluctant to do so now considering that it takes my iPhone about an hour to restore fully (very sucky road to go down for adding ANY content to your iPhone). You better believe that I will turn off ZA before the next sync session.

    I feel it is also worth mentioning that my iPhone/iPod has recently started skipping occasionally when playing my uploaded KQRS Morning Show. A couple of recently ripped CDs have also had skipping tracks. I still have to rule out the ripping DVD player as the issue for the CD track skipping (just cleaned the laser on the player), but a skipping downloaded set of MP3s from the KQRS website? Not cool.

    My biggest beef on troubleshooting this problem is that since my iPhone is now old, the only Apple support I can get is if I dish out money to Apple Care. I think this really ***** because I am confident that this is a software issue that is out of my control, but I have no say to Apple about it unless I pay them. What a bunch of BS!! Also, I have been running ZA longer than I have had my iPod (160GB with no issues whatsoever, synced on an XP machine) or my iPhone. Why is ZA an issue now?

    There is my two cents. OK, so maybe I gave you four cents worth instead!
    hp dv9428nr laptop, Windows Vista, 32-bit Home Premium 3 GB RAM

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.