12 Replies Latest reply: Sep 24, 2009 9:37 PM by alindar
disneyjen Level 1 Level 1
I wish I had not downloaded iTunes 9. When I synced my iPod to the new update the playlist I have of Podcasts is now sorted by Artist, when in iTunes it is sorted by date, which I prefer. Also, other playlists containing podcasts (like KEXP Song a Day) push those items to the bottom, and again sort by artist.

If this is how it's going to be in iTunes 9, is there a way to get 8 back?

PC, Windows XP
  • Sandra A Level 1 Level 1
    Until things get better you can make your own playlist of your podcasts and put them in order you wish.
  • disneyjen Level 1 Level 1
    Yeah ... I had that ... in iTunes 8, but the new upgrade doesn't keep the sort with the sync. So even though it is sorted correctly on iTunes, when I sync my iPod it re-sorts the play list by artist on the pod, sorted correctly in iTunes, not on the iPod. Can't figure it out.
  • JakeP Level 1 Level 1
    Yes, I just posted a question exactly like that. I'd organized a playlist of podcasts and it disappeared. Though iPod defines a Podcast category, the list is out of order and not playable in succession without scrolling and selecting each time.
  • iszlq Level 1 Level 1
    I agree, I want 8 back. Itunes 9 screwed up everything on my ipod.
  • iszlq Level 1 Level 1
    I think this will help you. Go into the playlist in iTunes 9 that has your podcasts in it and highlight all them. Right click and choose Get Info. Then go to Options. Change the media type from podcast to music. That should cause your playlist to reappear on your Ipod. If you have a lot of them (like I do) it will take a while for them to download all over again to your ipod. You may need to close and reopen iTunes if you still don't see them.

    Let me know if that works for you.
  • JakeP Level 1 Level 1
    Nope; didn't work for me. The media type refused to change.
  • iszlq Level 1 Level 1
    Perhaps this has to do with the podcast itself or the way you made your playlists. I made mine manually. I noticed that when I went in to the podcast section, iTunes was wanting to download podcasts that I already have. So if your playlists are auto playlists that could be the reason.

    The podcasts I've collected are for learning a new language, so they are not time dependent. If you are looking for a continuous update, you might have to wait for Apple to fix the problem. If not, you could simply make manual playlists and then try changing the media type again.

    I sympathize with you though. My iPod was very organized before this upgrade. I will be making fixes for a while.
  • JakeP Level 1 Level 1
    Mine was a manual list: I dragged-and-dropped downloaded items to a designated playlist. This worked well until the update, so I suspect there's no workaround for the moment. But thanks for the replies, nonetheless.
  • iszlq Level 1 Level 1
    This is exactly what I had. Have you tried to change the Media Kind 1 at a time? I have no problem changing it even in the podcast area in iTunes. Do your music files allow you to change them? Maybe it's the particular podcast itself. Media Kind is under "equalizer preset" in the options tab. When you change it the podcast will disappear from the podcast area and reappear under music. I understand your frustration.
  • gubbex Level 1 Level 1
    Have same issue with my configuration:

    Windows 7 / iTunes 9.0 / iPod Nano
  • owf Level 1 Level 1
    Apple Music
    I've written a workaround for the sorting problem with synced smart playlists.


    It's a Python script that will copy smart playlists whose names end with "\[source]" to correspondingly-named normal playlists, which will sync as expected to iPods/iPhones.

    Run it before syncs and things on your iPhone should work much as before Apple borked syn.
  • alindar Level 1 Level 1
    This seems to have helped me, thanks. My problem was with the iTunes generated Smart-list, "Recently Added," which I use to play my podcasts in chronological order. It has worked for me for a long time, until this recent update.

    I noticed when I went into "Get Info" and then options, nothing was checked. So I did check them as music and now my problem seems better, but I'll be on the look-out for more problems. I do hope it's the fix I needed. It's been a crazy-making pain.