Previous 1 2 3 4 5 6 7 Next 97 Replies Latest reply: Jun 11, 2014 1:54 PM by Billsid Go to original post
  • rustys6004 Level 1 Level 1 (0 points)
    A day later and I can report the fix seems to have been successful. Deleting the contents of that hidden folder did make the Recovered Mail item go way.

    FYI, the mail that kept coming back was something I sent, and the recipient did get it, so who knows how/why it got stuck.
  • jpherm Level 1 Level 1 (0 points)
    Thank you so much VTPete! Worked Perfectly!
  • CheckOK Level 1 Level 1 (0 points)
    Thanks VTPete,

    your instructions worked like a charm.

    CheckOK
  • f3ilter Level 1 Level 1 (5 points)
    Thank you VTPete for your good instructions. Problem fixed.
    Its too bad that apple are taking so long to fix this problem.
  • Y2KNEVERFORGET Level 1 Level 1 (0 points)
    thanks for posting this, it helped me fix my mail today
  • SWallisPhoto Level 1 Level 1 (0 points)
    Worked fine for me too - accidentally attached a 32MB file and then tried to stop the send.

    I quit Mail, used Onyx to show hidden files, and then deleted the offender in the OfflineCache folder.

    I then relaunched Mail and the issue was gone - no need to remove and set up the email account.

    Thanks again!
  • The Moondoggie Level 1 Level 1 (0 points)
    I just got over the same issue! Mail kept downloading a message with file attached over & over and stored them in "recovered messages" folder. VERY annoying. After deleting mail account and "plist" and reopening my gmail account nothing happened. Weeks of troubleshooting later I turned off my airport and reopened mail. Went to preferences, then mailbox behaviors tab, in "trash" I selected, "quitting mail", and under "advanced" tab,
    I selected "don't keep copies of any messages" I then closed the preferences window and deleted the "recovered messages" folder. I then closed mail. turned on my airport, then relaunched mail. So far it has worked. The problem is definitely with the Mail program. I hope this works for all of you with the same problem.
    Norm
  • Drew Milwaukee Level 1 Level 1 (0 points)
    I have been battling this problem ever since I upgraded to SL. I have tried what Moondoggie suggested and it did not work. The only way I am able to continue to receive email is by emptying the .offline cache folder. I am required to do this several times a day to keep receiving. This was not an issue until I upgraded to 10.6.

    My apple @me account works just fine of course.

    Please find a permanent solution to this problem. Receiving email should never be this complicated. If I don't get a solution soon, I will have no choice but to use a different mail app.
    Andy
  • Drew Milwaukee Level 1 Level 1 (0 points)
    I just spoke with Apple and they provided me with a solution that worked.

    In Mail preferences, choose the IMAP account that is having the problem and choose Mailbox Behaviors. Uncheck, Drafts so that they are NOT stored on the server. Save changes to these preferences.

    Problem Solved!
  • David Wilkinson6 Level 1 Level 1 (15 points)
    I am also having this problem. At first I thought it was just annoying, but it's more than that. I am now losing messages that have ended up in the "Recovered Messages" folder.

    My setup is as follows:
    OSX 10.6.2
    Apple Mail Client
    IMAP mail account on 1and1.co.uk
    I have 2 Mail Rules set up.
    1. Every time I receive an incoming message of any sort, fire the applescript "Filter Sent Messages". This is a widely used Mail Script that simply runs all rules against the Sent Mailbox.
    2. My second rule moves anything that I have sent to a Store folder within my IMAP account.

    Symptoms of problem.

    Send an email in Mail (from me, from my 1and1 account.)
    Email sits in Outbox mailbox
    Wheel spins against Sent folder
    Mail activity pop-box shows very slow progress in completing send of "Outgoing Messages"
    Meanwhile wheel spins to indicate attempting synchronisation against 1and1 IMAP account
    During this slow progress, many copies of the email start appearing in the "Recovered Messages" mailbox.
    Eventually Send appears to have completed

    However, and this is the worrying part, I am definitely experiencing some of these messages not being sent, with no sort of warning that send has failed. Also, I am also experiencing the message being sent but my second rule (see above) failing to move the message to my IMAP store folder. If I delete the "Recovered Messages" I lose such messages completely.

    Any advice wold be gratefully received. I'd also like to know how to bring it to Apple's attention.

    Deleting Offline Cache folder is treating the symptom. It cures nothing

    Thanks

    David
  • Catwhit3 Level 1 Level 1 (0 points)
    I too am having the same problem. Recovered message keeps reloading in time machine. I cannot receive gmail in apple but can send. Have been to apple store genius bar three times and they are no help. Say its a gmail problem --from everything I am reading on here, I dont agree. Have taken IMap gmail and changed it to POP, still does not help. uNplugged, rebooted, reinstalled gmail...One month now with this problem. And yes, upgraded snow leopard.

    now what???
  • Catwhit3 Level 1 Level 1 (0 points)
    Congrats on the fix. How do I get to the library mail folder and how do I restore?
  • Iza6 Level 1 Level 1 (0 points)
    VTPete,
    Thank you very, very much for this. Finally, a fix that's easy to follow, works and doesn't take all day! I was ready to throw my laptop out a window. You saved a Mac today and a Mac user. Thanks!
  • Catwhit3 Level 1 Level 1 (0 points)
    I did the same thing Norm suggested three times and did not work. HOw do i unload t he offline cache? what is really irritating is apple says its a gmail problem!
  • Catwhit3 Level 1 Level 1 (0 points)
    It workEd! Cleared out the cache and did turned off airport and redid the mail as per the instructions! THANKS!