Previous 1 2 Next 20 Replies Latest reply: Jun 18, 2010 6:08 AM by John Kool
ncasalejr Level 1 Level 1 (0 points)
I have read a few posts on this but do not see a solution. I occasionally use Click N Ship to make labels...the PDF does not launch. I have had this problem in the past but was able to locate an icon on the left portion of the screen to get the PDF to launch. I can not seem to do that now. I have Snow Leopard.

This is not for eBay so responses should not say try, Endicina or PayPal. Thanks for the help.

iMac, Mac OS X (10.6)
  • pbeaudet Level 2 Level 2 (360 points)
    It is true that Safari does not launch Adobe Reader in Snow Leopard. However, in my case, Safari completed and printed the label on my HP C6180 without a problem. It bypassed Adobe Reader all seven times that I have used USPS CLick N Ship.

  • Barry Hemphill Level 8 Level 8 (37,065 points)
    Hello n:

    I have also printed labels from the USPS site.

    You might try using an alternate browser to see if it a Safari problem or more global. I use Firefox in similar situations.

  • ncasalejr Level 1 Level 1 (0 points)
    I actually dont have adobe usually opened in 'Preview" in the past. Maybe I will try installing Adobe. I have had this working in the past...
  • Barry Hemphill Level 8 Level 8 (37,065 points)
    Hello again:

    I just posted this elsewhere - a fix, I think.

    I found the answer to the USPS issue by talking to a really technically competent person at USPS>

    At the moment, Safari does not work. Use Firefox.

    Here is what you need to do:

    1. Be sure you have the latest version of Adobe reader installed (and only one). Open reader. Go to preferences>internet. Unclick +"display PDF in browser using"+

    2. Open Firefox>preferences>applications. Scroll down to PDF file. The window should show Adobe reader. If it has "default" after Adobe reader, select other and then select Adobe reader from the options. Close the preferences.

    3. Go to the USPS site and try to print a sample label.

    This worked for me.

  • Raul Gutierrez Level 1 Level 1 (35 points)
    We had click and ship working for several months without problems. It was even working after the snowleopard upgrade. But since the subsequent security update that included an HP driver update click and ship is not working in Safari. (When you click to print nothing apparently happens).

    The solution for now is to use Firefox. When you click you'll get a message asking you what to do with the serverlet download. You can select having it open in adobe reader in which case it will open automatically and print or you can save it to disk. If you save it to disk you must rename the file so that the extension is .pdf
  • John Linck Level 1 Level 1 (5 points)
    Cant make click n ship printing on my new macbook pro/snow leopard in either Safari or firefox. Even tried the tips above. No luck. Works fine on my old plain leopard mac.

    confused, john
  • Sawdustman Level 1 Level 1 (0 points)
    I have used click n ship for a long time and have had this problem at other upgrades but always made it work again. This time I am stymied. Tried removing pdf plugin and all other suggestions without results. Bottom line, can't use click n ship on safari in snow leopard. Of course it is possible to open the file by going to window, activity and clicking on the file itself after it loads. Hope this gets fixed soon. Hate having to use different browsers for different things. Also even when the pdf plugin is in the internet plugins folder it doesn't show up in loaded plugins in Safari.
  • pbeaudet Level 2 Level 2 (360 points)
    My previous post I said I had no problems with Click-N-ship with safari. That is still true.

    I used Click-N-Ship today. Safari (Version 4.0.3 (6531.9) printed my label without a problem. I am running 10.6.1.

    I have a 32 bit machine. Perhaps, there is something amiss with 64 bit Safari?

  • Calvin Vance Level 1 Level 1 (0 points)
    I tried what Barry without success. But, I ended up able to print labels because of his suggestion.

    I went to Adobe Reader preferences>internet and unclicked "display PDF in browser using" just as he advised.

    But when I went to Firefox>preferences>applications, I couldn't select Adobe Reader from the options. I could navigate to it, but the selection wouldn't stick.

    I tried to print test labels again, with no success.

    Later I noticed my downloads folder had several files named com.usps.cns.web.pdf.LabelGenerationServlet. They were the test labels I had tried to print.

    I checked back in Firefox>preferences>applications and saw that PDF file was set for Save File.

    Just delete the LabelGenerationServlet extension and Preview will open them.

    I then went back to the USPS site and printed my label. I kept the USPS page open. I then opened the file in my Downloads folder and printed the label using Preview. Only then did I click on the appropriate button on the USPS page to signify the label printed successfully.

    To recap.

    1. Go to Adobe Reader preferences>internet and unclick "display PDF in browser using"

    2. In Firefox>preferences>applications set PDF file to Save File

    3. Print a test label. Keep the USPS page open.

    4. Open your Downloads Folder and delete the LabelGenerationServlet extension from the com.usps.cns.web.pdf.LabelGenerationServlet file you'll find there.

    5. Test to make sure you can print it.

    6. Now print your label. Again keep the USPS page open, DON'T click on anything in it yet.

    7. Follow steps 4 and 5.

    8. If successful, click on the appropriate button on the USPS page.

    It's a few hoops to jump through, but it worked for me.
  • StephenM Level 1 Level 1 (110 points)
    To be able to print out postage, Safari's build in PDF viewer is the root of the problem and must be turned off. This can be done in one of two ways.

    1) Use a program like Cocktail to turn off PDF viewing in Safari. In Cocktail , this option is labeled "Disable PDF Support".

    2) Do an Internet search for "Disable Safari PDF Viewing" and find the terminal command that does the same thing.

    After doing either, Restart Safari. The display of the PDF file now happens in Preview and can be printed from there.
  • Sawdustman Level 1 Level 1 (0 points)
    Thank you StephenM,
    This fixed the problem and got me back to where I was before snow leopard.
  • karenrile Level 1 Level 1 (0 points)
    I'm having an awful time of this. I used to have no problems printing these labels; after upgrading to Snow Leopard I had to switch to Firefox, but last week that stopped working. Following instructions in a discussion on another site, I used Opera last week, which worked. But now nothing works. I've spent an hour painstakingly trying all of the fixes in this discussion, but I cannot get to the print dialog box-- the USPS site stays stuck in "processing". I also spent time on and email chat box with a USPS rep but he had nothing to tell me (he thought "snow leopard" was a kind of browser. Very disappointed because I've been relying on this service to save a tone of time at the post office.
  • ipaqrat Level 1 Level 1 (0 points)
    Me, too; Thanks StephenM: positive fix for my snow leopard safari problem with USPS Click & Ship. TOTAL SOLUTION!
  • odonusa Level 1 Level 1 (0 points)
    THANK YOU ipaqrat!!! That really was a total solution. Worked out of the gate.
Previous 1 2 Next