Skip navigation
This discussion is archived

Updated to itunes 9:  now Airtunes won't connect,

57083 Views 119 Replies Latest reply: Oct 10, 2010 4:32 PM by GoPSU2 RSS
  • david4c Calculating status...
    I am a FIOS customer with Verizon Actiontec MI424 wireless router. I have 2 AE n-version for streaming itunes connected to a family room home theatre and a small sony receiver on my deck.

    I upgraded to itunes 9 and completely lost my airtunes.

    I tried reconfiguring the AE's but had no luck.

    I tried deleting the \library\preferences... but that didn't work

    tried reapplying the firmware - no good

    hard reset/soft reset..... no luck

    I decided to turn the firewall off, then rebooted, turned it back on and somehpw that seemed to do the trick.

    Thankfully I'm on my deck around a nice fire watching the game and listening to some Cake.

    Sometimes you have to "go the distance" to fix this stuff..... Thanks to all the contributors for giving me some ideas on how to fix this. Let's hope for a fix from Apple soon.
    MacBook, iBook, iMac, Mac OS X (10.5.8)
  • dskilken Calculating status...
    I have a TimeCapsule Airport Extreme base station, and an older Airport Express (b/g). Intermittent connection with all iTunes copies in the house. Sees the airtunes on the Express, but either no music, or music with static. I was able to fix it once by restarting the Airport Extreme/TimeCapsule, but this time to fix it, I had to factory reset the Airport Express by putting a pen/pin in the reset button, and plugging it in and holding it till it flashes green and then back to orange. Then I fired up the Airport config software and reconfigured the Airport Express to extend my network. This seems to have returned the music. Still get some static. This is quite intermittent. It is making me look for my CDs and see if I remember how to use a CD player...
    MacBook Pro
  • Great Greyhounds Calculating status...
    Currently Being Moderated
    Oct 19, 2009 6:17 AM (in response to david4c)
    All,

    Here's what I did to correct this problem:
    MBP 17"
    MB 13"
    Airport Extreme 'N'
    Airport Express 'N' with Speakers
    Airfoil 3.3.4
    iTunes 9.0.1
    Snow Leopard 10.6.1

    With the new iTunes update, couldn't stream music to the Airport Express, even after upgrading it to the latest firmware, from either Mac.

    Added the AirFoil 3.3.4 to the Firewall, under system prefs->security, still nothing.

    Turned Firewall off with iTunes running, and was able to connect to the Remote Speakers without the '-15000' error.
    Turned the Firewall back on, and the music continues to stream.

    This also works with AirFoil.
    Seems that cycling the firewall off, connecting to the airport express, firewall on, allows for the speakers to work.

    Go Figure....
    MacBook Pro 17"/2.66Ghz/4GB, Mac OS X (10.5.6), Glossy Screen
  • Joe-ri Calculating status...
    Currently Being Moderated
    Oct 20, 2009 8:06 AM (in response to stephbu)
    I experienced the same problem since the iTunes 9.0.1 update.
    When I start iTunes, iTunes start connecting to my Airport Express but fails to connect and start to play through my internal speakers. No error messages, so I had no clue what went wrong.

    Tried to solve it by removing "/Library/Preferences/System Configuration" which solved my problem, temporary. After each reboot/shutdown (for example after returning from Boot Camp), the problem returned.

    Today I started to get so frustrated, I started a deep investigation.
    I remembered a "long" time ago (guess iTunes 7), the same problems occurred and the most common fix for that issue was by disabling the ipv6 ability of your Airport configuration.

    I just tried it and fixed the issue almost immediately . Haven't tested after rebooting, but I'm confided having solved the issue permanently. (I'll post the result later on).

    So people; when you have problems with iTunes not connecting to your Airtunes maybe you can try the following:
    1. Open System Preferences
    2. Open Network pane
    3. Select Airport in the left list
    4. Click the Advanced button
    5. Go to the TCP/IP tab
    6. Set the "Configure IPv6" field to Off.
    7. Click "OK"
    8. Click "Apply"
    9. Let iTunes connect to you're Airtunes speakers

    My environment:
    Macbook White (Mid 2007), Mac Os X Leopard 10.5.8
    Airport Express (without 'N'), firmware 6.3
    Firewall "Set access for specific services and applications:" (Specified to allow incoming connections for iTunes).
    iTunes 9.0.1

    Hope this post will solves or at least helps to solve this issue.
    Macbook White (Mid 2007), Mac OS X (10.5.8), Ipod Touch (2nd Gen), Airport Express
  • jbigane Calculating status...
    Currently Being Moderated
    Oct 21, 2009 1:55 PM (in response to Joe-ri)
    Brilliant! I've been beating on my Airport Express configs for days. I have one 802.11n AE and a 802.11g AE and couldn't get iTunes 9 to play out of the 802.11g one for days. Turning off ipv6 did the trick perfectly.

    Thanks for the suggestion!

    John
  • kargoyle Calculating status...
    Currently Being Moderated
    Oct 22, 2009 6:47 AM (in response to Joe-ri)
    Fantastic Joe-ri! Worked immediately!

    One question. Not being a network guru, I'm not sure when I might be needing IPv6. What issues might crop up from this setting being in the off position?
    Mac Mini / Powerbook, Mac OS X (10.6.1)
  • mpdajo Level 1 Level 1 (30 points)
    Currently Being Moderated
    Oct 22, 2009 10:49 AM (in response to kargoyle)
    Is IPv6 required for Back to My Mac?
    Power Mac G5,Macbook Pro,Macbook,iPhone 3G, Mac OS X (10.6.1)
  • olico Calculating status...
    Currently Being Moderated
    Oct 23, 2009 10:50 PM (in response to Joe-ri)
    It works fine.
    Thank you very much.
    --
    olico
    MBP 15' Unibody, Mac OS X (10.6.1)
  • BobKetcham Calculating status...
    I've been having a similar problem. I have a mixture of 5 N and G Airport Express Units fed from a mixture of Macs and PCs all with iTunes 9. The problem occurred N to N, G to G and N to G using the Macs. I solved it before I determined if the PC had the same problem.

    iTunes 9 / Airtunes to the remote Airport Express would play for 2-3 seconds then quit. Sometimes, error messages reported the remote Airport Express could not be found. I tried many of the suggestions posted (IPV6= off, Firewall toggle), all with with no improvement.

    To finally solve the problem, I reconfigured the AE from "Participate in WDS network" to "Join a wireless network". The problem went away.

    There was a time when the only way to get Airtunes to work with the original AEs was to use WDS. I had been assuming that was still required for Airtunes.

    Without WDS you will lose the ability for the remote AE to extend the wireless network. I had that turned off anyway, the three Ethernet connected AEs cover the house. I just tested iTunes 9 from the Ethernet connected PC and could stream to the computer, one stereo connected to a wired AE and two stereos connect to remote AEs simultaneously.
    MacBook Pro, PC, PowerMac G4...
  • ArchiTexTerry Calculating status...
    Currently Being Moderated
    Oct 24, 2009 2:53 PM (in response to PinkyViko)
    Same exact problem here...Macbook with clean install of Snow Leopard and iTunes 9.0.1 and went to listen to my music over the home stereo system, tried to connect to my speakers, and got the following message "An error occured while connecting to the remote speaker the network connection failed."
    MacBook 1.83 Core 2 Duo, Mac OS X (10.6.1), Airport Experss 6.3
  • Michael Seavello Calculating status...
    Currently Being Moderated
    Oct 24, 2009 3:54 PM (in response to gurghi)
    I've have a similar problem.

    I try to activate "Remote" from my iPhone & my iTouch. Neither can connect to my MacBook. I delete my iTunes Library & try to add it again. I enter the 4 digits, but neither the iPhone & iTouch will connect. I close & reopen iTunes, with no success. I restart both devices, but still no luck. This happens if only 1 device is on & when both are on.

    If I restart the MacBook, I can connect, but only for a short time.

    Since the problem affects both of my devices, I assume the problem is with iTunes.
    2.53 GHz, MacBook Pro, Mac OS X (10.6.1), iTunes 9.0.1
  • brecken Calculating status...
    Just bought a new laptop loaded with Windows 7 at Best Buy. Installed iTunes and it recognizes my Airport Express (lit wiht a green light) but won't connect - just hangs on "Connecting to User's Airport Express".

    Tried a few suggestions: disabling firewall, unplugging, resetting AND reconfiguring the AE, no luck.

    Can anyone help? Thanks.
    Gateway, Other OS, using Windows 7
  • bobotski Calculating status...
    Currently Being Moderated
    Oct 29, 2009 5:04 PM (in response to brecken)
    A new version of iTunes (v9.0.2) is out, and you'd think that Apple addressed this issue by now. The answer is NO. My Airport Express is still a BRICK. So much for Apple's quality and product support. Airtunes was not built for Windows and iTunes 9, period.
    Windows XP
  • Mouse213 Calculating status...
    My Airport Express was a brick whenever I had security on it and fine when I took it off. After the most recent update it's working fine.

    Recently tried to use Airtunes and it had stopped working. I uninstalled my antivirus and it's working again now. Pretty sure that's the problem for most people here

    Message was edited by: Mouse213
    Windows Vista
  • Kenneth Kirkpatrick Calculating status...
    This trouble is not just with Windows. I have an all mac set up with 3 airport expresses and an airport extreme. I have Snow kitty on all 4 computers and the latest Itunes update. Airtunes is broken. It will work, then if I pause a song, I will get the same error message 1500... This ****** me off. I have used Airtunes for years with little to no trouble. I update my software, and now it is broken. No changes in the hardware anywhere in the system. Iphone remote has trouble finding the Itunes library as well at times.

    Ken
    Macbook, Mac OS X (10.6.1), airport extreme, 3 airport expresses-g's
1 ... 4 5 6 7 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.