Skip navigation
This discussion is archived

can't turn off album artwork after itunes 9 upgrade D:

16752 Views 14 Replies Latest reply: Dec 8, 2009 10:16 AM by chrisageorge RSS
mynabyrd Calculating status...
Currently Being Moderated
Sep 11, 2009 1:34 AM
Since I upgraded to iTunes 9, I can't find the option to turn off album art on my 60GB iPod Video! I have a huge library and album art takes up way too much space that could be used for music.

It turned it on by default after the upgrade-- I've looked everywhere and can't find a box, radio button or preferences panel that lets me change it. Everything that I copy now copies the album art over as well. :[

Thanks!
1.25GHz G4 Mac Mini, Mac OS X (10.5.2), 1GB DDR SDRAM
  • brad_14 Calculating status...
    ahhhhh same here! They need to put it back on the next update >:o
    sony vaio, Windows Vista, 30gb iPod Video
  • Jeff Bryan Level 9 Level 9 (61,785 points)
    It seems as if Apple decided to remove the ability to turn off syncing of album artwork in iTunes 9. Use the following link to let Apple know your thoughts.

    iTunes Feedback.
    iMac 20" 2GHz Intel Core Duo; 2GB ram;, Mac OS X (10.5.7), 1TB Time Capsule iPods:Touch/Video/Nano.
  • teddy k123 Calculating status...
    New iTunes update, no ability to remove album art from iPod. Try again Apple.
    MBP 2.33GHz Intel Core 2 Duo, 2GB 667 MHz DDDR2 SDRAM, Mac OS X (10.5.8), video iPod 30gb, Airport Extreme & Express BS
  • Bex_y Calculating status...
    It is so frustrating... Most my music has album art and only random album art display like 1 in 30 albums is actually show on my ipod. I would rather fill the space with more music. I'm considering down-grading my iTunes to version 8.
    Abided Mac Computer user (several machines), Mac OS X (10.5.8)
  • PT Level 7 Level 7 (20,870 points)
    The inability to turn off artwork is rather alarming as many times the solution to repairing an iPod that is mis-displaying artwork is to clear out the artwork cache on the iPod. This, as I am sure you have suggested to users like I have, is done by turning off artwork, sync the iPod to clear the artwork, then turning it back on again.

    With artwork no longer selectable, that would only leave less desirable options like a full restore.

    Good thing I didn't bother to update out of iTunes 8 yet!

    Patrick
    iMac 24" 2.66GHz  eMac 1.25GHz (OS 10.4.11) , Mac OS X (10.5.7),  Canon iP4200 printer  Many Ext Drives  30GB and 80GB 5th Gen iPods
  • FutureRockStar3 Calculating status...
    Currently Being Moderated
    Oct 1, 2009 9:29 PM (in response to PT)
    I'm confused here. I just upgraded to iTunes 9 yesterday and my artwork still doesn't appear on my albums until I right click and click, get album artwork so I'm not understanding about the album artwork automatically appearing.
    Windows XP Pro
  • Jeff Bryan Level 9 Level 9 (61,785 points)
    Currently Being Moderated
    Oct 2, 2009 1:27 AM (in response to PT)
    Good thing I didn't bother to update out of iTunes 8 yet!


    Me neither.
    iMac 20" 2GHz Intel Core Duo; 2GB ram;, Mac OS X (10.5.7), 1TB Time Capsule iPods:Touch/Video/Nano.
  • PT Level 7 Level 7 (20,870 points)
    FutureRockStar3 wrote:
    I'm confused here. I just upgraded to iTunes 9 yesterday and my artwork still doesn't appear on my albums until I right click and click, get album artwork so I'm not understanding about the album artwork automatically appearing.


    In this case we are talking about artwork on iPods. Under iTunes 8 (and previous) you had the choice of syncing artwork to the iPod with the music or leaving it off (to allow more room on the iPod which could be used for more music). This all assumes the artwork is already present in iTunes. So it was the ability to turn ON/OFF the sending of artwork from iTunes into the iPod which apparently has been removed under iTunes 9.

    Patrick
    iMac 24" 2.66GHz  eMac 1.25GHz (OS 10.4.11) , Mac OS X (10.5.7),  Canon iP4200 printer  Many Ext Drives  30GB and 80GB 5th Gen iPods
  • vpkb Level 1 Level 1 (40 points)
    Currently Being Moderated
    Oct 3, 2009 6:23 PM (in response to PT)
    This is annoying me too. I use my iPod with my Kenwood car stereo and the the artwork is slowing down the operations. There's a noticeable lag because the artwork is trying to load.

    Come on Apple, give us the option back. I sent in a feedback already, I hope it's for something.
    iMac aluminum 2.4ghz & MBA Rev. A, Mac OS X (10.6.1)
  • Michael Wiggins Calculating status...
    Try CTRL G (Windows)
    or
    CMD G(MAC)

    That will toggle the Artwork Tab.

    Hope that helps.
    HP 5800, Windows XP Pro
  • PT Level 7 Level 7 (20,870 points)
    Michael Wiggins wrote:
    Try CTRL G (Windows) or CMD G(MAC)

    That will toggle the Artwork Tab.


    Which has nothing to do with turning on and off the loading of artwork onto an iPod.

    Patrick
    iMac 24" 2.66GHz  eMac 1.25GHz (OS 10.4.11) , Mac OS X (10.5.7),  Canon iP4200 printer  Many Ext Drives  30GB and 80GB 5th Gen iPods
  • dbfreedom Calculating status...
    I found this problem because I tried to use Sharepod, and it crashed with a message talking about the artwork. Tried to turn it off in iTunes, and found the same problem.

    However, if you go into the iPod and delete the Artwork folder in iPod control (after un-hiding it) it brings your space back, and makes Sharepod work again.

    You folks probably know all this.
    Other OS
  • chrisageorge Calculating status...
    Depending how 'technie' you are, you can do one of the following:
    OS X:
    1. Open a terminal
    2. type in cd /Volumes/<Name of ipod>
    3. cd Ipod_Control/Artwork [you can use ls -la to find the correct directories]
    4. rm -rf *

    Option 2 OS X:
    1. Look up how to turn on show hidden files/folder in OS X
    2. Double click ipod from desktop
    3. Find folder and delete

    Windows:
    1. Open cmd prompt [or in their explorer turn on 'show hidden folders'
    2. Open ipod from desktop/explorer
    3. Find directory and delete.


    Note: This *will not* stay if you 'auto sync'
    iMac 24" 2.8 GHZ C2D, ATI 2600HD, Mac OS X (10.6.1)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.