Previous 1 2 3 Next 32 Replies Latest reply: Nov 30, 2009 6:56 AM by Cookdorf
wastedyuthe Level 1 Level 1
I am not sure what the culprit was- whether it was iTunes 9, iPhone firmware 3.1, or a hardware issue on my 3GS. But Wednesday evening I installed iTunes 9 and firmware 3.1 with success on both. Thursday (yesterday), my iPhone functioned properly all day until about 3:30pm, when I took it out of my belt clip and it had an error saying it couldn't make or receive incoming calls, and that I should connect to iTunes and restore.
So, after connecting it to iTunes, it comes up with an error message saying "iTunes cannot activate your iPhone because the SIM card is not inserted or a SIM PIN is required". After checking the SIM card and trying again, I called Apple Support, and a nice man guided me through putting it into recovery mode (holding Home when connecting to the Mac), and restoring, only for it to come up with yet another error message, saying it can't restore "Error (23)". We tried downloading firmware 3.1 again and even trying on my other Macbook, to no avail. He therefore made an appointment for me at my local Apple Genius bar. It looks like I may have to swap to a new device if they can't sort it out.

Firstly, has anyone else had this issue since 3.1? This is the first time this has happened to me, and it seems too much of a coincidence that I have only just updated it. It is NOT jailbroken or hacked in any way, fyi.

Secondly, if I do have to swap to a new device, am I able to restore from the backup of my old device so I get to keep all my save data?

Macbook Pro iPhone 3GS 32GB AppleTV, Mac OS X (10.5.7)
  • hexonxonx Level 4 Level 4
    I had this happen with my 3GS almost a month ago. No amount of trying to restore would work and the Apple Genius claimed he had never seen anything like it.

    My iPhone was bricked with the error 23. I plugged it into XCode and it failed to restore saying there was a radio failure. There was no 3G, no WiFi no edge and no bluetooth. They were all grayed out in settings. Apple replaced my phone with no problem. This is what you will end up having to do as well.

    You will be able to restore from your previous backup.
  • wastedyuthe Level 1 Level 1
    Did it happen to you after an update?

    Once you had the replacement device, did you manage to restore from a previous backup, or did you set it up from scratch?
  • hexonxonx Level 4 Level 4
    I had this happen after i restored my iPhone to a previous restore that was jailbroken. I also restored the new iPhone using that same restore and have had no problems.
  • AGR99 Level 1 Level 1
    Im having the same problem they said i have to mail my phone in something about the processor overloaded so it shut down in order to keep from frying and has to be fixed from the inside but i never updated to 3.1 it did this running on 3.0 i was just looking at my maps and then it bricked
  • Dave Hutch Level 4 Level 4
    Same problem. Was playing the iPod and had driven for a couple of hours using Maps.
    It id get a bit warm so I switched on the air vents in the car that blow directly onto it in its holder.
    Told me it could make or receive calls and needed a Restore.
    Hasn't worked since, saying there is no SIM or it is SIM locked.

    Should I visit Apple or O2?
  • wastedyuthe Level 1 Level 1
    Well I figured O2 would just blame Apples firmware, so I went straight to Apple, booking an appointment at the Genius bar. After a quick check and confirming it wouldn't restore even in recovery mode (hold the Home button while connecting to the computer) they immediately gave me a new iPhone instead. Went home, updated to 3.1, then restored from Backup so I didn't lose anything.
  • Dave Hutch Level 4 Level 4
    Will give them a call and arrange to go in tommorow. Hope they have a 32GB white one?!
  • wastedyuthe Level 1 Level 1
    Good luck. Let us know how you get on.
  • Dave Hutch Level 4 Level 4
    They can't even fit me in for a 10 minute appt. until Fri. evening!!?
    Fed up now
  • Joost40 Level 1 Level 1
    I got the same problem - can´t activate (says defect simcard) and can´t restore get code 23 in DFU mode and in Recoverymode it says defect simcard or locked sim.

    Happen using my iPhone and Navigon today on a trip from Hamburg to Denmark.
    Lost GSM-signal and then lost GPS-position, and got a message to connect iPhone to iTunes to restore it.

    BUT I can´t do nothing....?

    Bought the iPhone simunlocked from VODAFONE in Italy this summer...
  • Joost40 Level 1 Level 1
    Apple won´t help out? Because I bought the iPhone in Italy/Vodafone.

    Vodafone Italy don´t have an emailadress and numerus calls to the Vodafone One store in Perugia did not get me any further? No answer?

    Now I have a 719 Euro paperweight - that can´t do nothing - what could one do?.
  • akarelin Level 1 Level 1
    Apple will help out. As long as the phone hasn't been jailbroken and is on warranty, they'll take care of it.
  • Joost40 Level 1 Level 1
    I hope you are right - I just shipped it with tracking to the Vodafone One store in Perugia Italy, and hope they will help me out...

    No its not jailbroken and yes I bought it june 29. th in the Vodafone One store in Perugia, on my vacation.
  • Saul Neutel Level 1 Level 1
    I was driving today with my iPhone 3GS 32GB, using NAVIGON and I got the same error message to restore my iPhone. Restored on my iMac and got error 23, tried a windows PC, same problem. I took it into VODACOM, they said they will replace it!
Previous 1 2 3 Next