11 Replies Latest reply: Sep 14, 2009 3:19 PM by harleydocdavidson
Kris Jones Level 1 Level 1 (55 points)
I recently tried to upgrade my father's machine to Snow Leopard. On doing so I found it was unable to access his broadband connection. None of the network settings had changed since Leopard but nevertheless, I decided I should access (and if necessary, reconfigure), his modem to correct the problem. In common with most other broadband modems, his D-Link 300T has the address 192.168.1.1 which I duly entered into Safari. I was confronted with an error message telling me there was insufficient memory allocated. It invited me to send a bug report to Apple. I tried Firefox and it too could not access the modem.

Since I was unable to resolve the issue I downgraded to 10.5 using a Time Machine backup. On restarting the machine connected to the broadband network with no difficulty. I double-checked the network settings. In doing so, I noticed one oddity. Network Preferences showed the router address IP was the same as the external IP. I tried to correct that both in Network Preferences and via the modem configuration pages. The modem itself showed the address as 192.168.1.1 as expected.

I tried installing Snow Leopard again and the same problem occurred. I took a screenshot of the error message Safari presented when trying to access the modem, but unfortunately didn't have the foresight to save it elsewhere, so it was lost on restoring back to 10.5.

Has anyone any ideas as to what the problem might be? Like many my father regards me as his "help desk", so it is useful for him to have the same OS as me.

For reference, he has an iMac 2GHz Core 2 Duo. 4GB of RAM and connects to broadband via a wired ethernet connection using a D-Link DSL-300T modem.

Any help will be most gratefully received.

iMac 1.83Ghz Core 2 Duo 17 inch, Mac OS X (10.5.5), Boot Camp 2.0. Windows XP Pro SP3
  • donv (The Ghost) Level 5 Level 5 (4,600 points)
  • Kris Jones Level 1 Level 1 (55 points)
    Thanks for that. I'd previously overlooked that thread because it seemed to relate to wireless access. Nevertheless I've looked through carefully and I see that DNS seems to be a common problem. I'd previously been using OpenDNS so I've removed their numbers from the setup. However, I still have a DNS number that is greyed out and I'm unable to remove it. Looking through the modem log, it appears that number is generated automatically from the connection (the log shows primary and secondary DNS numbers and the primary is the one that is greyed out in the Network Preferences). I'll try another upgrade this evening when nobody wants access.
  • donv (The Ghost) Level 5 Level 5 (4,600 points)
    You are very welcome. I hope your next effort works a treat.

    Message was edited by: donv (The Ghost)
  • Kris Jones Level 1 Level 1 (55 points)
    I tried upgrading again, though regrettably without success. There was however, some progress. I was able to access the modem configuration page through Safari and Network Diagnostics showed the ethernet connection was working and the ISP recognised, but with no Internet or network access. I think in those circumstances I need to check with the ISP provider before I proceed any further. Nevertheless, I'm still baffled as to why things work when downgraded back to Leopard.
  • donv (The Ghost) Level 5 Level 5 (4,600 points)
    Your experience is very common. SL is one of those things that I think to myself, "gee didn't anyone try it." But, it's all working well for me. I guess I was dealt a lucky hand.
  • Mike Hubbard Level 1 Level 1 (5 points)
    I think you will find it seems to be the router, but I dont know why.

    I have exactly the same problem with a D-link DSL 320T

    See my problem...

    I upgraded my perfect 10.5.8 system to Snow Leopard, and, it left me without an internet connection.

    I tried everything I could think off to restore this but had no luck with anything. Details of problem:

    Ethernet router/modem DLink 360T
    Network settings showed a connection and valid IP
    Could not access any webpages in any browser
    Could not ping any ip addresses - returned a "could not allocate memory" error
    Attempting to access router using 192.168.1.1 returned same error
    Could access the CUPS pages
    Could ping 127.0.0.1 (loopback)

    I just let the installer run with no options selected, can't understand the memory errors.
    Is this a router isssue?

    Safari reported an: NSPosixErrorDomain12:Cannot allocate memory
    message whenever attempts to access the router using 192.168.1.1

    Tried reseting router - this did not help (Router = D-Link DSL-320T)

    Re-installed SL on a blank external HD, did not migrate any accounts, upgraded to 10.6.1.

    Internet problem still exists, so fitted an alternative router (Thompson TG585).

    Everything now works.

    Anyone know why?
  • Pauline Scanlan Level 1 Level 1 (10 points)
    Hello there

    I upgraded to snow leopard on the weekend. My set up is exactly the same as your father's. I spent an infuriating four hours over two days trying to reestablish contact with the internet as a result of this upgrade. I read all the techie info on these discussion forums and tentatively tried a few of the ideas but nothing worked. One point came up a number of times in the threads - that the router could be the problem. In my un-techie mind I decided that maybe my router was too old for all the swishy new stuff going on with the new Operating System. Probably illogical - but anyway as a last resort, and before I threw everything out of the window with rage I unhooked my Dynalink ADSL router (which was about five year's old) and hooked up a new one - a Thomson.

    It worked.
  • mileygwen125 Level 1 Level 1 (0 points)
    until they fix these internet,facebook,twitter,wireless printers and all the problem I downgraded back to 10.5 an everything works normal again! way to go sl lol. If anyone hears about an update let us all know =)
  • donv (The Ghost) Level 5 Level 5 (4,600 points)
    Watch out for the update too.
  • Mike Hubbard Level 1 Level 1 (5 points)
    I've had the same problems, and this fixed it (for a DSL-320T):

    I found a firmware update on D-Link support that fixed a connection issue. This jogged my memory, I remember playing with Boot Camp and a copy of Vista - I couldn't connect to the net under Vista, but when I reconfigured to XP it was fine !!

    So, I've upgraded the firmware to the Vista fix - and, it now works in Leopard and Snow Leopard.

    Strange or what ....

    This tech note might enable someone to explain why:

    +Due to certain changes in Microsoft Windows Vista, it has becomenecessary to take additional steps to use the DSL-300T or DSL-320Tin some circumstances.+

    +There are a number of ways to resolve these issues:+

    +1) If you are using the DSL-320T and are stillable to access the web configuration interface, you can upgrade thefirmware to a newer version that adds Windows Vista support. Pleasefollow this link to download the file.+

    +2) If you are unable to access theconfiguration, or are using the DSL-300T, click on the Start menuand enter the following command into the search box:+

    +route -p ADD 0.0.0.0 MASK 0.0.0.0 192.168.1.1+

    +Run the command by pressing the Ctrl and Shiftkeys at the same time as the Enter/Return key. You shouldsee a dialog box pop up, asking you to confirm that you do want torun the command. Confirm that you do.+

    +You should then be able to configure the modem and accessthe Internet.+

    Really odd, but fixed.
  • harleydocdavidson Level 1 Level 1 (0 points)
    down here in Chile I got the same problem after installing snow leopard, I couldn´t connect to the internet, though the diagnostic said the airport was working right and the wi fi signal was ok. What´s the solution, help please.