14 Replies Latest reply: Dec 13, 2009 12:29 AM by BadBrad130
Matthews77 Level 1 Level 1 (0 points)
One problem and three questions:

Problem: Apple Mobile Device Support will not install, even after two days of working my way through the forums and trying everything, even system restores have been unable to fix the problem.

Question 1: Is there any other advice out there that might work that I have not tried yet?

Question 2: As the iPhone is my first Apple product, I've never dealt with Apple's support before, but does it only extend as far as having good Samaritans on the Internet provide help? I've checked the support pages and it's clear I'm not entitled to any direct help from Apple.

Question 3: If I stop trying to solve this problem myself, will Apple fix the problem and inform us that the problems with iTunes have been fixed or will my iPhone be unable to connect to my computer forever?

Hewlett Packard PC and iPhone 3Gs, Windows Vista
  • Matthews77 Level 1 Level 1 (0 points)
    I guess that answers question 2.

    Bring on answers to 1 and 3.
  • jam1983 Level 1 Level 1 (0 points)
    I've had what sounds to be the same problem as you since Friday. Everything would install correctly except Mobile Device Support - It nearly finishes installing then just rolls itself back and leaves little clue as to why!

    I've tried absolutely everything I can think of and which i've seen posted on forums. In the end I put it down to running Windows 7 and a half baked installer package by Apple.

    Ended up simply removing iTunes 9, and going back to iTunes 8.2 - Which works fine.

    Word of warning though, I did try to upgrade my firmware to 3.1.0 (from 3.0.1) using iTunes 8.2 - However this went majorly wrong and I needed to restore everything which took over 2 hours!

    I'm going to hold fire for an update to iTunes 9 - With the hope that Apple will resolve the problem in a future release!
  • dg3274 Level 1 Level 1 (0 points)
    Exact same problem here. Are either of you using 64 bit Vista too? I'm wondering if this particular problem is just with Vista 64 which may be why we don't see too much information about it yet.
  • jam1983 Level 1 Level 1 (0 points)
    No, I'm using windows 7 32bit. Think I'm just going to rollback to xp for the time being - hopefully that'll fix it!
  • pjordan Level 1 Level 1 (0 points)

    I posted in the other thread about this.

    I had the same problem on Vista x64. To get it to install, I had to login to the Administrator Account, then open an elevated (administrator) command prompt, and run the AMDS .msi package from that window.

    It work, then forced a reboot. Seems to be working fine now.
  • dg3274 Level 1 Level 1 (0 points)

    Darn. I was really hoping that would work... but it did't. Thanks for the suggestion though. That's one thing I did forget to try.

    Edit: I just read the other thread and saw you mentioned the elevated CMD prompt doesn't work from your regular account but did from the Administrator. Actually, I didn't try it that way! I will give it go and report back soon. Thanks!

    Message was edited by: dg3274
  • dg3274 Level 1 Level 1 (0 points)
    Well that didn't work after all. Oh well.
  • cbell4 Level 1 Level 1 (0 points)
    Running 32-bit Vista SP2 and same problem here.
  • dg3274 Level 1 Level 1 (0 points)
    Just tried 9.0.1. Still wont install.
  • dg3274 Level 1 Level 1 (0 points)
    Ok I got it working. Finally!

    Here's what I did:
    Open a CMD prompt and run the apple mobile device support msi file with the switch: /l*v C:\log.txt
    This will create a log file so you can see where the installation is failing. After the installation fails and rolls back open the log file at C:\log.txt and search the file for the word "fail". In my case it was failing because

    "DIFXAPP: INFO: Could not open file C:\Windows\System32\DriverStore\FileRepository\usbaapl64.inf_2f2a8112\prnms001. inf. (Error code 0x2: The system cannot find the file specified.)"

    So I searched my system for another copy of prnms001.inf and added it to the folder it said it was missing from. I had to modify the permissions on that folder (usbaapl64.inf_2f2a8112) in order to copy a file into it because it is a protected folder and only has System permissions by default.

    I then rebooted and ran the itunes installer normally and everything installed fine this time.
  • Spice9892 Level 1 Level 1 (0 points)
    For the second time, I have just spent 2hours and 43 minutes on the phone with Apple support for the same problem. Installing, uninstalling, turning off Windows defender, turning off User Account controls, everything. Nothing works...the apple support person was kind, and patient, but unable to solve the problem. The first time this occurred two months ago, it was 2 hours and repaired...and my IPhone worked fine, until yesterday, when I made the fatal error of saying YES to an upgrade of my iPhone software and blame, all went haywire, and the mobile device is no longer recognized. My phone is unusable as a phone....I'm taking this iPhone back to AT&T and getting a real phone that will interface with Windows...I'm done, what a waste of time, it's clear that Apple and Microsoft do not work consistently well together despite the marketing hype.
  • Zdravko Level 1 Level 1 (0 points)
    Same problem here, running win7 32bit, tried everything, but it just won't install the mobile support, all I want to do is getting mobile me running on it so that it will sync....

    I've uninstalled and reinstalled about 30 times with no luck....
  • mfinzel Level 1 Level 1 (5 points)
    Zdravko, don't know if you ever got this working, but I finally found a solution. Please read it here: http://randomwindowstips.wordpress.com/2009/12/08/windows-7-itunes-9-software-is -not-installed/
  • BadBrad130 Level 1 Level 1 (0 points)
    I couldn't get any of the above solutions to work for me, or any thread I've stumbled across for that matter. But, I did finally get a solution, just from trial and error. Most of the stuff below a combination of other people's suggestions, so thanks to those people who posted.

    Windows XP

    Note: The below steps should only be done with someone that is familiar with computers, otherwise, you may cause more harm than good to your system.

    Software needed (free):
    WinRar : http://www.rarlab.com/download.htm
    LessMSI : http://code.google.com/p/lessmsi/

    For me, Apple Mobile simply would not install. During the install step it reached a certain point and then started to roll back the install. I needed to see what was going on during the install.

    I grabbed the latest itunes.exe file and then opened it with Winrar. I then extracted out just the AppleMobile component and saved the msi file to my desktop. Then, I ran "Run" from the Start Menu and typed cmd to go to the command prompt. I typed: applemobiledevicesupport.msi /l*v C:\log.txt

    This creates a log file called log.txt, located in your C:\ drive, and then loads the installer.
    After the install fails, I opened the log file. I searched for the word "Fail":

    This appeared:
    DIFXAPP: ERROR: encountered while installing driver package 'C:\Program Files\Common Files\Apple\Mobile Device Support\Drivers\usbaapl.inf'
    DIFXAPP: ERROR: InstallDriverPackages failed with error 0x5

    The error 0x5 means it is a access denied error message, and I have no idea why this occurs. I am the admin of this machine.
    I decided to uninstall Itunes, and to enter Safe mode and try to install it from there.

    To go into safe mode, you'll need to reboot and press F8 on the first startup screen. Select Safe mode from the list that appears.

    One thing that windows doesn't like is installing things in Safe mode, so we'll need a workaround. There's some tricks using a program called SafeMSI, but this didn't work for me.

    I decided to go another route. I created a temp file on my desktop called "Apple Temp". I opened up the AppleMobileSupport.msi from the desktop with the LessMSI program, and extracted the files into this folder.

    Now, we are almost done. We now need to copy the files into the proper locations.

    1) In "Apple Temp" go into the folder: SourceDir\Common Files\Apple
    and copy the "Mobile Device Support" folder
    to: C:\Program Files\Common Files\Apple

    2) In "Apple Temp" go into the folder: Windows\system32
    and copy the 3 files
    to: C:\WINDOWS\system32

    3) In Apple Temp" go into the folder: SourceDir\Windows\winsxs\Manifests
    and copy the 2 files
    to : C:\WINDOWS\WinSxS\Manifests

    4) In Apple Temp" go into the folder: SourceDir\Windows\winsxs\Policies\x86policy.8.0.Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_x-ww77c24773
    and copy the 2 files
    to : C:\WINDOWS\WinSxS\Policies\x86policy.8.0.Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_x-ww77c24773

    5) In Apple Temp" go into the folder: SourceDir\Windows\winsxs\x86microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.762_none10b2f55f9bffb8f8
    and copy the 5 files
    to : C:\WINDOWS\WinSxS\x86microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.762_none10b2f55f9bffb8f8

    6) In Apple Temp" go into the folder: SourceDir\Windows\winsx\x86Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.762_x-ww6b128700
    and copy the 3 files
    to : C:\WINDOWS\WinSxS\x86Microsoft.VC80.CRT_1fc8b3b9a1e18e3b_8.0.50727.762_x-ww6b128700

    7) In Apple Temp" go into the folder: SourceDir\Windows\winsxs\x86policy.8.0.microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.762_none9193a620671dde41
    and copy the 2 files
    to : C:\WINDOWS\WinSxS\x86policy.8.0.microsoft.vc80.crt_1fc8b3b9a1e18e3b_8.0.50727.762_none9193a620671dde41

    If any of these folders don't exist in c:\Windows, then just create them.

    Once that's done, reboot your PC with your iPhone plugged in and re-install Itunes. Itunes will now install all the correct files, and the Apple Mobile Support application will be loaded, and will now also appear in the Add/Remove items list.

    Feel free to now delete the Apple Temp folder and the AppleMobileSupport.msi file from your desktop.

    There's probably a better workaround, but I couldn't find one. I haven't had a problem yet.

    Message was edited by: BadBrad130

    Message was edited by: BadBrad130