Previous 1 2 Next 28 Replies Latest reply: Dec 26, 2009 12:45 PM by Riverbed Productions Go to original post
  • aaron evans Level 1 (5 points)
    same problem here. happened about a week or 2 ago. something Apple updated caused this. unacceptable, Apple. Get this fixed NOW>
  • JonOtto Level 1 (0 points)
    Just got back from a weekend vacation to discover that my macbook is no longer connecting to the internet, both wired and wirelessly. The problem is limited to my mac, as another computer on my network isn't having any connectivity issues at all. Seems like you guys are having similar issues, and thinking it may be related to a recent security update. I don't have any recollection of installing the latest update, and the only recent change was that it was shut down for four days. My apple care expired last month, and I'm hoping that a quick fix is possible, as I'm not in a position to buy a new computer, let alone foot the bill for an extensive repair.
  • Level 1 (0 points)
    I have been having a similar problem to you all. It takes FOREVER for any web page to load (we're talking like several minutes even to load Google search), but it shows I have full signal strength. However, my husband's MacBook is functioning fine as well as his PC which all use the same network. I have an AirPort and AirPort extreme. I've even tried directly connecting to the AirPort extreme to see if that would help the speed problem, and it did--but only for a few minutes. After that, it displayed the samed the same problems as before--MIND-BENDINGLY SLOW page load. I've cleared the cache, history, renew DHCP, reset the router... everything I can think of and still to no avail.

    I took it to the Genius Bar, twice, and they said it has to be my network, because it connects and loads pages at lightning speeds when I'm on the Apple Store network. Ugh. This is sooo frustrating and has basically rendered my mac useless.

  • jtjbt20x Level 1 (0 points)
    Count me in. I've had problems since after the first update to Snow Leopard. Strange thing is if I am connected to Skype or iChat, those connections stay working. It's just new web pages or Google Earth that craps out. Go figure, but it's definitely since the first Snow Leopard update.

    I even changed routers to see if that was the problem--it wasn't but it did increase my throughput.

    Message was edited by: jtjbt20x
  • jtjbt20x Level 1 (0 points)
    I forgot to add that this happens with either airport or ethernet connection from the Macbook.
  • jtjbt20x Level 1 (0 points)
    Well, I tried some of the things mentioned here:
    --I created a new location, that didn't work.
    --I changed routers from a Linksys WRT54GS v2 to a WRT54GS v7 that I had and that didn't work.
    --I had an old entry in my router DNS tables, took that out, that increased the time to lost internet connection to about 90 minutes.
    --Then I turned off uPNP on my WRT54GS v7 router and I've been up and running for over 12 hours on my macbook.

    I'll keep my fingers crossed. Oh and when I turned off uPNP my Dell laptop could see my macbook in my workgroup again--I was even able to remotely login into my macbook--before this I could see my Dell from the macbook but not the other way round.

    Next I'll have to see if it all works when I don't try to log into my macbook from my Dell.
  • highgroove Level 1 (0 points)
    A few months ago I ran the software update for 10.5.8 and ever since, I've had internet connection problems. I use both Firefox and Safari and I noticed that every couple hours or so I get a message on the browser where I've lost the internet connection. I can turn Airport off and then back on and then my connection is fine again. Was there an Airport update in there? If so, I bet that caused this screw-up for all of us. What the heck can I do to fix this?
  • Joseph Caprario Level 1 (0 points)
    Similar problems with my Macbook. Just started within the past couple weeks.
    The connection often just drops.

    I found that if I disable the connection using the airport menu at the top of the screen and re-enable it right away that my connection is fix at least for a while.

    Not sure if it's a hardware of software problem. Could it be some sort of firmware issue??
  • eveck Level 1 (0 points)
    I posted something about this today:

    I've had the same problem except I was able to link it to battery power and I have been able to reproduce it. This specific problem is with Snow Leopard and 10.6.2.

    When macbook is running on power (plugged in):

    If battery power is below 60%, connection is spotty - the lower it is, the worst the problem.

    If the battery power is above 60%, no problems at all, runs fast and no drops.

    When macbook power is not plugged in and running on battery:

    Below 60% almost useless
    Above 60% spotty and worse as the battery drains

    The only solution I have found is to keep my laptop plugged into all the time which I hate doing as it is bad for the battery.

    I never had these problems pre 10.5.8. When using 10.5.8, my laptop would overheat, the fan would consistently be on and wireless was useless so I reverted. I then upgraded prior to Snow leopard and found that if I left istumbler running in the background, the connection would be 'ok' on or off battery power.
  • Joseph Caprario Level 1 (0 points)
    Try zapping the PRAM: pro.html

    "Command (⌘), Option, P, and R keys simultaneously immediately after re-starting the system. You must do this before the gray screen appears. Don’t let go of the keys until you hear the startup sound for the second time."

    So far that seemed to do the trick.

    Other suggestions:
  • dick the flick Level 1 (35 points)
    I have had weeks and weeks of similar experience - it seemed to coincide with OSX 5.8 (not risking Snow Leopard yet)

    I also logged this here:

    However - since trying Joseph's PRAM Zapping this morning, things seem much much better.

    I still have the occasional hic-up but hoping that's simply my over attentive response to any slowness after the weeks of serious misery! Fingers crossed.

    I really do recommend a zap ....... please report back though!
  • dick the flick Level 1 (35 points)
    Wo, wo and thrice wo .......... PRAM zapping seemed to make my problem go a way for a while but it is back again and worse.

    However connecting via ethernet works fine.

    Once again when using Airport ..... Network Diagnostics says
    Airport / Network Settings are both Green Lights
    ISP / Internet / Server all FAILED Red lights

    THIS MAKES NO SENSE,,, has anyone heard anything further from Apple?
  • A22YearUser Level 1 (0 points)
    My problem stems from mDNS Responder and configd incoming connection errors. See suggestions at Try reinstalling 10.5.8 combo update. Or follow instructions to add configd and mDNS responder to firewall to allow incoming connection for these services
  • Riverbed Productions Level 1 (5 points)
    I'M having the same problem as you guys, I have the original MacBook and the same problem is happening and it's really annoying. It's happening on both sides of my MacBook which includes my windows side. The only thing is, hat every other computer on my network is working fine, it's just my MacBook. So I'm hoping they come out with a new update soon :s.
Previous 1 2 Next