Previous 1 2 Next 24 Replies Latest reply: Jan 3, 2010 4:21 PM by megauser Go to original post
  • luvlabs Level 4 Level 4 (3,610 points)
    What do you get when you tap the blue arrow (>) next to your network name? If your IP address starts with 169.x, you are connected to your router but not the network. Things that cause this are WEP encryption, old router/firmware, router that needs to be restarted.
  • lcnewman Level 1 Level 1 (0 points)
    WAP; I have since done a complete factory reset and reinstall and still it doesn't pick up the DNS address. This is getting very annoying ... it is not under warranty anymore.
  • lcnewman Level 1 Level 1 (0 points)
    Turns out I am still under warranty after all! Apple wants me to send it back for repair, so we will see what happens after that!
  • Gill Bates Level 1 Level 1 (0 points)
    I have just got an ipod touch 3G 32gb with 3.1.2 - I had exactly the same problem with the message 'unable to join network' always displayed, as well as being unable to save a password when connected to my home router - it also wouldn't auto-reconnect after going to sleep. After reading numerous forums, trying the 'reset network settings' on the ipod, and resetting the router, none of these methods worked!

    Looking at the settings on the modem admin via the IP address, it stated that having the factory setting SSID could be a security risk, despite working perfectly with my laptop, PS3 and every other device! At last, success - the problem was fixed by changing the SSID on the router from the factory default to another name. I can't explain why this worked - it could have been a security issue causing the connection not to remember, or giving it a new SSID could have just given it a new clean network to connect to?! Frankly, I don't care as the problem has gone away! If you have this problem and still have your router with the factory setting SSID, then this is well worth trying as it has solved all my issues.
  • rockmyplimsoul Level 5 Level 5 (6,230 points)
    Gill Bates wrote:
    If you have this problem and still have your router with the factory setting SSID, then this is well worth trying as it has solved all my issues.


    Just to clarify, did you change the name of the SSID, change the SSID broadcast, or both? Turning the SSID broadcast ON will help the Touch remember the network security, but the name shouldn't have anything to do with it.
  • Gill Bates Level 1 Level 1 (0 points)
    The SSID broadcast was already on - I was just using the default name! All I changed was the name! I agree, in theory it shouldn't do anything, however, using the default name did seem to flag a security message in the modem admin saying that it wasn't a secure method of using the SSID - I was being lazy! The iPod Touch is the only item that has ever had a 'security' or issue with the router and SSID! Seems strange, but worked! I can't explain why, but as it worked for me, maybe worth a try?!
  • Rhumb Level 1 Level 1 (0 points)
    My iPod Touch (OS 3.1.2), too, seemed to suddenly take a khrapper trying to connect to my home WiFi, which it had done before without issue and that my main computer (which I'm typing on now) does just fine.

    Had been using standard WEP, to no avail, then even dialed back to no security just to trouble shoot. Nada. Did the Reset Network Setting thing too. Nada. Typed in my password, paying attention to case. Nada. SSID is the same (non factory) that always worked and works with my desktop system.

    Kind of running out of ideas here, any thoughts. Dang thang seems bound and determined NOT to connect.
  • lisa214 Level 1 Level 1 (0 points)
    i have the same problem... i have the 1st generation.. i tried to hook up to my wireless internet at home.. i have resetted the network settings.. where would you find the password to connect.? and how do you change the 5 password?
  • packetbrain Level 1 Level 1 (0 points)
    Just bought the iPod touch two days ago for my wife...

    The trick to get 64-bit WEP working on a Linksys BEFW11S4 was to place a "$" dollar sign in front of the 10 hex digit WEP key #1

    goofy - and I assure you this is an Apple specific issue... nothing like any other wireless product/vendor I have worked with as a networking professional
  • megauser Level 1 Level 1 (0 points)
    I, like many others, have been having this "unable to join network" problem. I read multiple, multiple forums and in the end what worked for me was:
    (First of all, to do all of this I went to "http://gateway.2wire.net/" to access my router, I have at&t so your access to your router may be different. I did the general steps as in "#)" and the steps I took specifically for att uverse as in "#)*")
    1) Changing my Wi-fi network's SSID from the factory name (it was 2WIRE481) to a custome name.
    1)* For steps 1 and 2, I went to http://gateway.2wire.net/, then to "Home Network", then to "Wireless Settings", I was then able to change the SSID and network password.
    2) I changed the password of my wi-fi address (I don't think this is necessary, but it was more convenient for me anyways)
    2)* Same steps as in step 1. Make sure to click save, otherwise the network will not change it.
    3) I completely restarted my network system.
    3)*I did this by going to "http://gateway.2wire.net/" and clicking system, then looked at my wireless router and clicked "view details", then clicked "restart the system".

    After doing these steps I was able to connect to the network on my itouch by opening wifi and typing in the password! I wasn't able to use my wi-fi for months and this finally fixed it. Thanks for everyone's help.

    Hope this helps!
Previous 1 2 Next