5 Replies Latest reply: Oct 1, 2009 8:34 PM by Ryan Vetter1
mcaers Level 1 Level 1 (0 points)
My MacBook Air has 77% left in the battery. The power cord is attached and the green light is on however my machine is telling me that the battery is not charging.

What is the problem and what can I do to solve it? Thanks

MacBook Air, Mac OS X (10.6)
  • carl wolf Level 6 Level 6 (14,295 points)
    "The power cord is attached and the green light is on however my machine is telling me that the battery is not charging."

    The green LED is an indication that the battery is not charging, so your machine is telling you the truth. Try resetting the SMC, and calibrating the battery.
  • Ryan Vetter1 Level 2 Level 2 (460 points)
    Sorry for your troubles, but it's nice to see I am not alone. Same problem: plugged in, green light, but not charging. That is what it says under the battery icon, which just shows the plug inside the battery icon.

    When I unplug it, the computer shuts down. When I restart, the date and time are reverted back to something incorrect.

    I tried a good MacBook Air AC Adapter to rule that out, and still the same problem. Reset the PRAM and SMC, but not go. Still the same thing. Must be something wrong with the battery. I want to say it is the microchip in the battery... so I would need a new one. Maybe there are some quality issues with them...

    At any rate, this is my first refurbished Apple. I saved $400 off the retail price, but now a bit disappointed because it is not functioning properly. But I do have warranty so Apple has to service it...

    But the fact that it is not saving the date and time tells me the PRAM battery is dead. And a dead PRAM battery can lead to problems with charging the battery. Any suggestions?
  • Ryan Vetter1 Level 2 Level 2 (460 points)
    That was using Leopard. Just finished upgrading to Snow Leopard, now it has an X over the battery icon. Usually, on older PowerBooks, resetting the PRAM will fix this. I will try that. Also, firmware update in progress.
  • Glorfindeal Level 6 Level 6 (9,330 points)
    It sounds like your battery is defective. I would call Apple to see about a replacement.

    Glor
  • Ryan Vetter1 Level 2 Level 2 (460 points)
    Hi:

    Thanks... it now registers the battery, but it says: "Not Charging". And the condition of the battery is: "Replace Now".

    I am sure this was the problem with the unit before, since it is a refurbished item.

    Maybe they replaced the battery or something, but it does not charge, and it is not reporting hardly any information in System Profiler other than the fact that a battery is recognized. I think this is a problem with the circuity from the battery to the motherboard (i.e. the PMU). It won't charge, it won't power the unit, it won't do anything.

    That requires a logic board replacement, and the Genius agreed. So I have to send this unit back and get a refund, then reorder the same refurbished model. I will try one more time to have a swap out at the local Apple Store but the other one did not have my SSD model, so likely back to Apple.