1 Reply Latest reply: Sep 22, 2009 12:48 AM by Qwelldrin
naywa01 Level 1 Level 1 (0 points)
Hey all, if you keep getting the 'Windows is configuring' message when firing up iTunes, look for .pcast and pcast in HKEYCLASSESROOT in Regedit (you can find Regedit in the Windows directory or by typing it in a 'Run' command box.

Right click on these values (you may get an error message, but just click ok) and then click 'permissions' and then click the 'Advanced' button at the bottom of the box that pops up, select the 'Owner' tab on the nect screen and then highlight your Windows username (which should be listed in this tab) and click OK.

Then you can add permissions on the main permissions screen, just click 'Add' and type in your Windows username (or 'everyone' - without the apostrophes!) and then click OK. Once back to the main permissions screen select the user account in the list and check the 'Full Control' and 'Read' checkboxes below.

Then click OK and you should be done, remember to do this for both '.pcast' and 'pcast'.

Looks like for some reason the iTunes installer isn't setting permissions correctly in the Windows registry and is then unable to set the correct key values - hence the configuring message every time you start as it tries (unsuccessfully) to write the correct values.

BTW - This fix isn't my work, so all credit to the guy that figured this out. Hopefully the iTunes dev team will fix this irritating installer bug.

Intel Quad Core, Windows Vista