Previous 1 2 Next 19 Replies Latest reply: Dec 18, 2010 9:55 PM by Wellinton Lee
Neil Ward1 Level 1 Level 1 (5 points)
I have had sooo many difficulties in attempting to set up my HP LaserJet 4050N using an IP address connected to my iMac via Ethernet… but tonight I have finally succeeded! So for the benefit of anyone else who is having difficulties here is a complete step-by-step guide to how I achieved it.

In ‘System Preferences’ in ‘Network’, I made sure that ‘Ethernet’ is set to the following:
‘Configure IPv4: Using DHCP’

Two numbers are given:
‘IP Address’ and ‘Subnet Mask’

(you might need to click ‘Renew DHCP Lease’ by clicking ‘Advanced’ and under ‘TCP/IP’ clicking ‘Renew DHCP Lease’)


Go to ‘Applications’ folder and click on ‘Utilities’ and open ‘Network Utility’. Click on the ‘Info’ tab and from the drop-down menu select ‘Ethernet’.
The ‘IP Address’ should be the same as that given in the ‘Network’ settings panel for the Ethernet port.

On my HP LaserJet 4050N I went through the following menus:

Click the green ‘GO’ button until the display reads ‘Offline’
Click ‘MENU’ 7 times or until ‘EIO 2 JETDIRECT MENU’ shows
Press ‘ITEM’ button until ‘CFG NETWORKJ=NO *’ is displayed
Press ‘VALUE’ button until value reads ‘YES’
Press ‘SELECT’
Press ‘ITEM’ button until ‘CFG TCP/IP=NO*’ is displayed
Press ‘VALUE’ button until value reads ‘YES’
Press ‘SELECT’
Press ‘ITEM’ button until ‘BOOTP=NO’ is displayed (or press ‘VALUE’ button until value reads ‘NO’ and then press ‘SELECT’)
Press ‘ITEM’ button until
‘IP BYTE 1=XXX’ is displayed and where I have put ‘XXX’ using the ‘VALUE’ button enter the first number of the ‘IP’ address given in ‘Network Utility’.
Repeat this procedure for ‘BYTE 2, 3 AND 4’ by using entering a value each time using the ‘VALUE’ button and then pressing ‘SELECT’ before finally moving onto the next ‘IP BYTE’ value using the ‘ITEM’ button.
After all of the ‘IP’ values have been entered pressing the ‘ITEM’ button will display ‘SM BYTE 1=XXX’ – this is the ‘Subnet Mask’ value. Follow the same process as for the ‘IP’ address and enter the values given in the ‘Ethernet’ pane in ‘Network’ under ‘System Preferences’.
After entering the final ‘Subnet Mask (SM)’ value (BYTE 4) press ‘SELECT’ and finally press the green ‘GO’ button.

As soon as the green ‘GO’ button has been pressed the ‘IP’ value in both ‘Network’ (under ‘System Preferences’) and ‘Network Utility’ (Applications/Utilities) will change to display a new ‘IP’ address. The ‘Subnet Mask’ value displayed in ‘Network’ (under ‘System Preference’s should display the same ‘Subnet Mask’ value).

Now close ‘Network Utility’.
Click on the ‘SHOW ALL’ tab in the open ‘NETWORK’ window.
Click on ‘Print & Fax’ in ‘System Preferences’.
Click on the ‘+’ tab on the left of the ‘Printers’ Pane.
Click on the ‘IP’ tab.
From the drop down menu ‘Select HP Jetdirect – Socket.’
Now in the Address field enter the ‘IP’ values that you entered in the printer (and that you wrote down earlier).
Once entered click ‘Add’.

I really hope that what has worked for me works for anyone else who is struggling to set up their HP printer using IP over Ethernet. Please post any success.

Kind regards


iMac 2.66 Ghz Intel 4GB memory, Mac OS X (10.6)
  • Ponteigh Level 1 Level 1 (0 points)
    Neil Ward1 wrote:
    I have had sooo many difficulties in attempting to set up my HP LaserJet 4050N using an IP address connected to my iMac via Ethernet… but tonight I have finally succeeded! So for the benefit of anyone else who is having difficulties here is a complete step-by-step guide to how I achieved it.

    Does this still let you use Ethernet to connect to the Internet as well as print?

    Thank you,

  • Bob in MN Level 1 Level 1 (0 points)
    Thank you, Neil! Your instructions worked.

    Several comments to clarify your instructions.
    They mostly expose my simple minded understanding of computers....

    1. At the line in part 3 beginning with " ‘IP BYTE 1=XXX’ is displayed...", the 'XXX' means the first set of numbers before the first '.' in the IP address. For an IP address of '', that means '78'. You push the 'VALUE' button many times if the number is three digits. IP Byte 2 for the same IP address is '123'. Etc.

    2. When you have finished all the steps, it works! What a relief.
    The printer will appear in the print dialog box as an IP address.

    3.You can change the name of the printer if you want.
    Go to System Preferences>Print&Fax
    Select the printer. (it is listed by its IP address number)
    On the right side of the box will appear several buttons.
    One button is 'Options & Supplies'. Click it.
    Another box will drop down.
    Choose 'General' from the 'General / Driver / Supply Levels' buttons at the top of the box.
    The name of the printer will be defaulted as the IP address.
    Type in whatever name you want for the printer
    Click 'OK'

    4. It may be possible to go one step further and connect the HP LaserJet 4050N
    printer to the computer through an airport express, but I have
    had enough frustration the past two weeks that I am not that curious. Yet.

    Once again, thank you Neil!
  • George_GRPA Level 1 Level 1 (0 points)
    Thank you Neil. This worked for me with an HP LaserJet 4050N hooked to an airport extreme. I followed your instructions and used the IP for the airport ethernet port I had the printer connected to (
  • ilska23 Level 1 Level 1 (0 points)
    I had to work for some hours before it worked. One thing which is very important to clear out is that the IP adress that the printer is given is unique. First I thought that it should be the same as the computer-that will of course not work. I just hope that this configuration will be stable so that I don't have to push buttons all the time.

    My next problem - which possible is impossible to solve is to get my GCC Elite XL 608 printer to work with Snow Leopard. I have a Farallon Ether Wave Adapter to connect this appletalk printer with.
    I know that Appletalk is no longer supported. But I have read about a software called Netatalk and Darwinports. The problem is that I am not technically enough to deal with all these Terminal commandos. And will it work in the end anyway ?
  • Michael Goettee Level 1 Level 1 (35 points)

    Hope you're willing to stick with this thread once more. Regarding the possibility that the printer is at a different address than what's in the Network preferences: While going through the steps you listed, I noticed that the only number I had to change in the printer menu was the ip address. It originally ended in 4, but the ip address shown in the network prefs and the Netork Utility ended in 5. I changed the printer to 5. I'm still not printing. In the new print cue there's the waiting print job and above it says: Network host '[my ip address]' is busy; will retry in 30 seconds... but it never prints. It's late and I'm going to go through these steps again in the morning, but wanted to get this one ip number question answered before I tried again. Thanks.
  • Michael Goettee Level 1 Level 1 (35 points)
    Neil. Even as I'm nearly falling asleep at the screen, I tried one more thing, setting my printer back to the original ip address and choosing THAT number rather than the ip address in the network prefs and the network utility. It actually WAS a different address and when I chose the printer I typed in ITS address rather than the other. Still, your advice got me here and I'm printing.
  • shadepuppy Level 1 Level 1 (15 points)
    sounds like you changed your printer IP to the same address as your Local Network, so you get a "busy signal".....try this article and see if it helps...I have a HP 4000N and had the same problems you are having...this article cleared everything up for me and the 4000N is now working perfectly
  • Michael Goettee Level 1 Level 1 (35 points)
    Thanks. I saved that page to my folder of printer manual pdfs just in case I ever have to do this again. I wish I'd seen it sooner. Honestly though. Neil's advice got my 99% there. It wasn't until I figured out what my PRINTER's actual address was that I could type that in during the setup of the printer adding.

    Thanks to all. I'll be sleepy all day now after my final fix last night at 12:30am.
  • TomVCS Level 1 Level 1 (20 points)
    Thanks for the help Neil. I just picked up and Airport Extreme and was having a nightmare connecting my 4050N. This worked perfectly.

  • StatusBackBaby Level 1 Level 1 (0 points)
    Thank you for this. I've had a very heavy paperweight laying around my office until I finally found your post.
  • grizzlygriff Level 1 Level 1 (0 points)
    Wow, you are the best!!! This worked perfectly and saved me purchasing a parallel to USB adapter. I cannot thank you enough!
  • MarieC Level 1 Level 1 (0 points)
    Thank you, Neil. I hope you get this message as it's been a good while since you posted your 'guide'.

    I followed all your directions, but although the printer and computer are connected, the printer just puts out pages of code and does not print the document I send it.

    I downloaded the latest HP drivers from Apple, and have read everything HP says about it also.

    Four drivers come up - HP 4050, a CUPS driver and a gutenprint and a foomatic/pxlmono. I've tried it with each one, and get the same results.

    Any other advice you can give would be most gratefully received!

    MacBookPro early 2008, OS X 10.6.4. 4 G RAM.
  • MarieC Level 1 Level 1 (0 points)
    Thank you for the additional information. It brought me one step farther, but I still was getting just code.

    Here is my solution which may help anyone else out there who still has problems:

    I found three files I needed to download before setting up the printer, and they must be downloaded and installed in the order in which they are listed on this page:
    < #MacOS_X_10.3.x_.28Panther.29_-_Mac_OS_X_10.6.x_.28SnowLeopard.29>

    (Select the one for SnowLeopard)

    Next I restarted the computer with the printer connected to Airport Extreme Base Station and turned on.

    Then I went to the Systems Preferences and then to Print/Fax set up and once again set up the printer. This as Neil and you describe. I allowed it to automatically select the driver, which turned out to be the Generic PS driver.

    I quit from the program and tried to print a page and: Voila! Success.

    Thanks again to Neil and you and may this help others.
  • Testemonial MAC convert Level 1 Level 1 (0 points)
    Thank you. I have the HP 4000 printer since 1998 and it is still in great shape. I was now able to link my Macbook Pro 15" i7 to it through my Airport Extreme's ethernet. Thank you again.
Previous 1 2 Next