14 Replies Latest reply: Nov 10, 2009 6:48 PM by jasoncreek
iwick Level 1 Level 1 (0 points)
I have 4 mac computers trying to use Home Sharing, all are running the latest version of Leopard (10.6.1).

The first two computers started sharing from each other properly (an iMac and a Mac Mini). When I sign up the third computer (15" Mac Book Pro), I am able to log in properly using the same account name. It appears like it will work (Home screening icon is there, and it prompts me to hit "Create Home Sharing" which I click, and then I click "Done".

But when I hit "Done", the icon disappears immediately from the "Sharing" section of iTunes on my 15" MBP. No sharing is listed at all. The other two computers continue to share properly, but I can't get my third computer to hook into this. I haven't even tried to do the 4th computer yet.

The first two computers were set up to automatically share music and iphone apps automatically between each other- auto syncing for those 2 categories.

Help please!

MacBook Pro 15in, Mac OS X (10.6.1), iTunes 9
  • Mohawk Guy Level 1 Level 1 (0 points)
    I get a similar result when trying to use Home Sharing between my iMac and a PC running XP. Seems like it should work but the home sharing icon disappears from both machines after hitting "Done."
  • EDOZ929 Level 1 Level 1 (0 points)
    I'm having the exact same issue.

    On my 3rd Mac, as soon as I click "Done" the Home icon disappears.

    Help!
  • BrianOravetz Level 1 Level 1 (5 points)
    I am with you guys, I am having no luck whatsoever with Home Sharing. My family has just begun the process of switching over to Mac's, so we have two PC's and one Mac in our home.

    That said, all computers are logged into the same account, and on every computer we get the message starting that we're logged into Home Sharing; but once we press "done", the "Home Sharing" icon and the "Sharing" icons disappear.

    I will say however... Just minutes ago, I logged out of one of my PC's and then logged back into Home Sharing; I did not press the done button. Leaving the home sharing and the sharing icons in place. Then I ran upstairs to the Mac, logged out of Home Sharing and logged back in. I let it sit for a minute and then all of a sudden, I saw the PC listed under the sharing tab, however no library was showing. Then, as quick as it showed up, the share disappeared, and the Mac stopped recognizing the PC; and we are back to square one.

    This is a major bug, I'm not sure how it was allowed out to the world. Hopefully the fix will be along soon enough! I almost had my wife convinced of a new iPod! Then the sharing didn't work... That was a let down because the majority of our music is on my computer.

    C'est La Vie!
  • poiuwfnsl Level 1 Level 1 (0 points)
    Yeah, I got a pretty new PC running XP just fine, you know, as far as PCs go, and a PowerMac G5 in mint condition running the latest version of Leopard (10.5.8), and both have iTunes 9.0, so why can't I home share? Both are logged into my account, sharing is activated, and they are even connected on a home network through an AirPort Extreme, but neither pick up each other's iTunes Libraries.
  • fastcat77 Level 1 Level 1 (0 points)
    Hiya,

    Have managed to see and play music that sits on my Macbook from my Imac and vice versa.

    My problem/query is that it hasn't allowed me to copy any songs across. I also can't see any settings in the bottom right hand corner of Itunes (as referred to in the help tutorial). The icon in the shared bar on the left of iTunes is a blue box with a musical note on it- not a "house" as in the tutorial - can't figure that out.

    Any ideas?

    Thanks.
  • poiuwfnsl Level 1 Level 1 (0 points)
    You must not have iTunes 9.0 if your home sharing symbol isn't the same. If you do, however, have iTunes 9.0, then I can't imagine why it would appear that way. As for your problem I have never needed to associate myself with that, so I can't exactly help.
  • poiuwfnsl Level 1 Level 1 (0 points)
    Oh, and as for your song transfer problem, it may depend upon the server settings. Check your iTunes sharing settings on your computers to make sure it doesn't block transfer. Plus I have had that problem when putting an iPod into another computer and trying to put my files onto the computer and vise-versa, and I don't know how to solve it.
  • Brian Reese Level 1 Level 1 (5 points)
    So no solution then?
  • sproxton Level 1 Level 1 (0 points)
    I found this post in Mac rumours, which seems to get half of the way there. It's written for two Macs but the point seems to be to Authorise all computers for all users (which is different to signing in for Home Sharing). In iTunes you go up to Store and then Authorise Computer (but make sure Home Sharing is OFF first). Anyway, here is the post:

    This works on 2 (and probably more) Macs—

    without messing around with any port settings
    with OS X Preferences, Sharing, File Sharing turned OFF on BOTH computers
    with iTunes Preferences, Sharing, "Share my library on my local network" turned OFF on BOTH computers

    (apologies for documentation overkill—just being thorough)

    1. Turn OFF Home Sharing on BOTH computers (this is NOT done in Preferences; instead, go here: Advanced, Home Sharing)

    2. Make sure BOTH machines are authorized for BOTH iTunes accounts (Store, Authorize Computer)—i.e., if each has its own iTunes account

    3. You do NOT have to be logged into the same account on both computers; each computer may stay logged into the iTunes store under its own login

    4. For sanity's sake on this part, check to make sure of this—i.e., that each machine is logged into the store with its own store account (Store, View My Account, check to see ID is correct)

    5. NOW turn Home Sharing back on (Advanced, Home Sharing) on each computer, but use ONE account to log into Home Sharing on both (or all) computers

    6. DON'T WORRY, this does not "flip" the login ID for a particular computer's iTunes Store connection to the ID being used for Home Sharing

    7. On each computer now you should see a "Home" icon with the shared library in the left-hand sidebar

    8. Open the shared library and drag and drop as desired

    The bottom line seems to be this:

    1. Keep each computer logged into the store with a separate iTunes ID (if you need to)
    2. Get all the computers authorized for all available IDs
    3. Use ONE ID to log into Home Sharing on ALL computers

    You will of course ONLY see the Home Sharing icon pop up if both computers are on, with iTunes open on each

    You'll know that this whole thing is working if the shared library listed on the left has the correct "Home" icon (and not the blue, "shared" icon that shows up when Preferences, Sharing, "Share my library on my local network" is turned on—yes, this is the one you see in Internet cafes filled with Mac users)

    I've tested the above over and over again, even completely rebooting my two machines (they have different iTunes accounts), and it still works. This is running Leopard on both machines. ________________
  • iwick Level 1 Level 1 (0 points)
    The last post from Mac Rumors helped a lot and seemed to fix it.

    For Mobile Me users, here's another tip. I started my iTunes account before I had Mobile Me. But then after I got Mobile Me the user name sometimes got populated automatically when I bought a song or app (probably from an auto-field inserter function or something).

    Net, I probably had one or two songs/apps that were under my Mobile Me account without knowing it.

    If you authorize all computers for ALL accounts, and follow the steps in the Mac Rumors post, it seems to work.

    Thanks!
  • ()z Level 1 Level 1 (0 points)
    My problem with Home Sharing turned out to be that in my home I have two different subnets, and home sharing does not work between them. Put both computers on the same subnet and it works fine. Seems Apple want to restrict a home to a single subnet.
  • Raldino Level 1 Level 1 (0 points)
    I have a lt on vista & one on XP. having tried your suggestion, i am no better off. Could there be another solution for my OS?

    HELP!
  • mickeysingh Level 1 Level 1 (0 points)
    I have an imac and a mac book pro and am having similar problems with sharing since I upgraded to itunes 9. Until then I was able to see the librariesh on each computer and vice versa with no problem but now the sharing does not work period. Forget about home sharing, I don't have the sharing icon period in the left menu. I have doble and triple checked my preferences. I have all the sharing options checked. Both my computers are authorized with the same itunes account. Both computers are on the same network. I have rebooted the computers and the network several times but still neither computer's library shows up on the other. The Sharing menu says "Status:On, No users connected". I am completely confused. Funny thing is if I try to deauthorize either one of my computers, I get an error message that the login or password is incorrect, which is not true as I only have one itunes account and I can see that both computers are logged into it. To make things even more ambiguous, my friend came over last night when I was struggling with these issues, we opened itunes 9 on his laptop which runs on windows, my library showed up on his PC right away.....Can someone help me figure this out? Really would appreciate any suggestions. I also plan to call apple care in am.
  • jasoncreek Level 1 Level 1 (0 points)
    I was having exactly the same problem described: home sharing icon disappears entirely, nobody connected, etc. I have an iMac and a HP PC on the network. I followed the step-by-step instructions listed here to no avail. What I figured out: the PC had logged off my wireless network, and onto a neighbor's network (what I get for having a PC, I know). So, "my solution" is to be VERY SURE that both computers are using the same wireless router. Many times people don't change their SSIDs, so you can be on the wrong network by accident (i.e., lots of networks are named linksys, or belkin54g, or NETGEAR, etc.) so be sure to give yourself a unique SSID, and don't broadcast it. So, you have to enter it... that should make sure you have both of your computers on the same network. Hope this helps.