Previous 1 2 3 4 Next 46 Replies Latest reply: Jan 1, 2010 4:24 PM by luvlabs Go to original post
  • Steve M. Level 5 (4,740 points)
    It could very well be the router. Other posters here in the past have suggested that old routers may contribute to problems like you are having. Let us know what you find out when you get to use your new router this weekend.

    Good luck,
    Steve M.
  • Naitzyrk Level 1 (0 points)
    @Ogre That´s exactly my problem
    @Steve M. Thanks man, I will
  • Ogre_fl Level 1 (0 points)
    I bought a new router when I got my iPod touch because my old one worked horribly with the touch.
    I don't know what this problem is, but I don't think it's the router either.
  • Steve M. Level 5 (4,740 points)
    Have you done a thorough search of this problem here in the discussions? It seems to be going on out there for various users. There must be multiple threads here with proposed solutions. Sometimes with a problem like this you just have to read over several threads and you may find something that solves it for you. Sorry, that's all I can come up with now.

    Steve M.
  • rawFM Level 1 (0 points)
    I'm having the same problem. I noticed today, it's only occurring when I'm trying to use free wifi somewhere. Here at home with my wireless network, it seems to work fine.
  • rm4g3d0n Level 1 (0 points)
    It's not your router, its not your iPod or any hardware related issues, its the **** firmware. There's a whole discussion board about it
    It's occurred since the release of the 3.0 firmware and Apple has yet to address the issue even with the release of 3.1.1
    Yes you get a whole bunch of feature like: bluetooth, copy&paste, download videos from itunes, BUT ITS NOT WORTH IT WHEN THE WIFI ***** (ARE YOU LISTENING APPLE?)
    I was on 3.0 firmware for a while and have been following discussion boards and forums about it, and up til now its still no good.
    Luckily I was able to downgrade back to the stable version 2.2.1, having a stable wifi connection is so worth it compared to the other crap 3.0 enables.
    I won't say how to downgrade your firmware, you have to figure it out yourself, there a whole internet out there.
  • ladines Level 1 (10 points)
    I'm having the same problem since updating from 3.0 to 3.1.1. WIFI is completely unreliable using my home network (sometimes works sometimes doesn't, asks for password and refuses connection...) and, as mentioned in a previous post, it doesn't ever connect at free WIFI spots. Shows full signal strength but just keeps spinning. Apple needs to get to work on this.
  • IrishHighlander Level 1 (5 points)
    agreed. I am on the board to get a new iTouch as I have been documenting my issue since the "downgrade" from 2.x to 3.x Just today my apple tech forced me kicking and screaming into 3.1 as a precondition to giving me a new one. As easy as I can tell... while there are the rare cases, the devices do not appear to be 100% updatable as a whole. ie: Most devices on 2.x can't go to 3.0 and Many devices that shipped with 3.0 are having issues with 3.1 Sadly, until Apple stops acting like Microsoft and goes back to their roots of simply making stuff that works - things are going to get much, much worse.
  • luvlabs Level 4 (3,610 points)
    Hate to burst your bubble, but there were as many WiFi problems from 2.0 to 2.1 to 2.2 to 2.2.1. I don't know if you will accept this explanation, but the 3.0 and 3.1.1 firmware updates added a number of critical enterprise wireless networking options. On the consumer side, they did put a premium on having reasonably up to date routers to connect to.

    Think about it for a minute. There are a number of router manufacturers and by the nature of the beast, there will be variations on how standards are implemented. Some of the most popular routers have had multiple firmware updates because of errors, incompatibilities with various programs/network configurations, and so on. Try to write software that will connect with everything under the sun, whether it is properly programmed/implemented or not, and you begin to see the problems.

    I have not had problems with 3.0 or 3.1.1 and WiFi. I also have a router that is less than a year old and regularly checks for updates. Most 3.0/3.1 WiFi issues are solved with a router firmware update or replacement of the router.
  • IrishHighlander Level 1 (5 points)
    okay... so... if your router is BRAND NEW and has the latest firmware and worked perfectly on the iTouch BEFORE 3.x and continues to work great with every other NON Apple 3.x device are you saying that there still is absolutely no way that there is anything wrong with the 3.x software? I would argue that it is flawed based upon the simple, tried and true, scientific method of FACTS. When you eliminate all possible causes, what remains is your focus.
  • luvlabs Level 4 (3,610 points)
    What I have observed is that there is nothing inherently wrong with the WiFi software from 2.0 -3.1. Network design and configuration has a lot to do with whether or not you may or may not experience problems. For example, someone is using an Apple Extreme Base Station as their router and their touch doesn't work. Since the Extreme comes preset to operate in N mode only, which works perfectly with all of their wireless Apple devices, it must be a problem with the touch based on your reasoning example.

    So I'll take you through the basic recommendations/troubleshooting steps that I suggested when 3.0 first came out. Not a 100% guaranteed fix, but a high enough win percentage to make it worth the effort of trying it: (testing after each step is optional but it would be more scientific)

    1. Unplug your router. Wait at least a minute and plug it back in.
    2. Reset your network settings on the touch: Tap Settings > General > Reset > Reset Network Settings.
    3. After your iPod restarts, log back into your network using Settings > Other Network and re-inputing your network name. Tell the touch your security (encryption) method and reenter your password.

    Some additional things that can trip you up:

    1. Using WEP encryption? Since Apple products implement WEP differently than Microsoft, your best bet is to change to WPA-psk or WPA2-psk.
    2. SSID - if you turn it off, your touch will not remember your network when you put your iPod to sleep. You will have to log in each time you want WiFi.
    3. DHCP - most routers work fine and assign IP addresses correctly. If you are still having problems and your touch is reporting that it's IP address is 169.x.x.x and subnet mask is then your router is not assigning the IP address. If you have a lot of devices on your network, increase the IP range available to DHCP or turn it off and manually assign IP addresses.

    Please let us know how you make out. Also, in the future, please don't thread jack. Post your problem as a new one. You will be more likely get a faster result and more complete answer. This seems to be especially true for WiFi problems as there are seldom two people who have the same problem with WiFi.
  • IrishHighlander Level 1 (5 points)
    ..and yes, all of that has been implemented/tried. Here is the "plain english" situation:
    1800sq ft house
    router in the middle... D-Link 655 with expansion antennas for wider footprint.

    MacBook Pro and any OTHER WiFi-enable device can get full strength coverage anywhere in the house and at least 1/3 to half on the whole property general of 4k sq feet.

    iTouch on 2.x is the same as the above... 3.x and the iTouch will only work a maximum of 40-50 feet from the router... roll back to 2.x and function returns.

    Conclusion... there is something wrong with 3.x as:
    (1) The above facts indicate

    and supported by...
    (2) The HUGE number of other users reporting the exact same problem... disproportionate to upgrades prior to 3.0
  • matttysmanu Level 1 (0 points)
    I also have the same problem is there any way a patch can be released or we can go back to 2.2.1 because it worked fine befrore but now the update it has 3 signal bars but doesnt connect to anything
  • Aristotle_666 Level 1 (0 points)
    On a slightly different subject, I have just bought a new I-Touch and whilst I can get it to connect to my Linksys router when the SSID is enabled, my network normally operates with this disabled so that the network is not plainly visible to the rest of the world.

    If I enable the SSID the I-touch logs on no problem, but if I then disable the SSID whilst the I-touch is connected, the first time it hibernates it looses the connection and won't then reconnect when I turn it back on. This is despite what the User Manual says about "...once you've joined a Wi-Fi Network manually, I-touch automatically joins it whenever it is in range."

    This is in direct contrast to every other computer that I have which uses this WiFi network (2 desktop machines and 4 laptops). All the others will automatically find, and connect to, my Network even with the SSID disabled once they nave been allowed to connect once with the SSID enabled.

    Can anyone help me out with this please? I've tried it a number of times and it works fine with the SSID enabled but that's not how I want to operate my system as it's too vulnerable to outsiders.

  • luvlabs Level 4 (3,610 points)
    The touch has been forgetting hidden networks (not broadcasting their SSID) forever. Sometimes it doesn't, other times it does. It does not depend on the firmware edition. We (the members of this discussion group) have never been able to pinpoint a reason.

    I would suggest you stop hiding your network name. It does nothing to "hide" your network from the outside world. In fact, anyone can detect your network with a device with a wireless network card. You would be better off directing your attention to your encryption scheme - like using WPA2-psk and a good 8+ character password to protect your network.