Previous 1 2 3 4 Next 46 Replies Latest reply: Jan 1, 2010 4:24 PM by luvlabs Go to original post
  • awitchy Level 1 Level 1 (0 points)
    so. You all are saying, that if we have upgraded to 3.0 (and can not downgrade) that we are screwed with trying to use wifi?
    This really *****. I lost my internet connection at home, and I really counted on using my iTouch's wifi ability. (besides being addicted to the app store, I was counting on at least getting my mail)

    PLEASE Apple, fix this!

    I have reset both the iTouch, and the Network connections (using the free wifi at the library) now, even though it shows the wifi icon, I am getting nothing.
  • luvlabs Level 4 Level 4 (3,610 points)
    Without any information about what you are trying to connect to or what your exact problems are, it is virtually impossible to help you with this problem.

    WiFi works well with 3.0/3.1 if you follow a few rules:
    o Your router firmware has to be up to date
    o You should stop using WEP encryption and use WPA-psk or WPA2-psk
    o You must have your home network setup properly. Enable DHCP, SSID. Disable MAC address filtering.

    Also, thread jacking onto the end of an old discussion thread is not a good way to get lots of eyes looking at your problem. I suggest you repost with lots more information about the router you are trying to connect to, the types of error messages you receive, etc.
  • IrishHighlander Level 1 Level 1 (5 points)
    In Regards to this...

    WiFi works well with 3.0/3.1 if you follow a few rules:
    o Your router firmware has to be up to date
    o You should stop using WEP encryption and use WPA-psk or WPA2-psk
    o You must have your home network setup properly. Enable DHCP, SSID. Disable MAC address filtering.

    No, it doesn't in a LOT of cases. You could do all of those things above and it STILL would not fix your problem of wifi. In a lot of cases, the only solution is to downgrade to 2.2.1 which so far does seem to have the most functionality. As to WHY this is... still do not know for sure.
  • matttysmanu Level 1 Level 1 (0 points)
    Similar problems happen to me Wi-Fi worked fine on my 2nd gen Ipod touch with 2.2.1 when i upgraded to 3.1.1 it still has 3 signal bars but comes up with 'Invalid Argument' and doesn't work. Can you make a way to downgrade or get this problem fixed.
  • Mezigli Level 1 Level 1 (0 points)
    Throughout this thread, there seems to be numerous suggestions to update router firmware--over and over and over.
    Maybe I am just not getting it.

    I mainly use wifi at places like Starbucks, the library, the mall, etc. I'm sure I am not the only one who does this. I have no control over the wifi setup in public places. At home, I don't even have a router--I use an ad hoc connection to my PC. Updating router firmware--while I'm sure it's a good idea--doesn't seem to be the answer to a lot of people's concerns, and yet it is suggested again and again.

    I am still using 2.2.1 on my 1st Gen Touch because of all the problems I am reading about with wifi on 3.x. Are people having problems with accessing public wifi after updating to 3.1? What about ad hoc connections--does 3.1 screw that up also?
    Thanks.
  • luvlabs Level 4 Level 4 (3,610 points)
    Tap Settings > WiFi > and the little blue > next to your network name? Are you getting a valid IP address or are you getting one that starts with 169.x? If you are getting the 169.x address, please repost as a new problem and give some details about your network.
  • luvlabs Level 4 Level 4 (3,610 points)
    Ad hoc connections are still an open issue with 3.1.x although I am sure there is a pretty straight forward "fix" for it. I haven't had time to play around with it, however.

    If you don't need/want the features of the 3.x OS, then there is no reasons to upgrade. If you do want them, be aware that 3.x behaves differently than 2.x for WiFi connections. Not better or worse, just different. The WiFi indicator appears to actually be sensitive to the signal strength being put by the router, connections to sites that require a terms and conditions page is more automated than before, and the combination of secure site/DHCP server seems put a premium on updated router firmware. The secure site/DHCP problem is not something you are going to face with public WiFi.

    And don't forget, people who don't have problems are the "silent majority" - ie, you only hear from the people with problems so your perceptions can get quite skewed by postings on this board and others.
  • matttysmanu Level 1 Level 1 (0 points)
    Yeh my ip address is 169.bla bla bla and subnet mask 255.255.0.0 and there is nothing for router or dns

    But it still has the tick next to it and the lock as well

    is there anything i can do to fix this problem it worked fine before i upgraded
  • richardagilbert Level 1 Level 1 (0 points)
    Some of us do not have a choice on unhiding the ssid. I have this same problem on the network that I most need my iPod Touch, and I have no control over this network. Upgrading to 3.1.2 did not seem to help either. Has Apple ever admitted to an issue so that we can hope for a patch at some point?

    My friend has an iPhone with 2.x software and the wifi with which my iPod has so much issue works fine on his. It also works fine on another friend's Pre.
  • fjsdofnsjgv Level 1 Level 1 (10 points)
    This forum is full of fanatics,the *****ng problem is the firmware,not the routers nor the ipod...

    After 3.0 came up all problems are related to WIFI,i used 3.0 and 3.1.2 and then i had to go back to 2.2.1 and the WIFI is perfect with this firmware so STOP saying the issue is related to anything but FIRMWARE, please.

    The worst thing is that Apple is not going to fix this...,so we have to choose:

    Bluetooth or Wifi....

    Sad but true
  • IrishHighlander Level 1 Level 1 (5 points)
    another option... I added the highest power antenna on my router. I used one of the Hawking outdoor long range coverage ones. All my problems with wifi are solved. Of course, you can also see my wifi signal from the next county.
  • BruceTR Level 1 Level 1 (0 points)
    Linksys WAP54G Wireless Access Point with firmware 3.04.03 > Linksys BEFSR41 Cable/DSL Router with firmware 1.39.1 > Alcatel Speed Touch Home DSL Modem > AT&T DSL 6.0 service. New iPod Touch purchased December 2009.

    iTouch recognizes the network, accepts the security pasword/key, and establishes a connection, but doesn't get onto the Internet because the IP Address starts with "169". I have tried both WEP and WAP2 encryption. I have used Reset Network Settings after every failed attempt.

    Should I downgrade to the 2.x software mentioned throughout the forum, or should I try something else? Help is appreciated.
  • pchrist Level 1 Level 1 (0 points)
    Two days ago I ignorantly updated my ITouch to OS 3.1 and my WIFI quit working. Apple refused to provide tech support even though I had updated the OS (not application) on a computer device that day.
    I've tried all the fixes like leaving the network, resetting newtork settings, and doing a full restore of factory settings and restore a backup. I've updated the firmware on my router. When it detects the ip it is 192 not 169. My itouch doesn't even detect or join the network most of the time. It doesn't work on on my home or many public routers. If it does work in public it can be slow. All my other wifi devices work fine at home

    Extortion is the word to describe it. The tech support Apple that will provide cost $30 (600% the price of the OS I bought). They claim the device is out of warranty although I bought the OS 2 days ago.
    I asked multiple Apple support techs if I paid $30 could they assure me they could get it working and ALL of them said NO. After all the troubleshooting I've done WHAT IS APPLE GOING TO DO OTHER THAN TELL ME IT IS AN ISSUE WITH MY ROUTER.

    *Has anyone paid for the Apple Support and did it fix the problem? Is Apple working on a fix.*

    All I can say is if Apple doesn't acknowledge or fix the problem very soon they have definately lost a customer.
  • luvlabs Level 4 Level 4 (3,610 points)
    You should really have posted this as a new question since that other thread hasn't had any activity for two months. However, let's focus on your problem.

    For whatever reason, your network DHCP function is not issuing an IP address. This is usually fixed by the firmware upgrade, however. Do you have anything like MAC address filtering running on your network? I would power cycle your router and your wireless access point. Reset your touch network settings one more time and try this log in routine:

    1. Tap Settings > WiFi > Other
    2. Re-enter your SSID
    3. Re-enter your security (WPA2 would be the preferred setting since WEP require you enter the hex key for best results. Don't use WPA2 enterprise, btw).
    4. Re-enter your password (at least 8 characters but please not 25 characters) or if you are using WEP, your Key1 hex key.

    Don't downgrade to 2.x because it is highly unlikely to fix this problem and a number of apps now run on 3.x only.
  • luvlabs Level 4 Level 4 (3,610 points)
    Same goes for you - this should have been posted as new discussion and not tagged onto the end of a two month old inactive thread.

    You do realize that Apple doesn't read or participate in these forums too often - so your rant isn't going to do you much good. As far as I know, Apple is not working on a fix as there is not a systemic problem with WiFi.

    Most people have zero problems (and are not going to post here); the ones with problems will post. And with a few exceptions, most WiFi problems are correctable. OS 3.x does require you to have an up to date wireless network. That can be as simple as having the latest router firmware installed. However, if your router is no longer in production or supported, it might mean spending a few bucks to replace it.