Previous 1 2 3 Next 292 Replies Latest reply: May 7, 2013 6:42 AM by kwxr2000
neu242 Level 1 (10 points)
A couple of times a day, the keyboard stops working when I select another space using a keyboard shortcut. It does not happen every time I switch spaces.

Symptoms:
~ The Spaces selector stays on-screen, it doesn't fade away as usual
~ The keyboard is unresponsive for regular typing (such as in a text document or in Terminal)
~ I can still use keyboard shortcuts to move to another space
~ The Keyboard Viewer still shows keys as I type them
~ The mouse and touchpad works as it should

The only thing that makes the keyboard responsive again is either a reboot, or performing a standby + resume.

Is anyone else experiencing this?

This happens both on my non-unibody Macbook Pro 15" 2.5Ghz at work and on my unibody 13" Macbook at home.

Message was edited by: neu242

Macbook Pro 15" 2.5Ghz, Mac OS X (10.6.1), 4GB RAM
  • gbvrules Level 1 (0 points)
    Yep, exactly as you describe -- and increasingly annoying. Short of the full reboot, logging out and logging back in also seems to work. Other than that....
  • neu242 Level 1 (10 points)
    Good to hear that I'm not the only one. I haven't seen this described anywhere else...
  • WBG4 Level 1 (0 points)
    I have the same issue as well. What mouse do you have? Do you have any mouse sw installed? I am wondering if we can find a common theme. It seems to happen more when I am using space and remote desktop. I thought 10.6.1 had fixed it but I guess not.
  • neu242 Level 1 (10 points)
    I use a generic logitech mouse on the MPB and just the touchpad on the Macbook. I don't think this is mouse related at all...
  • WBG4 Level 1 (0 points)
    Hmmm any aftermarket stuff like quicksilver, ical viewer or iStat menus? I have a m$ mouse because i got tired of the logitech drivers not working so that doesn’t seem to be common. This is getting really annoying. Un plugging and replugging the keyboard doesn’t work either. Some process must be dying.
  • neu242 Level 1 (10 points)
    Nope, I don't run any of those applications. It looks like Apple needs to fix Spaces.
  • Jacob F Level 1 (0 points)
    I am having exactly the same problem, as are others (see the thread at http://discussions.apple.com/thread.jspa?threadID=2117886).

    I have no real fix but FYI I have found that my keyboard can be quickly restarted by unplugging and replugging its usb cable.
  • WBG4 Level 1 (0 points)
    That doesn’t work with my nice old black pro keyboard.
  • gbvrules Level 1 (0 points)
    And I'm working with standard a Apple Mighty Mouse (wired) and Pro keyboard (ditto). In fact, I've noticed that when I have the problem, both the external keyboard and the built-in one on my Macbook Pro cease to work -- though the mouse continues to work. So it doesn't seem to be a USB bus problem, and the USB unplug/plug routine doesn't work for me.

    I do believe there's some connection with Screen Sharing/Remote Desktop, which I and some other affected people also use. Something about the combination of that and Spaces, in Snow Leopard (never saw this before the upgrade)?

    Quickest "fix" I've now got is to sleep and reawake, per neu's original post.
  • kjtriplett Level 1 (10 points)
    lol...I just posted a question on this exact issue...didn't see this post. I'm having the same problem. I fix it by logging out and logging in, but it is frustrating.
  • neu242 Level 1 (10 points)
    I do not use Screen Sharing/Remote Desktop either, I still think it's a bug in Snow Leopard's Spaces.
  • cverond Level 1 (0 points)
    I have the very same problem, just appeared on a mac mini after updating to snow leopard.
  • gbvrules Level 1 (0 points)
    OK -- then I guess the conclusion is that keyboard input stops working regardless of whether it comes from an attached keyboard, a built-in laptop keyboard, or a remote keyboard via Screen Sharing. So it really doesn't sound like a USB bus problem, but more software: the system and applications simply stop accepting keyboard input, until jogged by a sleep or logoff or reboot.

    As I think I mentioned, in every case both my mouse and the built-in trackpad continue to work, which is how I manage to sleep or log off the machine. Again, less of a general I/O problem than input specifically from a keyboard not getting processed.
  • gbvrules Level 1 (0 points)
    Also, as neu also said, for me the bug only occurs when switching Spaces via keyboard shortcuts -- switching apps (and thus workspaces) via the Dock or Command-Tab doesn't seem to trigger it.

    So one (hopefully temporary) workaround is to disable the Spaces shortcuts and train yourself to move around those ways. But it's a huge pain. as most of the convenience of Spaces lies in the keyboard shortcuts.
Previous 1 2 3 Next