Previous 1 2 3 4 Next 292 Replies Latest reply: May 7, 2013 6:42 AM by kwxr2000 Go to original post
  • direwolf8 Level 4 (1,280 points)
    Message Subject: Re: BUG: Spaces prevents keyboard input
    Follow-Up: 77440885

    This is the ID for the bug report I posted on this issue some time ago. There is no solution yet, but you can restore keyboard function temporarily by opening Activity Monitor and Quitting the Dock process. Your keyboard will be available again but it won't prevent the problem from recurring.
  • monkeypaul Level 1 (0 points)
    Same issue here. Just upgraded to 10.6.1 today and it started. Quite annoying. I use a Bluetooth mighty mouse and alu keyboard on a Macbook Alu.
  • Bruce Etnyre Level 4 (1,445 points)
    I use that work-around also of selecting the Dock in Activity Monitor and clicking Quit Process, then Quit Process in the "Are you sure" dialog box. I keep Activity Monitor open all the time, have it assigned to all Spaces and put it near the edge of the screen so I can click on it in the background to quit the Dock. After quitting the Dock, it nearly immediately restarts itself, so no lost Dock functions.

    Until Apple fixes the problem, quitting the Dock in Activity Monitor is much easier and faster than restarting or logging out. There are several threads reporting this problem, but so far, I've not found a permanent solution.
  • Jacob F Level 1 (0 points)
    I am not sure we are all having exactly the same problem, because as I posted above I can consistently restart the keyboard by unplugging and replugging the keyboard USB, whereas it sounds like others cannot.

    However FWIW I have noticed that the keyboard freeze happens whenever the optical drive drawer is closed (ie every time it is used, but specifically when it is closed). I'm not sure, but since noticing this I don't think I've seen it happen at any time other than this.
  • neu242 Level 1 (10 points)
    Jacob F: I think you have a different problem. "Our" problem only happens when navigating between Spaces, regardless of optical drives.
  • neu242 Level 1 (10 points)
    direwolf8: Thanks! Killing the dock is a pretty quick workaround
  • Jacob F Level 1 (0 points)
    neu242: There are some differences but I think they are related. In "my" problem, the spaces grid icon always remains on the screen when the keyboard freezes, just as others said. So I assume (not 100% sure) that it is also triggered by using spaces. If I close the CD drawer by physically pushing it, the problem does not occur-- only if I use the eject key on the keyboard to close the drawer. So there is some conflict involving the keyboard commands for spaces and the eject key, which together induce a keyboard freeze.
  • sabor Level 1 (5 points)
    This is incredible, really. There has been a revision to Snow Leopard and this was not fixed? It's a freakin bug that leaves us without a way to use the computer, how is that for severity?

    I know of the workaround, and appreciate others posting, but seriously, why the **** hasn't this been fixed?

    BTW, you can avoid it by turning off spaces. So thank you Apple, for introducing Spaces in Leopard and making it IMPOSSIBLE to use in Snow Leopard.

    Where is you QA team? How can something so severe make it through? Very disappointing.
  • WBG4 Level 1 (0 points)
    Rather typical apple though. OS X Server's open directory has yet to work correctly for me and not corrupt its self, but that's life I suppose. You could use one of the 3rd party options (no idea if they are still around or not).

    I just hope apple fixes it soon but i am not holding my breath
  • Clif Smith Level 1 (0 points)
    I am having the same issue as well and yes, this is **** frustrating. I must say, for what was supposed to be a bugfix/enhancement, Snow Leopard has given me the most problems of any OS X upgrade.
  • driftir Level 1 (0 points)
    This happens to me as well.
  • gbvrules Level 1 (0 points)
    There's now a CNET article noting the problem here: http://reviews.cnet.com/8301-13727_7-10361439-263.html

    I'm curious -- which modifier key have people been using to trigger the Spaces shortcut? Mine had been the Command key (which I think is the default). This article suggests that a possible cause of the bug is conflicts between the system-level Spaces shortcut and the ones used by applications -- and indeed several of my apps have Command-number key shortcuts that Spaces (when it's working) will override.

    So I've switched my Spaces modifier key to the Option key, and for several hours haven't had the bug recur -- which doesn't mean that it couldn't happen any minute. Would be interested to know which modifier key people have been using, and whether changing it makes any difference?
  • WBG4 Level 1 (0 points)
    I use control and arrow keys or control and numbers so that kinda rules that out i think.
  • Petre Level 1 (0 points)
    Hallo, I have the same problem and I never had a mouse....
  • neu242 Level 1 (10 points)
    Here the quickest workaround yet:

    1) Start Automator
    2) Select Execute shell script
    3) type "killall -9 Dock" (without the quotes) as the script
    4) Save as an application, e.g. KillDock
    5) Put it in the Dock

    Now you only have to select KillDock in the Dock each time the problem occurs.
Previous 1 2 3 4 Next