Skip navigation

Keyboard stops working in Snow Leopard when using Spaces

113322 Views 292 Replies Latest reply: May 7, 2013 6:42 AM by kwxr2000 RSS
  • Mac.S Calculating status...
    Currently Being Moderated
    Jan 28, 2011 7:44 AM (in response to nle)
    Well, I found a solution for myself: deactivate Spaces. I don't have issues anymore, neither with the mouse nor with the keyboard (both, working and playing). So, it's definitely a software problem...
    Macbook Pro 13" (2010), Mac OS X (10.6.6), 2.4GHz, 4GB, NVIDIA GeForce 320M graphics
  • Sherman Wilcox Calculating status...
    I find it remarkable that this problem has been reported for at least 2 years and it still has not been fixed. I've had it across two computers, including my current MacBook Air 13" with the very latest Snow Leopard OS.

    My solution is to use the third-party application Hyperspaces. As long as I switch spaces with the keyboard shortcuts I set in Hyperspaces, I never experience a keyboard lockup. Once this week I accidentally used a Spaces shortcut, and I got a lockup.
    MacBook Air (late 2010) 13", 2.13 GHz, 4 GB, 256 SSD, Mac OS X (10.6.6)
  • mmatrix Calculating status...
    I have what appears to be a solution for this problem. After reading many pages of 'me too' and possible culprits I found that, for me at least, the problem seems to have been the choice of using "<CMD> Number Keys" as the trigger. When I switched to using "<CTRL> Number Keys" I cannot make the problem occur. I have been trying now for an hour, switching back and forth between my spaces with <CTRL> and it has not once locked the keyboard.

    SOLUTION: Use "<CTRL> Number Keys" instead of "<CMD> Number Keys" in the Expose/Spaces preferences to switch directly between spaces.
    Late 2007 Macbook, Mac OS X (10.6.6)
  • Sherman Wilcox Level 1 Level 1 (100 points)
    It would be nice if this were a solution, but I don't think it is.

    I have Spaces set to use neither CMD nor CTRL with the number keys to switch directly to a space. And it still locks up if I use CTRL-arrow keys to switch between spaces.

    As I say, for me the only solution is to turn off everything in Spaces, and then use the commercial application Hyperspaces. I have it configured to use CTRL-arrow keys to switch between spaces. This consistently works flawlessly.
    MacBook Air (late 2010) 13", 2.13 GHz, 4 GB, 256 SSD, Mac OS X (10.6.6)
  • MarkRHolbrook Level 1 Level 1 (135 points)
    Ok I recently went gadget crazy in the new Apps store. I bought Witch, TimeSink, PinPoint, iStatMenus and Butler trying to load my menu up with stuff I could really use.

    I'm addicted to CMD-1,2,3,4,5 or 6 to switch to my desired space. Well I started to experience the unresponsive keyboard about a day ago on my MBP15 (2010 i7). I figured it was some problem with the utilities so I disabled them all and was working on an applescript to open some apps and align them nicely in space 1. Well I continued to see the keyboard disappear. My applescript had a System Events command to switch to space 1.

    So I started searching and found this thread. So far this problem has NOT effected my MacPro which I use the same basic stuff in. Just my MBP 15.

    So I have KillDock in the dock but frankly every time I switch to a space the keyboard dies. So I downloaded Hyperspaces hoping it was a solution. From what I can see it solves the problem but also doesn't have the direct to a space keyboard shortcut I'm looking for. Am I missing something?

    I admit I'm so addicted to spaces I cannot live without it right now. I guess one could use expose to make things work but it seems like a pain compared to having things open in all these desktops.
    MacPro 2x2.88, 18gb, MBP17 2.6ghz, 4gb, 250g HD, iPod 60gb video, iPhone 3GS, Mac OS X (10.6), Upgraded and running Snow Kitty OS!
  • Sherman Wilcox Level 1 Level 1 (100 points)
    Yes, Hyperspaces does have direct to space shortcuts.

    In the Shortcuts panel of the Preferences, it has sections for General, Switch Spaces without Direction, etc., and the last section is Individual Spaces. You can enter shortcut keys for direct switching to a space in that section. I don't use this -- I use Cntrl-arrowkey for switching -- so I can't say whether Hyperspaces solves the freeze problem when you use it to switch directly to a space.

    I'm also totally addicted to spaces (along with Divvy), and Hyperspaces saved my sanity.
    MacBook Air (late 2010) 13", 2.13 GHz, 4 GB, 256 SSD, Mac OS X (10.6.6)
  • Ettore Software Calculating status...
    After two whole days of head scratching trying to reproduce this bug, I am glad I finally found this thread which exonerates TypeIt4Me.

    I filed a bug @ https://bugreport.apple.com, hoping that adding to one already filed there by another developer (http://openradar.appspot.com/8622464) might cause Apple to give it a higher priority.

    Riccardo Ettore, developer of TypeIt4Me
    http://ettoresoftware.com
    Macbook Air 11, Mac OS X (10.6.6)
  • ruppinator Calculating status...
    Perhaps a silly solution:

    This happens to me probably once per week. At first, I thought there was a problem with my keyboard so I simply randomly pressed as many keys as possible, effectively running my fingers over all the keys on the keyboard as fast as I can. I have no idea why but it comes back to life.
    MacBook Pro, Mac OS X (10.6.6)
  • Maxime Lemoine Calculating status...
    HI everyone,
    I have start to experience this bug Friday, only after updating gxfcard status. It never appeared before but after reading all of the topic, it appears that's a bug of Mac OS X.

    Just like you the keyboard freeze and few times later come back to life.
    MacBook Pro Mid 2009 C2D 2.66, Mac OS X (10.6.6), w Momentus XT
  • gnestor Calculating status...
    I will switching Spaces activator key and/or disabling Spaces, but I've noticed that my keyboard consistently goes out when I'm doing heavy processing. It usually happens when I'm working on a large data file, working on a music project in Ableton Live, or when I have a lot apps open.
    MacBook Pro, Mac OS X (10.6.2)
  • deadsunrise Calculating status...
    Today's update to 10.6.7 has fixed the problem for me. no need to use hyperspaces anymore.
    macbook pro 13 - 2011, Mac OS X (10.6.7)
  • Maxime Lemoine Level 1 Level 1 (0 points)
    Well, I download the Combo
    MacBook Pro Mid 2009 C2D 2.66, Mac OS X (10.6.6), w Momentus XT
  • ozgarrison Calculating status...
    I don't think 10.6.7 fixes the problem. I didn't have this problem until after I installed 10.6.7. Before I found this thread I thought it was a new problem introduced with 10.6.7. Thankfully I also saw the suggestion for Hyperspaces and so far the problem hasn't returned.

    Message was edited by: ozgarrison
    MacPro, Mac OS X (10.6.7)
  • Tealie Calculating status...
    I didn't have this problem until 10.6.7 either! A quick fix I found was to plug in an external keyboard (I used a mac one) and it seemed to fix itself immediately.
    MacBook Pro, Mac OS X (10.6.7)
  • ozgarrison Level 1 Level 1 (0 points)
    I've already got an external keyboard, and un/plugging it doesn't help.
    MacPro, Mac OS X (10.6.7)
1 ... 14 15 16 17 18 ... 20 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.