Previous 1 16 17 18 19 20 Next 292 Replies Latest reply: May 7, 2013 6:42 AM by kwxr2000 Go to original post
  • Matthias Aurelius Jude Shapiro Level 1 Level 1

    The first 16 pages of this thread were about an issue that occurs when switching between Spaces and results in the keyboard not working for typing, but with the ability to switch Spaces and use the brightness, volume, and playback keys (but NOT the Exposé or Dashboard ones); the last few comments about the keyboard and mouse stopping functioning entirely is a different, unrelated issue. In the latter case, the kb & mouse typically disappear from the System Profiler list of USB devices.


    I too have the Spaces issue -- after switching Spaces a few times, the Spaces window hangs on the screen until I switch Spaces from the Menu Item, at which point it'll fade away but keyboard input still fails to be recognized as such (or is being captured by a rogue process).


    Sandra -- those log errors occur from a known issue with Google Chrome, although I thought it was isolated to the developer build (which I'm using). However, they only seem to occur randomly for me, but when they do occur they appear continually while I'm interacting with Chrome. Switching to a different application results in a halt to their generation, until I go back to Chrome. Not sure whether they're indicative of something going on with Spaces though, since I get them plenty even while not using Spaces.



  • RedHavoc Level 3 Level 3

    I am experienceing this problem as outlined in the original post.


    Random spacer switch bezel image getting stuck, can switch spaces, use brightness and volume keys, but nothing else. Happens often when using Screen Sharing.


    No fix for this yet?!

  • matthewfrompittsburgh Level 1 Level 1

    Hey guys, here's a workaround:


    When it happens, press the following keys: CTRL, SHIFT, EJECT.

    It puts the screen to sleep and releases the keyboard.


    *****, but it works.

  • markked Level 1 Level 1

    ^ That works, thanks so much! Saves me so much time on a restart.

  • Maxime Lemoine Level 1 Level 1

    I don't know for you, but I still have this problem with 10.6.8.

  • Wert© Level 1 Level 1

    I have it too :|

    10.6.8 didn't fix it for me either.

  • Da3dalus1 Level 1 Level 1

    I've had my Mac Pro for 3 years, never had a problem before now.  Clearly the Space/Dock bug.  I think what set it off was when I opened 2 large applications in rapid succession (Parallels Desktop 6 and ArchiCAD 15), which are each set to open automatically in a separate space.  I had to restart several times; each time, when I logged onto my account (with Spaces active), it would beachball the cursor, disable the dock, and even ignore Force Quit.  Even the Ctrl-Shift-Eject didn't work.  Managed to open activity monitor, but couldn't scroll or select anything.  However, I could log onto other accounts fine (including Admin), since they had no Spaces.  Repairing Permissions from that account did nothing.


    The fix for now:  Managed to log on, and immediately went to Preferences and turned off Spaces.  Even touching the dock or desktop applications seems to set it off.  Unfortunately, I really like Spaces, and I hope I can turn it back on.


    This MUST be a preferences file problem.  I'll try some things and report if I get a sure-fire cure.




    Mac Pro 3,1 - 2x2.8 GHz Quad Xeon, 8 GB RAM, 750 GB HD, nVidia GeForce 8800 GT 512 MB

    Mac OSX 10.6.8

  • Da3dalus1 Level 1 Level 1

    Following up... the computer worked OK for a short time, then, on my account, it went back to the beachball/keyboard lock behavior, even with Spaces turned off.  Hard shutdown is the only way out.


    I found an article that identified the preference files to erase:

    Since the Dock is involved in this problem, you might try removing its preference files, which are "" and "," located in the /username/Library/Preferences/ folder.


    I had to do this from my Admin account, which required changing a bunch of Library permissions.  This wiped out my Dock and Spaces setup, but it appears everything's OK.  I'm a little scared to turn Spaces back on, so I'm going to see if I can live without it for a while.


    Hope this helps someone!



  • jmanuelm Level 1 Level 1

    hi everybody,


    I'm a newbie in apple's world.


    I've been working inside windows world for 20 years and I switched to mac 2 months ago.


    The main reason why I did it is cause I'm fed up using an intel-win platform that stops working without support, with funny error messages and no clue of what's happening bellow the user GUI.


    I need something stable, that never fails, cause I have no more time to waste on troubleshooting.


    I expected Apple to be good, stable, maybe we don't have all the possibilities windows apps offer, but you know that if apple sets a new functionality, it will work.


    But this keyboard issue is unacceptable, annoying, and this is something I was not thinking on facing once I moved to Apple.


    I would not buy more apple products if I knew this kind of failures.

    And the lack of support is also unacceptable.


    18 pages in the apple discussion forum without and official feedback.


    thanks to the reply of CTRL+SHIFT+EJECT. it works for me as a workaround, but the image of Apple I had in mind is gone.

  • Da3dalus1 Level 1 Level 1

    I'm happy to report that after deleting those library files, and turning Spaces back on, everything appears to be working.  I've been using multiple apps in different Spaces for the last couple of weeks with no problem.  The only issue was that I had to rebuild my Dock from the default layout, which took about 10 minutes, and reset my Spaces preferences.


    This is also a good reason to have an Administrator or Admin account set up, with full permissions, used just for emergencies.  Many problems can much up an account, while the basic OS is fine.  It's even a good practice to set all of your user accounts with limited privileges, for added security, though I find this a little too restrictive.


    Hope this helps someone!



  • Schroeder Level 1 Level 1

    Didn't work for me.


    I uninstalled Babylon (and its "activation agent", always on) and everything's fine now.

    It's a short term test (only a few hours), but it's an educated guess: try looking in your system for "agents" activated by key combinations.

  • westmoquette Level 1 Level 1

    I erased the preference files as shown in the link, and everything worked fine for maybe a day. Now the problem has started again. After it happens, I open the Activity Monitor and kill the Dock process. This is the quickest way I've found to recover from the keyboard lock.


    New observation: After the problem has happened once, it happens every subsequent time I switch spaces using the keyboard shortcuts - very frustrating. Everytime I have to kill the Dock process to recover. However, if I stop using the keyboard shortcuts (and switch e.g. using F8 and click) for a while, or leave the computer sleeping overnight, everything goes back to normal and the keyboard shortcuts work again - for a time. Is there a buffer that gets filled, or a cache that gets emptied after some time...??



  • GWBii Level 1 Level 1

    As a workaround, I created an applescript app that kills the Dock. That gets the keyboard working again. I just leave the app on my desktop so I can easily get to it if the keyboard stops working. To do this, open the AppleScript Editor, add the line:


    do shell script "killall Dock"


    and save it as an Application.

  • regnauld Level 1 Level 1

    Seems to still be an issue in Lion - am experiencing it, and so are others:


  • cashshadow Level 1 Level 1

    The kill Dock method does indeed work, but as others have mentioned, once the bug introduces itself, well, you have to kill the Dock alot if your fingers have become accustomed to switching spaces using keyboard shortcuts. So its a problem with the Dock process, that much is for sure.


    One solution is to install Hyperspaces, you can easily google it, it's about 30$. It seems to capture the keyboard shortcut before it can mess with the Dock process. Since using it, the bug has not manifested itself.