Previous 1 3 4 5 6 7 Next 292 Replies Latest reply: May 7, 2013 6:42 AM by kwxr2000 Go to original post
  • direwolf8 Level 4 Level 4 (1,280 points)
    I've run into the problem with and without VMware, 2.0.X and 3.0 versions.
  • Connor Jackson Level 1 Level 1 (0 points)
    I have been having this same issue. The only way I have found to regain keyboard access short of a reboot is to open Activity Monitor, Quit the UserEventAgent process, which at that point had crashed, THEN restart the Dock process. Only a temporary fix.

    Connor
  • griso_n Level 1 Level 1 (0 points)
    Same problem here, happens about once or twice a week while switching space, very annoying!!!
  • Juha Karttunen Level 1 Level 1 (0 points)
    The keypad behaviour sounds exactly like if you had turned Mouse Keys accidentally on by pressing ALT multiple times.
  • treyethan Level 1 Level 1 (0 points)
    I don't know about others' experience, but for me at least the problem has WORSENED since applying the 10.6.2 update. Specifically, I've now started to have the keyboard lockup problem when I exclusively use the Dock icons to change Spaces. Before, it only cropped up when I used the keyboard shortcuts (specifically, the geometry-related ones like ^←, ^1, etc., not the application-switching ⌘⇥, ⇧⌘⇥, etc.).

    This is highly frustrating.
  • ledi Level 1 Level 1 (0 points)
    Similar problem - external pro keyboard (USB) and Mighty Mouse (USB) cease working for a certain period of time (a few seconds or longer) - mostly when using safari - trackpad and MBP keyboard are still responsive. I noticed that activity monitor often shows skype as "not responding" at the moment the freezes happen. No solutions found yet.
  • DPH1981 Level 1 Level 1 (0 points)
    So, I have this keyboard problem as described, but I'm not using anything that's been mentioned here - i was convinced it was a Quicken 2007 issue until I found that other users in my house have seen it too and I'm the only one who uses Quicken. I don't use Spaces, etc - seems like a very generic, random thing. Sometimes after I reboot, it happens again immediately. i seem lately (since 10.6.2?) to get more missed keystrokes, but the random repeats (across the page/field) as described also.
    Is there an agreed upon workaround? I tried to follow some of the suggested ones, but apparently don't really know how to start as I had no luck. Couldn't find where to "Quit Dock" - sounded promising.
  • Dan F Level 2 Level 2 (420 points)
    Unplug the keyboard, then plug it back in. Shouldn't have to reboot computer.

    I've had similar behavior happen with firewire devices as well.
  • Nic Heuser Level 1 Level 1 (0 points)
    I have been having this problem more often lately--3 or 4 times in the past two days! I do NOT use Spaces (it's turned off completely), and killing the Dock process doesn't help. Sleep/Wake also doesn't help. I've read this entire thread so far, and none of the suggestions work, except rebooting, which always works. I'm running 10.6.2 on a MacBook Pro, so there's no unplugging the keyboard. When it happens, my Magic Mouse and Trackpad both continue to work just fine, as do the Command, Option, Shift, Tab, Arrows, and F-keys, but it's just the character-producing keys that stop working. This is a big problem, and Apple needs to fix it SOON!
  • valrus Level 1 Level 1 (0 points)
    Dan F: That doesn't work, as others in this thread have pointed out.

    Curiously, I found that ⌘⌥⎋ worked correctly to bring up the "Force Quit Applications" window. I use ^⇧(arrow keys) to change Spaces.
  • Kevin Powers1 Level 1 Level 1 (30 points)
    I, like a few other people in this thread, don't use Spaces or BBEdit. I have my keyboard freezing up a few times a day. Sometimes it gets sticky or unresponsive keys briefly and then goes totally dead. Usually the mouse (attached through the keyboard) stills works, but it has occasionally frozen as well.
    Not only am I not using Spaces, but sometimes I'm not using anything - all applications are closed and the only thing on my screen is my desktop.
    Usually, but not always, unplugging the USB and reconnecting it fixes the problem.
    I guess there's at least two separate issues in this thread.
  • NewtonLewis Level 1 Level 1 (0 points)
    Like Kevin mentioned, I too do not use Spaces or BBEdit. After installing Snow Leopard, I had the keyboard freeze on me when trying to log in after the screensaver kicks in. I turned off the "Require password to wake computer from sleep or screensaver" option as I thought this would solve my problem. However yesterday and just a while ago, the keyboard froze on me when switching between applications using +Tab. Yesterday I had to shut down the MBP for my keyboard to start again. Today I managed to get it working after hitting random keys for about a minute. Both times, the trackpad continued working.
    I really hope Apple fixes this issue (besides other issues) in 10.6.3.
  • Nic Heuser Level 1 Level 1 (0 points)
    Well, I feel like a total idiot, but at least MY particular variation of this problem is resolved! The last time this problem happened, I was going through every key on the keyboard to see what worked and what didn't, and I noticed that some of the keys actually caused the mouse pointer to move by one pixel. That's when I realized that "Mouse Keys" was on. If you look in the System Preferences, Universal Access, Mouse & TrackPad, theres a checkbox option that says, "Press the Option key five times to turn Mouse Keys on or off." Mine was checked, and apparently I had been pressing the option key repeatedly (learning a new 3D program that uses the Option key a lot), and eventually Mouse Keys would turn on, rendering the keyboard almost useless. When I discovered this, I turned Mouse Keys off (and unchecked that box), and the keyboard worked again. I am convinced that it was only Mouse Keys causing this issue all along, and now that I turned off the checkbox, I don't expect to see this problem again. This may not be the same problem that the rest of you are seeing, but hopefully my discovery can benefit at least a few of you.
  • Shun Chu Level 1 Level 1 (10 points)
    Since nobody has a solution yet, I have an AppleScript that will simplify the Dock killing process painlessly.

    Here's the script I have:
    http://www.mediafire.com/file/4yhnaozmi1z/killdoc.scpt.zip

    Simply open it in AppleScript Editor and save it as an app and have a go with it. I keep it in the Dock in case the Dock hangs. It launches the Terminal app and runs a simple command "killall Dock". You can modify it to quit the Terminal app after the command if you wish. But since I almost always have Terminal open, it's nice to have the script run the command as is. Also, if the current Terminal is running something already (say, "top"), it will open a new tab and execute the command there. Big thanks to Neil Lee for the initial script I've adopted it from. It's only been tested on OS 10.6.2. Sorry.

    Let's hope Apple fixes this issue soon!

    Cheers!
  • neu242 Level 1 Level 1 (10 points)
    That's almost as simple as my automator app earlier in this thread: http://discussions.apple.com/message.jspa?messageID=10214371#10214371
Previous 1 3 4 5 6 7 Next