10 Replies Latest reply: Oct 31, 2009 5:57 PM by pdeblank
Jess123123123 Level 1 Level 1 (0 points)
when i turn home share on it askes me to log in and i do but after i push loging home share disapiers from my options on the side. how do i fix this problem?
  • sjlocke Level 1 Level 1 (0 points)
    Home sharing was working the other day when I first enabled it, but today, I start up iTunes, and there is no Home Sharing icon, and no music in my music folder. Disabling and reenabling makes it appear for a flash, and then gone again.

    Help!
  • RCook Level 1 Level 1 (0 points)
    Getting Home Sharing to work was not as straight forward as Apple would imply, I too was getting the disappearing icon, this is what I found worked for me:

    First you need to have available activations on your iTunes account, as does the other person(s). If you don't have any available activations you will need to deactivate all accounts and start over. I assume that Home Sharing is simply a front end to activation for your iTunes account but it doesn't seem to work correctly.

    Once you have made sure you have available activations on the respective accounts then you must activate your account on the other persons computer and vice versa. Once this is done you can then turn on Home Sharing and log in using your iTunes account, the other computer can also turn on and activate HS using their iTunes account.

    Now magic happens and you should be able to share libraries.
  • sjlocke Level 1 Level 1 (0 points)
    What? I have two computers, both are authorized under the same account, and both were home sharing the first day with the same account. Now, home sharing is nowhere to be seen.
  • Doug Sekus Level 1 Level 1 (0 points)
    I have the same problems. Very buggy. It worked just fine the second day, now the icon shows up sometimes on one PC and not the other, then the other way around, and now not on any. I close and reopen iTunes and I see the icons for a few seconds, sometimes for a few minutes .... A real mess.
  • drhollywood Level 1 Level 1 (0 points)
    Here's the fix that worked for me. Log into each itunes as the same user. Do this by logging out what user is setup in Itunes and then logging in the user you want to share music from. Then you will need to do the reverse for any other Itunes accounts. Do this for all accounts on all machines. Then the icon for home sharing stays up and works. Do this for all accounts and all computers you have( still limited to the 5 authorized ). Seems like a weird fix, but it does work.
  • wickedshopper Level 1 Level 1 (0 points)
    I have encountered the same problems with home sharing that was listed and none of the fixes have lasted. I have authorized users on both notebooks and enabled home sharing. It worked fine the first day and now won't show up at all except when you are enabling or diabling the account. None of the other libraries show up anymore even after authorization, deauthorization and reauthorization of the accounts/computers and with enabling and disabling the home sharing function. Very buggy system and there is no help on the apple website. Too bad Apple put a beta product out for use without ensuring that it works. I also lost some videos after I upgraded to Itunes 9. Anyone had success resoring items from their backup files?
  • Doug Sekus Level 1 Level 1 (0 points)
    It works sometimes, and does not last. The feature is just buggy. It needs to be fixed.
  • Samuel Poppen Level 1 Level 1 (10 points)
    I removed the iTunes library file from my iTunes folder. then i have no library or playlists but HomeSharing shows up. If you export your main library ("playlist") before doing this you can always import it again. Don't know if it'll return your playlists though.

    meh
  • SlighSniper Level 1 Level 1 (0 points)
    I was having the same issue when I found out that both computers MUST be connected to the internet and iTunes needs to be open on both of them as well. When I opened iTunes on my second computer it automatically updated in my Shared tab
  • pdeblank Level 1 Level 1 (0 points)
    Same problem, except I could not ever make it work. The Sharing icon in the tabbed list on the left shows up when you first authorize/de-authorize/authorize the computers, but when you then try to click on it, it disappears.