Skip navigation
This discussion is archived

Annoying Firewall Allow / Deny Dialog

27460 Views 32 Replies Latest reply: Sep 1, 2010 11:46 PM by fmLIE RSS
1 2 3 Previous Next
KyleGawley Calculating status...
Currently Being Moderated
Sep 16, 2009 6:53 AM
Hi,

Ever since upgrading to Snow Leopard, I've begun to notice this incredibly annoying dialog boxes popping up with various pieces of software - mainly the Adobe CS4 suite whenever I open up a Save/Save As dialog box.

For a second or so, a message pops up asking if I want to Allow or Deny the current application, then it vanishes with no input from myself.

Is there any way of disabling this dialog box within SL?
Macbook Pro 17", Mac OS X (10.6.1)
  • Craig Anschuetz Calculating status...
    Currently Being Moderated
    Sep 16, 2009 3:43 PM (in response to KyleGawley)
    I notice this too. You can turn your firewall off in System Preferences>Security>Firewall tab. However, I would advise against doing this.
    MacBook Pro 15" 2.53 GHz Intel Core 2 Duo, 4 GB RAM, Mac OS X (10.6.1)
  • beaut Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 16, 2009 6:17 PM (in response to KyleGawley)
    I have been getting this too, but it comes and goes so quick that can't read what it wants me to allow or deny, tried catching it with a screen shot, but too quick to catch on photo. so it does get realy annoying as pops up every minute or so..
    Macbook5,2, Mac OS X (10.5.6), 2. GHZ 2. GB
  • Toukay Calculating status...
    Currently Being Moderated
    Oct 1, 2009 10:15 AM (in response to beaut)
    This is a recurring problem for me too. I currently cannot connect to any network drives without first turning off the firewall.

    This is UNACCEPTABLE. Please fix Apple.
    imac 2007 24", Mac OS X (10.6.1)
  • donv (The Ghost) Level 5 Level 5 (4,600 points)
    Currently Being Moderated
    Oct 1, 2009 11:28 AM (in response to KyleGawley)
    What environment are you using the firewall in? I never use it unless I am at, say, a Starbucks--i.e., a public network. The rest of the time I am behind an excellent router firewall. If your situation is similar, then just turn the firewall off.
    15" 4 GB 2.8 GHz 500 GB MacBook Pro with LaCie 1TB external 7200 RPM RAID 0, Mac OS X (10.6), PowerBook 540c; iBook G4; 2 Dell Laps; 1 HP Lap; Mega Gateway FX Desk
  • gavjones Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 1, 2009 2:21 AM (in response to KyleGawley)
    Yeah im getting this too, its annoying hopefully a fix will come soon
    MacMini; Macbook Pro 13"; iPhone 16GB; AppleTV, Mac OS X (10.6.1)
  • gavjones Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 12, 2009 1:40 PM (in response to gavjones)
    Just updated to 10.6.2 and still getting the pop up
    MacMini; Macbook Pro 13"; iPhone 16GB; AppleTV, Mac OS X (10.6.2)
  • donv (The Ghost) Level 5 Level 5 (4,600 points)
    Currently Being Moderated
    Nov 12, 2009 5:36 PM (in response to gavjones)
    Depending on your circumstances, the work around I posted above should be satisfactory until a real fix turns up, if ever. The work around is, IMO, better than receiving the annoying messages.
    15" 4 GB 2.8 GHz 500 GB MacBook Pro (10.6.2)-LaCie 1TB external 7200 RPM RAID 0, Mac OS X (10.6), Boot Camp/Win7; PowerBook 540c; iBook G4
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Nov 13, 2009 4:11 PM (in response to KyleGawley)
    I've had this, too, on only one app (so far).

    Low-tech solution:

    1. Start something(s) that will tie up your computer, so the dialog box stays on screen a bit longer.

    2. Hold one finger over the Return key while doing whatever causes the box to appear.

    3. The instant it does, press Return.

    4. You may have to repeat for each app that's doing it.
    24" iMac 9,1 2.66 GHz; 4gb; 640 gb, Mac OS X (10.6.2), dual-band AEBS v. 7.4.2
  • opmisk Calculating status...
    Currently Being Moderated
    Nov 24, 2009 7:59 AM (in response to KyleGawley)
    I'm experiencing the same problem on both my iMac and Macbook since installing Snow Leopard. It only happens with a few apps but is annoying nonetheless. Most recently it started occurring with Handbrake. I've added firewall rules for each that seems to be affected but the pop up still occurs each time I open the app, and usually several times while working within the app.

    Like others have mentioned, the window flashes for only a second before disappearing... very annoying.
    iMac 2008, Mac OS X (10.6.2)
  • Ecualgeacy Calculating status...
    Currently Being Moderated
    Nov 28, 2009 4:55 PM (in response to KyleGawley)
    Bought my iMac 21.5" Sunday 11/22. I'm having the same problem with the firewall on. Everytime I open a program that I downloaded from the web (OpenOffice, RealPlayer, etc.) it pops up the Allow or Deny window for just a second before it goes away. It keeps flashing it every few seconds, usually in the same spot, so if you can catch it and hit the Allow, it will usually stop showing up for that program.
    iMac 21.5" 500GB, Mac OS X (10.6.2)
  • Bob Jackins Level 4 Level 4 (1,990 points)
    Currently Being Moderated
    Nov 28, 2009 8:03 PM (in response to Ecualgeacy)
    Maybe it's a "Vista Virus" LOL
    Imac G5 Rev B 20, Mac OS X (10.4.11), Ipod touch 16 GB
  • Sunkai Calculating status...
    Currently Being Moderated
    Dec 1, 2009 3:35 AM (in response to Bob Jackins)
    I have the latest Macbook and OS X version, and I have this issue with many applications, including Adium and WinClone.

    Is there a way of configuring the firewall to set up working exceptions for these applications? The constant popups are a deal breaker for me, and I will have to leave the firewall off unless this is fixed.
    Macbook A1342, Mac OS X (10.6.2)
  • kpowick Calculating status...
    Currently Being Moderated
    Dec 9, 2009 1:51 PM (in response to KyleGawley)
    This one is driving me crazy too. OSX 10.6.2 on MBP 15".

    Took quite a while to enter the correct search terms to find this thread, but I'm glad I'm not the only one having such an issue.

    Firewall is on and set to not allow anything access automatically. I did try enabling the option to allow signed applications access, but it did not appear to make any difference.
    MBP & iMac, Mac OS X (10.6.2)
  • A*J*P Calculating status...
    Currently Being Moderated
    Dec 10, 2009 6:59 AM (in response to KyleGawley)
    Same problem here with at least Adobe After Effects CS4 and Premiere Pro CS4. Allowing them permanently in firewall settings does not help. I also thought I managed to click "allow" button for couple of times, but it has not helped either.

    Very annoying, since the dialog box interrupts what ever you're doing in another application by making the current app window inactive for a couple of seconds.

    The pop-up seems to often come when you try to import something and the finder window opens.
    Mac Pro, Mac OS X (10.6.2)
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.