3 Replies Latest reply: Sep 30, 2009 10:24 PM by michellinha22@gmail.com
llcarpe2 Level 1 Level 1 (0 points)
Choose>Tools>Download only and try manually.

and everytime i try to do it manually it tells me this again it won't update my itunes.

What dod i do?

Dell, Windows XP
  • lisfolks Level 1 Level 1 (70 points)
    I'm having the same problem. It seems this occurs often, based on other discussions, but I'm not sure what to do in this case.

    I am running Windows XP via VMWare Fusion on my Mac.

    I run ASU (Apple Software Update) in XP, and it shows me 6 updates available. When I click "Install 6 items", it steps me through the agreements (which I accept). It seems to work for a moment, then I get the message "Errors occurred while installing the updates. If the problem persists, choose Tools > Download Only and try installing manually." I click OK, and ASU restarts, displaying my 6 updates.

    One of the updates is for ASU 2.1.1, so I try downloading that one. I deselect the other updates. Then, I click Tools > Download Only. ASU shows "Verifying...". Then, it returns the message '"Apple Software Update" has an invalid signature. The download has been removed.' I click OK. The Documents and Settings folder for my user opens up, and ASU restarts simultaneously.

    Where do I find the Apple Software Update update to download manually from Apple's site? (It seems this is the next step suggested in most discussion articles...)
  • lisfolks Level 1 Level 1 (70 points)
    Try installing the Safari+QuickTime Update for Windows from Apple's site - that's what worked for me! Here's what I did:

    I went to Apple's Downloads site -
    http://www.apple.com/downloads/macosx/apple/

    I clicked on Application Updates at the left, found Safari 4.03 (I was still on version 3), and clicked the Download button under the description.

    I clicked the radio button for Safari 4.03+QuickTime for Windows XP or Vista. (QuickTime was one of the updates that wouldn't work for me earlier, so I figured I'd do both at once.)

    Then, I clicked the Download Now button. When the download completed, I clicked the spyglass icon in the downloads window to locate the downloaded file. Then, I double-clicked SafariQuickTimeSetup.exe (the downloaded file) to start the install. (I did close Safari at that point, too.)

    As the install ran, I noticed that it removed and reinstalled ASU as well! Then, towards the end of the installation process, it popped up ASU - this time with only 3 items to install. I selected to do the update, and it seemed to work together with the install program. I got some red exclamation points AND the message about 'error installing', which I OK'd through. The Safari installation continued for a bit to completion and launched Safari successfully.

    Re-running the ASU, the applications that had had the red exclamation points earlier were no longer there; however, some new ones were. I ran those successfully, without any errors! Phew! My stuff is now updated, and I hope this tip will work for you, too.
  • michellinha22@gmail.com Level 1 Level 1 (0 points)
    lisfolks.... thank you.

    without my iphone I am nothing. and without the itunes update (kept getting error message while downloading) apparently my iphone flips out and stops working and just says to reconnect to itunes. I did what you said. But only after I uninstalled my old Itunes version (as recommended by an apple expert) then I went to this website and reinstalled and didnt move an inch. Just ok. Ok. Ok. (Please god) ok. I had to restore my iphone. But most of my stuff is still there. hallaluhah!

    http://www.apple.com/downloads/macosx/apple/