13 Replies Latest reply: Sep 24, 2009 2:23 PM by Pope7
Pope7 Level 1 Level 1 (10 points)
Please, do not link me to http://support.apple.com/kb/HT2773, which is everyone's default reply to LOM issues.

I'm trying to get LOM setup on my server. And here are the issues I've run in to. Up front, the server is already setup, so using Setup Assistant is out.

When I use Server Monitor on the XServe itself, it connects fine to 127.0.0.1 (as expected). But of course, I want to connect to it via the IP. However, I'm not sure what the LOM was originally set to.

The server has an ip of 10.0.0.20. And I want the LOM to be 10.0.0.21. Yes, 10.0.0.21 is free for use.

I used "ipmitool lan set 1 ipaddr 10.0.0.21". And then I used Server Monitor to match those settings. And I verified the user settings with "ipmitool user list 1"

Now, if I try to use Server Monitor from the XServe for 127.0.0.1 it connects fine. For 10.0.0.21 it says "Incorrect user name or password".

However, I know the username and password I entered are correct. And if I look at the log it says "Failed to connect to server".

If I add the server with a completely made up username and password the same error occurs in the log ("Failed to connect to server".

If I add the server with a completely made up IP, such as 10.0.0.90, the same error occurs in the log ("Failed to connect to server").

So from the log it is not possible to tell whether their is an actual problem communicating to the LOM ip address or whether it is actually a username and password problem.

I also used ipmitool to manually set the user and password just in case Server Monitor was being wonky and not correctly setting them.


What steps might I be over looking?
What should I try trouble shooting next?

MacBook Pro, Mac OS X (10.5.4), Plus two XServes
  • MrHoffman Level 6 Level 6 (13,020 points)
    Did you unplug the Xserve power from box for thirty seconds, and then power it up? Once the LOM has been reset, can you connect from a remote host? From the local box? Getting the LOM going from the local box via IP involves NIC configuration and IP routing.
  • Camelot Level 8 Level 8 (46,320 points)
    AFAIK you always need to use localhost/127.0.0.1 when using Server Monitor to connect to the machine it's running on.

    You should test your 10.0.0.21 LOM address from a different machine on the network.

    Even though LOM is supposed - even designed - to work remotely, it shouldn't prevent you from using the network address from the machine itself. I know that doesn't make a whole lot of sense, but it does seem to work that way.
  • MrHoffman Level 6 Level 6 (13,020 points)
    I've not tried NIC (set for host operations) to NIC (set for LOM operations) static routing here, which might work here. (Not that I want to try that, nor would I recommend that. Way better to use localhost here.)
  • Pope7 Level 1 Level 1 (10 points)
    Things have been busy - sorry about the delay in response. Over the weekend I played with the LOM (powering off for 30 seconds whenever I made a change).

    From the local machine 127.0.0.1 works fine. (I'm not going to worry about 10.0.0.21 working on the local machine, since all I'm actually concerned in is getting LOM to work from other machines. (But I appreciate all the notes on where I'd have to start looking to get that working)

    Now when I try to connect from a remote machine to LOM on 10.0.0.21 there is no response. The log gives "Failed to contact server". Seems like it has all taken a step backwards.

    Also, ipmitool user list is now giving "Command failed with error 0xfffef9cc" and ipmitool lan print gives "Channel 14 is not a LAN channel."

    I'll tinker with the settings this evening if someone has a good suggestion. Is LOM typically this difficult to establish?
  • Camelot Level 8 Level 8 (46,320 points)
    Now when I try to connect from a remote machine to LOM on 10.0.0.21 there is no response


    Where are you testing from? more specifically, what's the IP address of the machine that you're testing from?

    This could just be an issue with routing - your machine needs to be able to route to 10.0.0.21, and the LOM needs to be able to route back to your machine.

    Of course, if your machine is in the same subnet then routing shouldn't be an issue, in which case you could be looking at a port authentication or VLAN issue.
  • Pope7 Level 1 Level 1 (10 points)
    I'm sitting at 10.0.0.54, so there shouldn't be a problem there.
  • MrHoffman Level 6 Level 6 (13,020 points)
    Pope7 wrote:
    I'm sitting at 10.0.0.54, so there shouldn't be a problem there.


    Shouldn't be a problem? Um, it's IP. Almost by definition, there are problems when IP is involved. Thanks for the chuckle, though.

    Any managed switches or vLANs or routers in the network here?

    The comment indicates the box was powered off for thirty seconds. Is that exactly what was done? Or was the box unplugged for thirty seconds? (Yes, I know, this question can be construed as pedantic, apologies for that, and yes, this requirement is discussed in [HT2773|http://support.apple.com/kb/HT2773], but this distinction is important here. But what was written can lead to exactly what is being seen here.)
  • Pope7 Level 1 Level 1 (10 points)
    Excellent point - I never unplugged the lan connection. Okay, after work hours are over tonight I'll try again but I'll be sure to power off the server and disconnect it (ethernet and power).

    I'll let you know the outcome.
  • MrHoffman Level 6 Level 6 (13,020 points)
    The power connection is the key here and not the LAN connection(s). The power supply (or power supplies) must both be disconnected from the mains for 30+ seconds as part of the LOM restart sequence. The LOM is otherwise always "hot" - running - whenever the mains are connected.
  • Pope7 Level 1 Level 1 (10 points)
    Thanks for all the help with this.

    (In the following, unplugged = ethernet, ac power, etc)

    - I powered down and unplugged last, and the problems persisted
    - I powered down, unplugged, booted up, issued ipmitool reset, and still no luck
    - I powered down, unplugged, booted up, and used the Server Monitor LOM reset option and no luck there either.

    Since LOM is amazingly convenient but not a strict necessity at the moment, I'm going to put it on my "when I have free time" list for the moment. But if you have more recommendations let me know.

    Edit: And to answer a question from earlier - nothing fancy here. No vlans or odd router setups.

    Message was edited by: Pope7
  • MrHoffman Level 6 Level 6 (13,020 points)
    To ensure I still understand what you're trying here, you're working to connect via the IP address into the box that's with LOM, correct? Not via localhost, but via the published IP address, directly from that same Xserve box host?

    If that's the case, that typically does not work. (If this is the case, then you're dealing with how IP and Ethernet work here; a host that's transmitting a packet is not listening to receive that packet, and the Mac OS X driver stack isn't AFAIK set up to "reflect" this traffic at a higher level. Yes, technically, a Ethernet station can listen for jamming. But that's typically the limit for listening while transmitting.)

    If you're trying to connect from another host, that's supposed to work. This presuming that one or both of the NICs is connected and operating, and that the LOM is configured to be connected to one (or both) of the connected NICs, using unique addresses for each connected NIC.

    All of which is pretty much what's in that previously-cited [HT2773 support article|http://support.apple.com/kb/HT2773]. Which then implies there's a hardware problem or a LOM configuration or a network problem with this Xserve box, presuming you're using a remote client trying to connect to the Xserve box.
  • Pope7 Level 1 Level 1 (10 points)
    MrHoffman,

    I am trying to access LOM on the Xserve from my Laptop. I'm not sure why I'd ever want to connect from the Xserve to its own LOM, especially when I could just connect via local 127.0.0.1.

    Both machines are behind the same point of the network. The server is 10.0.0.20 with a lom address of 10.0.0.21. And my laptop is 10.0.0.54.

    Here are the problems I've had with HT2773...
    1.) Server Assistant is for when setting up the machine.

    2.) Server Monitor - I've repeatedly tried to setup LOM using this, but to no avail. When I try to connect from my laptop it always says ""Failed to connect to server" in either of the following scenarios...

    Scenario 1: When given the right IP address but wrong username and password
    Scenario 2: When given the wrong IP address and right username and password

    So trouble shooting if it is a connection or a user problem is difficult.

    3.) I tried using ipmitool, but now it is giving the two errors I listed previously...

    "ipmitool lan print" gives the error: "Channel 14 is not LAN"
    "ipmitool user list" gives the error: "Command failed with error 0xFFFEF9CC

    These errors only appeared after I used ipmitool to create a new user and to assign the LOM ip address.

    Message was edited by: Pope7
  • Pope7 Level 1 Level 1 (10 points)
    "ipmitool channel info 1" and "ipmitool channel info 2" give appropriate responses. I'm not sure why in the world it is looking at Channel 14 - or how it got set that way.

    "ipmitool channel info 14" gives...
    Channel Medium Type: System Interface
    Channel Protocol Type: KCS
    Session Support: session-less
    Active Session Count: 0
    Protocol Vendor ID: 7154

    I've had no luck in getting it to switch to a different channel either.