Previous 1 2 3 Next 41 Replies Latest reply: Jul 22, 2015 2:37 AM by k3comms Go to original post
  • LeWoz Level 1 (0 points)





    You need to chmod 755 the /var and var/lib folders.


    You can do this via ssh by using the following:


    open terminal


    in a new terminal window type


    sudo -s


    then enter your password (you will need to do this in order to secure root access to your My Book World)


    Then type


    ssh (the IP address of your MBWE i.e.


    Password: welc0me (the o is omitted and replaced with a zero '0')


    once you are in, to ensure that you are starting at the root, type 'cd /'


    Then type:


    chmod 755 /var


    chmod 755 /var/lib


    then logout.


    You will then have access to the WD_Backup using the following credentials (however if you changed the password you will have to use the password you changed the user account WD_Backup to)


    username: WD_Backup


    Password: backup


    There was a permissions issue with the /var and /var/lib folders, the timemachine folder resides within the /var/lib container and timemachine needs specific permissions in order to work.


    This is fully tested and I can confirm that we have backed up all of our Macs now.


    Many thanks to for the information

  • nosdois Level 1 (0 points)

    I am also having this OSStatus error 5


    You said "I simply stopped the AFP service and started it again. The error went way, subsequently." But how do you do that?



  • darxider Level 1 (0 points)

    Thank you LeWoz! that did the trick for me.

  • VanEdge Level 2 (185 points)

    I tried this but cannot log in to the ip.

    I keep getting a message: ssh: connect to host port 22: Operation timed out


    Then when I try again I get:  ssh: connect to host port 22: Connection refused


    Any suggestions?

  • darxider Level 1 (0 points)

    if your ip address is correct it could only be that SSH is not enabled. Log on to your mybook control panel -> advanced mode -> advanced -> SSH access enabled.

  • VanEdge Level 2 (185 points)


    thanks very much. you were right about SSH not being enabled.

    I enabled it and was able to enter all the code into Terminal, but unfortunately I still cannot connect as registered user WD_Backup to the NAS. I'm so frustrated as this has been going on for over 6 months and the boards at WD have not been helpful. Anything else you might be able to suggest?

    I'll try anything at this point!


    Thanks again!

  • Per Magnusson Level 1 (0 points)

    Thanks for the tip. Time Machine for clients restored...

  • Homer'sApple Level 1 (0 points)

    ironically i am having the same issue but on a FREENAS 8 BACKUP which was working just fine yesterday! today no CMD+K candy! i am trying this now ...

  • Homer'sApple Level 1 (0 points)

    well that code did not work no terminal - but with FREENAS and AFP espcially one needs to restart both the Mac and the server and re-create a new SHARE - for TimeMachine mind you that you must be explicit in your instruction so:


    on the server :

    exclusive folder for time machine only

    enable discovery of this folder

    enable timemachine discovery of the folder

    goto FINDER on client and do CMS+K and punch in your exclusive path


    TimeMachine is finiky and always has been!

  • qqallan Level 1 (0 points)

    Worked for me. It wasn't a WD firmware issue though; just had to use the wd_backup credentials.

  • jfialkowski Level 1 (0 points)

    Thank you. I did the same thing and this solved my problems.

  • k3comms Level 1 (0 points)

    Thanks Gallai, this worked perfectly for me.



Previous 1 2 3 Next