3 Replies Latest reply: Sep 21, 2009 10:12 AM by Manny Acera
Manny Acera Level 1 Level 1 (45 points)
I use 2 network ranges in the building, a routable IP range for our mac desktops and a non-routable for our PC's. It's a security thing. I need the ability for my PC clients to transfer files to the Xserve. This is where SMB comes into play.

On my xserve, one of the network ports is on the routable range to take care of Mail and AFP. The second port is configured in the non-routable range so my PC's can connect.

The problem is when I configure SMB, the server makes the 1st port (config'd with the routable ip) the Workgroup Master Browser:

***
Samba name server MY_SERVER is now a local master browser for workgroup MYWORKGROUP on subnet xxx.xxx.xxx.xxx
***

The pc's don't see the workgroup or computer name. How can I specify my 2nd port, with the non-routable IP, to be the Workgroup Master Browser?

Mac OS X (10.5.6)
  • Camelot Level 8 Level 8 (46,255 points)
    How can I specify my 2nd port, with the non-routable IP, to be the Workgroup Master Browser?


    From man smb.conf

    socket address (G)
    This option allows you to control what address Samba will listen
    for connections on. This is used to support multiple virtual
    interfaces on the one server, each with a different configura-
    tion.

    By default Samba will accept connections on any address.

    Default: socket address =

    Example: socket address = 192.168.2.20


    so add a socket address directive to /etc/smb.conf
  • Manny Acera Level 1 Level 1 (45 points)
    I turned off SMB, added +socket address = 172.16.my.ip+ in the [global] area of /etc/smb.conf, saved, and turned SMB back up without success.

    My PC's can see the Workgroup but that's as far as I get. I get the following error messages:

    *From Win2k*
    Myshare is not accessible.
    The device is not connected.

    *From Win2k3 Server*
    Myshare is not accessible. You might not have permission to use this network resource. Contact the administrator of the server to find out if you have access permissions.

    The network path was not found.

    Since this is an active server, I'm unable to restart the entire machine at this time.
  • Manny Acera Level 1 Level 1 (45 points)
    Also, you can see how the server is making both of my network ports the master browser by looking at the log:



    [2009/09/21 09:49:45, 0, pid=11037] /SourceCache/samba/samba-187.8/samba/source/nmbd/nmbdbecome_lmb.c:become_local_masterstage2(396)
    ***

    Samba name server MYSHARE is now a local master browser for workgroup MYSHAREWG on subnet rou.tab.le.ip

    ***
    [2009/09/21 09:49:45, 0, pid=11037] /SourceCache/samba/samba-187.8/samba/source/nmbd/nmbdbecome_lmb.c:become_local_masterstage2(396)
    ***

    Samba name server MYSHARE is now a local master browser for workgroup MYSHAREWG on subnet pri.vat.e.ip

    ***