Previous 1 2 3 Next 168 Replies Latest reply: Feb 7, 2016 12:14 PM by domemvs
Jason Wooten Level 1 Level 1
Issue: When using any USB headset or USB audio input device on any Macintosh with any operating system from 10.5.7 to 10.6.1, after about 10-20 minutes of use, all audio from the headset becomes garbled and has a robotic static sound quality.

Tested with: Dozens of different Macintosh Computers over the last 6 months with different USB headsets and microphone input devices.

Reproducable: Yes, via either Garageband, Ventrilo or a number of other software applications that do USB Audio Input

References: sx.html 528&st=40

Additional Information and attempted fixes:
• Tried it with a powered USB Hub
• Switched the Audio Midi Setup input to 48k
• Using Audio Midi Setup to create an aggregate device
• Tried it on different Macs, Different Headsets and Different physical locations
• Tried different USB ports

Message was edited by: Jaycyn

Macintosh, Mac OS X (10.6.1)
  • joseravelo Level 1 Level 1
    Same issue here. My New Mac Mini came with OS X 10.5.6 and everything was working as intended, but i updated to 10.5.8 this past week and my usb headset makes my voice go robotic after 20-30 minutes of using it. Seems like unplugging and pluggin back in fixes things for another 20 minutes but this is really an inconvenience.
  • ryan.maroon Level 1 Level 1
    Heya Jaycyn,

    Thanks for posting about this, very comprehensive . For the longest time I figured it was just my headset until I purchased a new one and had the same issues with it as well. Was wondering though, have you submitted this as a bug report to Apple yet and if so, do you have a ticket number?

    - Ryan Maroon
  • Jason Wooten Level 1 Level 1
    Another user has bug report 7076979 on file - however, the Developer Bug Reporting system will not allow others to view your bug report.

    I have opened another report with more information 7239868
  • Ellyllon Level 1 Level 1
    Same problem here - nothing to do with the headset. (I made the sad mistake of assuming this, then ordering a new one.)
  • Jarrett Kertesz Level 1 Level 1
    I'm having this same problem while using Ventrilo and with a USB headset. After 20-30mins of running Vent, I have to quit it, disconnect my USB headset off of my Intel iMac (Snow Leopard all updated), reconnect it, wait a few and then start up Vent again, only to have the "buzzy" voice show up again whenever I speak.
  • Dabo7 Level 1 Level 1
    Same issue, REALLY annoying, and makes me regret installing the Mac Pro 10.5.7 that seemed to have started it all. So /bump in hopes of an answer.
  • chaoscomposer Level 1 Level 1
    This is a problem, and ventrilo has confirmed it's something that happened in 10.5.6

    I had this problem, and thought it was my Mac Pro or I was the only one (I sound like a robot). I moved to a new guild, where the guild leader there also had a mac, and guess what, he's had the same problem for just as long. The ventrilo forums are packed with people who have this issue, all since 10.5.6.

    Something in the USB chain is being corrupted in regards to mics.

    Message was edited by: chaoscomposer
  • Goatbert Level 1 Level 1
    Just confirming this isn't limited to Ventrilo - it is any USB headset in any voice app. It happens all the time to me when I'm on Skype, and Vent.
  • atimicmedia Level 1 Level 1
    Replacing the AppleUSBAudio.kext file from 10.5.6 fixes the problem

    If you can't find the old version of the AppleUSBAudio.kext you can find it here:
  • thornnastor Level 1 Level 1

    I had until recently a similar issue with my USB headset and stumbled
    over a different solution from the EVO people at

    One just has to use the utility Audio Midi Setup to change the settings
    for the USB audio from 48 kHZ to 44.1 kHZ. After that all is fine for me.

    BTW: My problem occured after the update to 10.5.7.

  • Jason Wooten Level 1 Level 1
    Please do not use the 'replace AppleUSBAudio.kext' fix if you are using 10.6.x as it will cause you all kinds of grief.

    As an update, there is a bug report on file with Apple regarding this issue and the engineers requested some documentation which I have provided.
  • morph21 Level 1 Level 1
    I've been researching about this for months now. Turns out I'm also a gamer and I do use Ventrilo. Not only that, but I communicate with friends through Skype and such.

    On my own, back on Leopard, I did a downgrade of * USB * (sorry, but the "feature" for bold doesn't allow an * to be close to words... very nice) in /System/Library/Extensions/ to the 10.5.6 ones and it worked well. A few other issues appeared for USB devices, but that was MUCH less important than being able to use a good microphone, at least for me.

    Now, with 10.6, I didn't want to try it, specially because there are a LOT of changes. I don't wanna go crazy checking for 32 or 64 bit compatibility and such.

    However, I got a brand new iMac 27", and guess what? Now I don't have a mic that works in here anymore. My old Mac had a mic port that I could use 3.5mm mics, and now, this one doesn't.

    So, yeah, brand new iMac, the built in microphone has a lot of echo, people keep mocking me saying I'm at the bathroom. Very nice.

    Since *the bug has SEVERAL MONTHS, Apple, please fix this*, as for the users, even advanced ones, we are running out of options.
  • cburgess Level 1 Level 1
    I have a 27-inch i7 iMac running 10.6.2 and I can confirm that replacing the kernel extension from 10.5.6 works just fine. I had been having this problem every since 10.6.2 (for some reason it worked up until then). I don't think this fix will work if you are booting with the 64-bit kernel (the default on ALL macs is to boot the 32-bit kernel so you would specifically have to be doing this). I haven't tested it in 64-bit though.

    Here are the steps I followed:

    1) Download the AppleUSBAudio.kext from 10.5.6 from the following URL. zip

    2) Unzip it.

    3) Open up terminal

    4) Make a backup of the existing driver by running the following in terminal

    cp -Rp /System/Library/Extension/AppleUSBAudio.kext ~/Documents/AppleUSBAudio.kext-BACKUP

    5) Exit any applications that are using a USB audio device and unplug all USB audio devices.

    6) Unload the existing AppleUSBAudio driver from the kernel by running the below command in terminal.

    sudo kextunload /System/Library/Extensions/AppleUSBAudio.kext

    If you get an error saying " not found for unload request" your fine. If you get an error claiming it can't be unloaded because its in use (don't have the text in front of me) then stop and go back to step 5.

    7) Remove the existing driver by running the following in terminal.

    sudo rm -rf /System/Library/Extensions/AppleUSBAudio.kext

    8) Put the new driver in place by running the following in terminal.

    sudo mv ~/Download/AppleUSBAudio.kext /System/Library/Extensions/AppleUSBAudio.kext

    9) Load the new driver by running the following in terminal.

    sudo kextload /System/Library/Extensions/AppleUSBAudio.kext

    10) Confirm the new driver is loaded by running the following in terminal.

    kextstat | grep AppleUSBAudio

    The output should look like the folliowing (the 2.5.8b13 is the important bit, some of the other numbers might be slightly different):

    cfb@snarfblat:~/> kextstat | grep AppleUSBAudio
    141 0 0x96c6f000 0x28000 0x27000 (2.5.8b13) <95 94 30 14 8 7 5 4 3 1>

    At this point you should be good to go. The only issue with this "fix" is that any time there is an update from Apple there is a chance that the driver will get replaced with a newer one. After each update you should run the command from step 10 again to confirm that you have version 2.5.8.b13. If it gets updated, repeat the above process.

    NOTE: Jaycyn I have tried to post this to your WoW forum post of the same issue ( 77020&sid=1#18) as that is how I found this thread and the solutions but there is something messed up with my forum account preventing me from posting to the WoW forums.
  • jbctech Level 1 Level 1
    I'm the user that reported bug 7076979 back on July 20, 2009. It has had absolutely no responses and is still left on the OPEN state. I have just made an update to the bug asking for a response. I have also referenced this thread.

    In my original bug, I noted that 10.5.6 did not exhibit this behavior, but 10.5.7 did and I'm still experiencing it with 10.6.2.
Previous 1 2 3 Next