Previous 1 6 7 8 9 10 Next 168 Replies Latest reply: Feb 7, 2016 12:14 PM by domemvs Go to original post
  • 4pack Level 1 (20 points)

    I also have this issue on 10.6.8 for the longest time. I use skype for my business calls a lot and I would often have the people at the other end complaining that I sounded like a dalek (robot) or that the line was terrible etc. I put it down to it being a skype connection problem/mobile phone at other end etc etc.


    I have call recorder running and had to go back and listen to some earlier calls and found thar the robot voice / static was actually captured and recorded, so figured it must be happening locally on my machine before it goes anywhere. Thus I only stumbled into this thread by accident as lately it has been so bad I thought my headset must be faulty and was googling mac usb headsets....


    I tried changing the kext over but the old one refused to load: Failed to load /System/Library/Extensions/AppleUSBAudio.kext - (libkern/kext) requested architecture/executable not found.


    Bu what I did try was going into the Audio Midi setup utility, into the audio window, and selected my usb sound device. In the input tab selected microphone and set the format to 48000.0 Hz (default 44100.0 Hz) 2 channel 16bit.


    This seems to have stopped the problem completley.


    It was very easy to test using skype. Just call the inbult soud test. That records you and plays it back, on the previous setting there was robotic distortion and static for the first few seconds of the call.


    Change and repeat until it corrects.


    This is my sound device id:


    USB Sound Device    :


      Product ID:0x0102
      Vendor ID:0x0d8c  (C-MEDIA ELECTRONICS INC.)
      Version: 0.10
      Speed:Up to 12 Mb/sec
      Location ID:0x1a100000 / 2
      Current Available (mA):500
      Current Required (mA):500


    Try that and see if it helps, its a better fix than replacing the kext, which will not work after an update etc.

  • fakeh Level 1 (0 points)

    Bu what I did try was going into the Audio Midi setup utility, into the audio window, and selected my usb sound device. In the input tab selected microphone and set the format to 48000.0 Hz (default 44100.0 Hz) 2 channel 16bit.

    Wow... that simple after.. two years?!

  • Ben Rose Level 1 (50 points)

    Not for everyone. I've tried this fix before (I found it somewhere online; maybe earlier in this thread, can't remember) and it doesn't work for me. It must be device dependent, or there is some other factor complicating things.

  • 4pack Level 1 (20 points)

    It may well be device dependent, which is why I posted my device I'd. I would guess the settings might also vary as well. So what works for one may not work for another.


    Also I'm not entirely sure the change persists if you restart or unplug etc. I have had the problem return and have to go into midi settings again and set it again.


    I'm using 10.6 as not been convinced to upgrade further ATM. So again that might effect it too???

  • Aaron Greenspan Level 1 (0 points)

    I have several pairs of Logitech USB headsets that I've encountered the stacatto-robot-sound problem with. I use Mac OS X 10.6.8. The problem doesn't occur with analog headphones--with those, I have a different problem, which is that there is audible hissing during and a few seconds after each audio event, after which there's a click and the hissing goes away. But the robot sound problem does occur with all of the Logitech USB headsets I have. I'm working on a MacBook Pro from 2009.


    I have noticed that the robot sounds only start when Mac OS X is out of free memory. Generally that means I have a lot of browser tabs open and the Flash plug-in running in Firefox, but it's not specific to any program or any time period--just the amount of memory being used. Whenever I notice the issue, running Activity Monitor in Applications -> Utilities will reveal something around 20MB free or less, which is basically nothing on a system with 4GB of RAM.


    One solution is to close programs until there's more free memory available, but what's bizarre is that built-in speaker output is never affected no mater how much memory is in use or free, nor does the built-in speaker exhibit the hissing problem that analog headphones tend to have.


    It would be great if the developers at Mozilla, Adobe, and Parallels (who indirectly most contribute to this problem through their respective memory leaks) would fix their bugs. But in the meantime, it would be even better if Apple could take a look at whatever driver/memory management interactions are causing this and just fix it at the OS level already.

  • MrJeaz Level 1 (0 points)

    This problem seems to be present even still in OS X Lion. I have 10.7.3 and still get robotic voice problem.


    It's not always there, and while using Skype, hanging up and redialing usually solves the problem, but still very annoying.


    But really sad that a bug like this is still around after years and years....

  • Gummo937 Level 1 (0 points)

    yes it is still an issue with 10.7.3  after using any voip software (Skype, Mumble, Ventrilo) for about 30 minutes it goes to the degraded robotic sound.

  • Zehwuh Level 1 (0 points)

    Anyone know if this huge annoyance is still around in Mountain Lion? Or if there is any working fix for 10.7.4?

  • MrJeaz Level 1 (0 points)

    The problem is very much existent in Mountain Lion, but as mentioned here, it's not up to Apple fix it. Skype is using some old calls or something and the problem lies with them, which they acknowledge. Sort of, they claim they fix the bug in version 5.3 and won't really listen to claims it isn't fixed.

  • MrJeaz Level 1 (0 points)

    Forgot to add the link to the ticket over at Skype if anyone wanted to follow their discussion.


  • morph21 Level 1 (10 points)

    The problem is not Skype or other software, Apple should NOT have released a new kernel module that simply blows itself up if called the wrong way. It should handle those calls and be stable, or just remove the old API and be done with it.


    This IS an APPLE problem.


    Just to enphasize, after rebooting the computer, without loading any third party software:

    - iChat with audio calls produced the problem

    - FaceTime reproduced the problem during a video call

    - QuickTime recording the incoming audio reproduced the problem


    As far as I know, those are also Apple products, or not? =p


    The whole thing about "it is a third party problem" is a big fat lie. Or better, lets go back to the old version of the kernel module and see if ANY of the products present the issue.


    If you have several variables, it is hard to find the cause, ok. Just change the module, does it work? Yes. People in this thread did so for months, until you could not replace the module anymore due to compatibility with the new kernel.


    This is one of the worst and most revolting issues I've ever had with a Mac, where Apple simply refuses to fix it and accept that they created the problem, while misleading people to blame other companies.

  • MrJeaz Level 1 (0 points)

    It's funny that you should mention it, but I can't reproduce the problem in either of the Apple apps you list. In fact, using Soundflower and LineIn, I've tried recording my voice with Quicktime while chatting on Skype. And when I got told my voice had gone robotic, I listened to the voice on QT and it was fine.


    Yes, the problem started with the kernel change, and while I can't comment for why Apple did it, I'm sure they didn't to it just to annoy people.

  • morph21 Level 1 (10 points)

    MrJeaz wrote:


    Yes, the problem started with the kernel change, and while I can't comment for why Apple did it, I'm sure they didn't to it just to annoy people.

    Oh no, there was a good reason. If I remember right, they wanted to increase the channels and allow more bandwidth through the module. In other words, they did so to improve professional audio applications, which is great.


    However, my last test with Lion was quite simple:

    - reboot, yes, please.

    - login holding "shift", just to make sure you don't load skype or any other "third party" tool. If you're sure you don't have those in your login, feel free to skip this step

    - open quicktime player

    - Menu File -> New Audio Recording

    - on the triangle on the right of QT window, select your USB mic

    - I then just pull the volume slider in QT window to the right a bit, just enough to hear some of my voice

    - play a song, start to sing, whatever, just use the mic

    - you don't even need to press "record", just keep talking, singing, whatever

    - after a few minutes, 10, 15, 20, it varies, I hear my "robot self" talking to me... freaks me out... (lol)


    That is what I do, and the problem is there. Don't know if I'm missing something. =)

  • MrJeaz Level 1 (0 points)

    To add to the frustration, this is not a problem with all USB headsets. I just got this problem a few months ago when my old one broke and I had to replace it.

  • iconmaster Level 1 (0 points)

    USB headset still buzzing in Mountain Lion, and not just with third-party apps. It covers all sound, including iTunes playback and computer alerts.


    Playing with Audio MIDI Setup may reduce the buzz, but didn't eliminate it for me.

Previous 1 6 7 8 9 10 Next