Previous 1 2 3 4 Next 165 Replies Latest reply: Aug 13, 2015 9:18 AM by Brungädda Go to original post
  • LiveMath Level 1 Level 1 (0 points)
    I was experiencing random static and noise from my usb mic (as well as the built-in internal mic when I would switch to it while trying to nail down what the cause was.) SL 10.6.2, iMac 3.06 C2D. It does seem to be a "running out of RAM related problem"; a restart and leaving everything else off *delays* the problem coming back up.

    I tried some of the other solutions out there on the net - creating a "midi augmented" device, etc.

    This solution of replacing the AppleUSBAudio.kext is the only thing that worked. Awesome! Thanks!

    Note: when you install a .kext, you have to run some chown's on it:
    chown root:wheel AppleUSBAudio.kext
    chown root:wheel AppleUSBAudio.kext/*
    chown root:wheel AppleUSBAudio.kext//
    chown root:wheel AppleUSBAudio.kext//*/
    chown root:wheel AppleUSBAudio.kext//*/*/
    to "clean out" the ownership requirements for kext's. Also you need to
    do a chmod:
    chmod 755 AppleUSBAudio.kext
    All of these things need to occur from being in your terminal as "root" or "super-user": su.

    Hope this helps someone else. And, of course, I hope our dear friends at Apple can track this problem down and fix it.
  • Zellski Level 1 Level 1 (0 points)
    The excellent instructions posted by cburgess (near-bottom of previous page) worked perfectly for me - thank you!
  • Einherji Level 1 Level 1 (0 points)
    Just upgraded to version 10.6.3 and I am still experiencing the same problem with my Logitech 960 USB headset.
  • LiveMath Level 1 Level 1 (0 points)
    I, too, upgraded to 10.6.3. The older 10.5.6 AppleUSBAudio.kext got replaced during the upgrade, and the static recording problem immediately reappeared.

    I repeated the steps from cburgess on the previous page, installed the older 10.5.6, followed my addition steps on chown & chmod the .kext, and the input from the USB microphone is, once again, perfect.
  • Zephyrana Level 1 Level 1 (0 points)
    I tried to follow the instruction from cburgess, but ran into problems.

    step 4: make a back-up of the existing driver
    result: cp: /System/Library/Extension/AppleUSBAudio.kext: No such file or directory
    I checked the folder, and there is no existing AppleUSBAudio.kext file.

    step 9: load the new downloaded driver
    result: /System/Library/Extensions/AppleUSBAudio.kext failed to load - (libkern/kext) not found; check the system/kernel logs for errors or try kextutil(8).
    The downloaded file is in my downloads folder.

    Please help? Every 20 minutes I turn into ROBOPRIEST and it's getting old. I don't understand what booting in 64-bit kernel means, and I don't know how to run chowns or chmods.

    I have a Mac Pro with 10.6.3.
  • Einherji Level 1 Level 1 (0 points)
    there are errors in the commands which have to be corrected before using them.

    Step 4 should be like this:

    cp -Rp /System/Library/Extensions/AppleUSBAudio.kext ~/Documents/AppleUSBAudio.kext-BACKUP

    Step 8 should be like this:

    sudo mv ~/Downloads/AppleUSBAudio.kext /System/Library/Extensions/AppleUSBAudio.kext

    I did this but reverted back to the original AppleUSBaudio.kext because I was getting Kernel panics when using the old kext.
  • Zephyrana Level 1 Level 1 (0 points)
    I tried with the corrected commands, but I keep getting errors.

    Step 4 error
    cp: /System/Library/Extensions/AppleUSBAudio.kext: No such file or directory

    Step 6 error
    Can't open CFBundle for /System/Library/Extensions/AppleUSBAudio.kext.

    Step 8 error
    mv: rename /Users/USERNAME/Downloads/AppleUSBAudio.kext to /System/Library/Extensions/AppleUSBAudio.kext: No such file or directory

    Step 9 error
    /System/Library/Extensions/AppleUSBAudio.kext failed to load - (libkern/kext) not found; check the system/kernel logs for errors or try kextutil(8).

    I checked the Extensions folder and there's no AppleUSBAudio file. The downloaded file is in my Users/USERNAME/Downloads folder.
  • Zephyrana Level 1 Level 1 (0 points)
    I got as far as trying to install the downloaded AppleUSBAudio.kext file, and got this pop-up message:

    "The system extension "/Sytem/Library/Extensions/AppleUSBAudio.kext" was installed improperly and cannot be used. Please try reinstalling it, or contact the product's vendor for an update."

    The error message in Terminal is:
    /System/Library/Extensions/AppleUSBAudio.kext failed to load - (libkern/kext) authentication failure (file ownership/permissions); check the system/kernel logs for errors or try kextutil(8).

    And now I can't use my USB headset or speakers at all.
  • Einherji Level 1 Level 1 (0 points)
    Open up diskutilities and run repair permission for the startup disc. restart the computer and then it should be good.

    You might have to run the " sudo kextload /System/Library/Extensions/AppleUSBAudio.kext " command again once you have restarted your computer though.
  • Zephyrana Level 1 Level 1 (0 points)
    Thank you for your help. I reinstalled the system because I needed to have sound working today, but I'll try your suggestion on the weekend.

    Thank you
  • dec182 Level 1 Level 1 (0 points)
    Seems like the latest update to OSX brought this back for me... so bump.
  • Harrolds Level 1 Level 1 (0 points)
    This fix did originally resolve the issue.. but since the latest apple update this fix no longer wants to work.. any suggestions?
  • r.sheth Level 1 Level 1 (20 points)
    I'm running 10.6.4 on my iMac i5 and I am having this problem as well over Ventrilo using a Logitech USB headset. Everything will be fine for 20 or so minutes, then out of nowhere my headset mic makes me sound like a robot. Pretty annoying.

    Hoping Apple gets a fix in the works for this.
  • Trevor Melski Level 1 Level 1 (25 points)
    Same issue here. This is really annoying. We know this is a USB driver issue because swapping the USB kext for an older one worked. Come on, Apple, please address this.

  • Pierre Vinandy Level 1 Level 1 (5 points)
    I am running 10.5.8. I tried different devices such as USB headsets and lately connecting a Allen&Heath Xone 42 DJ mixer via usb to my Mac pro. this is top audio equipment, yet I have the same problem as with the headsets. My voice sounds robotic. I need this way of audio input to stream music online and play live shows on second life, I will have to cancel all shows if I cannot resolve this. Hey Apple people! thanks for the Iphone and the Ipad, I think you are all doing a great Job. but this minor problem seems to have been around for a while and a tough one for many users! why the silence about it! You are winning the war with microsoft but do you not have a cure for the flu? PLEASE HELP! DO I HAVE TO SPEND MONEY ON CALLING APPLE IN THE US AGAIN AND SPEND HOURS ON THE PHONE TO FIX THIS????? driving me mad I must admit! This mac did cost me a bomb and I need it for a living. please make it work!
Previous 1 2 3 4 Next