Previous 1 8 9 10 11 12 Next 165 Replies Latest reply: Aug 13, 2015 9:18 AM by Brungädda Go to original post
  • MrSantana Level 1 (0 points)

    So would it be better to install windows directly through bootcamp rather than through a VM?

  • morph21 Level 1 (10 points)

    As long as you choose "Plug this USB into the VM" instead of the "Mac" in Parallels, it works the same.


    However, if you let the USB be captured by the Mac and THEN pass that to the VM, it won't work.


    Just install Windows 7 in Parallels, have it up and running, then plug the USB. When Parallels asks where you want the device to be plugged into, the VM or the Mac, choose VM. That simple. =)


    When you plug the USB device, you should see something like this. Just make sure you select the VM:



  • altkee Level 1 (0 points)

    Hey all if you really want to fix this problem once and for all buy a Creative usb sound card. All their sound cards have mac software and the robot sound does not happen. Also works with any microphone.


  • M2theC_NL Level 1 (0 points)

    Wow, have a brandnew iMAC late 2013 model and was having so much problems with my Sennheiser DW office headset. I actually have two of them and they both have the same issues as described. However it looks very random. But whatever the case, it always starts after 5 minutes (when it starts).


    First we thought it was Skype but when changing to the integrated omni mic everything worked fine again.


    I can not change any settings for this device in the midi tool. Very frustrating....  So after all the issues with their crappy Mail, the audio is having issues too. Its a shame.


    Good thing I found this thread, i was going crazy and about to invest another 300 euros for a new headset. That would have been 900 euros just to get this piece of crap working...

  • Kasi-Hasi Level 1 (0 points)

    I have the exact issue with the late 2013 iMac.

    I had a late 2009 model with Mavericks installed and a Samson Meteor Mic attached to it. Never had any trouble with the mic. Until I got the late 2013 model and made a fresh install of OS X Mavericks. Now I always get these alien sounds.

    I'm making test audio recordings with Quicktime where I have then recorded these aliens sounds.

  • Oversea Level 1 (0 points)

    This replaced my not supported USB Device and for me it works perfectly:

  • MrJeaz Level 1 (0 points)

    Actually, that's not true. I have a SoundBlaster Recon 3D and have the exakt same problems.


    Oddly enough, I didn't have it on my old iMac, although I had problems with other USB soundcards with it. But after getting a new iMac in December, the problems are back with the SoundBlaster soundcard.

  • Careless Nomad Level 1 (0 points)

    I was having the same problems on my late model 2013 iMac.   Glad to see it wasn't my headphones.  I also am using Creative brand USB headset.


    I had updated the drivers with no luck.   But now I have I updated the firmware and that seems to have fixed it.

  • Careless Nomad Level 1 (0 points)

    I take that back.


    After about an hour, the static is back, even after updating the firmware.  I think it starts when I have multiple applications open simultaneously, especially whenever I have my browser open in the background.

  • ptoal Level 1 (0 points)

    I am also encountering this symptom on a brand new MBPro Retina 15" w/latest 10.9.2 OSX.  I am using a SteelSeries V2 headset, which comes with its own USB dongle.


    This wasn't a problem on my older Macbook pro, because it had a Mic In port, but the new one no longer has that port, for what reason, I do not know.  So now, the only way to use a microphone (other than the built-in one), is to connect it via USB.


    I suppose I will open up a support case, refer to this thread, and see what happens.



  • morph21 Level 1 (10 points)



    Did you know that Apple has been using 4 pin connectors for iMacs and MBPs for at least 4 years?


    Basically, all you need is an adaptor, and the MBP does have a mic in, just not in the traditional "PC" way.


    All you need is one of these: AQ/


    I have one, and use it on my iMac late 2009 and used on my MBP too, as well as iPhone, iPad, you name it.

  • xarius87 Level 1 (0 points)

    Thank you morph21 - I didn't know that - I will try it out!


    My whole family uses Mac and i can confirm the problem on

    Macbook Air 13" Mid 2014

    Macbook Pro 15" early 2011

    Macbook Retina 15" mid 2012

    Macbook Retina 15" late 2013

    iMac 27" late 2012


    using MacOS 10.6, 10.7, 10.8 till 10.9.4. Robotic sound @Skype, @Teamspeak and @Ventrilo


    I tried 4 different usb-sound adapters. Same issue in all cases.

  • Brendan Casey Level 1 (5 points)

    I haven't solved this issue yet, but I had to login just to say THANK YOU. I have been having this problem across more macs and headsets than I care to admit. I blamed literally every part of the chain except apple. I have used (and spec'd hundreds of thousands of dollars worth of) their production gear professionally for so many years I just trusted them.


    I wondered what would make all my conversations start out with "wow, that's great audio you have on your end!", only to end up 5 minutes later with "uhhh, your voice just fell off the ledge there, you must have a network issue. we'll talk later".  I am so angry at this moment but also relieved. So, thank you for this slice of voip sanity.

  • KRH13 Level 1 (0 points)

    If your Mac ports are USB 3.0 this may help:


    I’ve got a solution that may help some but not others. I have a 2010 MacBook Pro and a 2012 iMac and I noticed that, with two different microphones, I was having the robotic voice problem when using my iMac (the MacBook Pro has always worked perfectly). After trying to run the USB through different cables, I plugged my headset through a (non-powered) USB 2.0 hub and the problem was resolved.


    I’ve since checked some different message boards and, apparently, there is a compatibility issue with the software when using a USB 2.0 headset with a USB 3.0 port. I cannot confirm this, I can only confirm that the USB 2.0 hub eliminated the issue for me.

  • themancan Level 1 (0 points)

    Glad I finally found this discussion. I've been having this problem for years with a Plantronics adapter. It'd go robotic after about 46minutes, without fail. Lost that and got a cheapy replacement which only lasted ~8min before going robotic, and that was bad enough to force me to find a solution. In learning that the Griffin iMic doesn't have the problem (and knowing I'd had problems with the C-Media versions, both with my Plantronics and with the new one), I wanted try something else. Nothing against the iMic, but it looked big, and it's also just so old.


    The Dragon voice recognition communities seem to be a good source for finding out about reliable hardware, and I learned about the Andrea Electronics USB-SA-1 (link to Amazon, currently $31), so I decided to try that. I just did an hour long video call without going robotic, which is better than I've ever had before. I'll update this post if I have longer calls (which I don't generally), but it looks like the Andrea Electronics USB headset adapter might be another good option.