Previous 1 2 3 4 5 Next 164 Replies Latest reply: Jan 26, 2015 3:38 PM by themancan Go to original post
  • Zehwuh Level 1 Level 1 (0 points)
    Having the same problem with suddenly having a robot voice with lots of static on Skype, Ventrilo, Humble and probably other applications too.

    This happens on both MacBookPro's (a 2007 model and a 2010 model) I've tried my two different USB headsets on. One USB-headset by logitech and one by Plantronics. When using windows with these headsets it does not happen which makes me believe it's caused by Mac OS.

    If I replug the headset the robot voice will disappear until it comes back randomly again (as I'm not sure what exactly causes it yet.).

    Please Apple, try to fix this as soon as possible. At least could you tell us you're working on it?

    It's impossible having proper phone calls on Skype with this happening! While I would hate to leave Mac OS for this, it's a possibility I might have to if it's not fixed.
  • Zehwuh Level 1 Level 1 (0 points)
    Anyone know a solution to this in 10.6.4?
    Would be very grateful!
  • Nikolas_ Level 1 Level 1 (0 points)
    This solution still works in 10.6.4, bud. I am using it myself.

    http://evo-wiki.cern.ch/twiki/bin/view/FAQ/AudioProblemMacOSX1057

    If you scroll down in that article, the older version of the kext is attached.
  • GeekBoy.from.Illinois Level 4 Level 4 (2,800 points)
    I can add a little to this topic, as I routinely use my MacBook Pro with a USB headset for Skype calls that run longer than 1-1.5 hours. I have a cheap Plantronics USB audio adapter and headset with twin 3.5mm plugs that connect to it, and it has this problem. I also have a more expensive Logitech USB audio adapter and headset with twin 3.5mm audio plugs, and it works great with no problems. I have been on calls lasting over 2 hours using the Logitech set and it was clearer audio than the people on their phones.

    I don't remember all the details, but Leo Laporte (TWiT network/ www.twit.tv) has also spoken of this issue for a year or more. With the correct USB headset, you can resolve this problem.
  • Zehwuh Level 1 Level 1 (0 points)
    Alright, thanks a lot for telling.

    Just wasn't sure if it did or not since someone said it didn't work for 10.6.4 earlier in the thread.

    And to the poster above: Even if some more expensive headset works in Mac OS, it's a bit strange that the "cheaper" (100+- euros) headsets work fine when using Windows. I've only ever had this issue on Mac OS. Could be that the headset creators should make their own drivers instead of course.
  • mr.bill Level 1 Level 1 (15 points)
    Same problem here... Only problem is that the apple engineers are working on 1 of 2 things:

    - iOS
    - Lion

    Snow Leopard has some pretty significant problems with audio and text rendering on external monitors. We can only hope they address it, but I'd be surprised.
  • dec182 Level 1 Level 1 (0 points)
    So glad to see this problem STILL exists in 10.6.5!

    Keep up the good work, Apple! Let's keep this bug alive!

    Domo Arigato, I am Mr. Roboto!
  • r.sheth Level 1 Level 1 (20 points)
    I can confirm that this bug is still in 10.6.5

    I had high hopes with all our posts and reports about it Apple would have looked into it by now.

    Guess not.
  • Mister Joshua Level 1 Level 1 (0 points)
    Yet another confirmation that it is not working on 10.6.5

    I had to do a combination of the fixes here, when trying the first fix I had permissions issues.

    So here's what I did. All in terminal (After un-plugging my USB audio device, of course).

    1. Unload the USB Audio Driver:
    *sudo kextunload /System/Library/Extensions/AppleUSBAudio.kext*

    2. Backup the newer (but broken) AppleUSBAudio.kext:
    *sudo cp /System/Library/Extensions/AppleUSBAudio.kext Documents/AppleUSBAudio.kext.backup*

    3. Copy the older (but working) AppleUSBAudio.kext
    *sudo cp Downloads/AppleUSBAudio.kext /System/Library/Extensions/AppleUSBAudio.kext*

    4. Fix the permissions on the file (I used the -Rv, "R" is for recursive (all subfolders) and the "v" is for verbose, so it tells you what it's doing...)
    *sudo chown -Rv root:wheel /System/Library/Extensions/AppleUSBAudio.kext*
    4a. You should get an output similar to this:
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/CodeDirectory
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/CodeRequirements
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/CodeResources
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/CodeSignature
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/Info.plist
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/MacOS/AppleUSBAudio
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/MacOS
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/Resources/English.lproj/I nfoPlist.strings
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/Resources/English.lproj
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/Resources
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/version.plist
    /System/Library/Extensions/AppleUSBAudio.kext/Contents
    /System/Library/Extensions/AppleUSBAudio.kext

    5. Load the new (old) driver!
    sudo kextload /System/Library/Extensions/AppleUSBAudio.kext
  • variuse Level 1 Level 1 (0 points)
    Hi,

    I'm struggling with this problem since countless OSX updates... the procedure described by Mister Joshua has worked every time by now. Unfortunately with 10.6.5 it does not work anymore since Apple seems to have changed something serious in AppleUSBAudio.kext this time (without solving the problem). The USB devices don't get recognized anymore. I haven't been able to find any workaround by now.

    Same issue here: http://discussions.info.apple.com/thread.jspa?messageID=12576237

    So it seems we have to wait for Apple to really fix it this time...
  • Sofakinbd Level 1 Level 1 (0 points)
    Same issue here, I tried to Time Machine back to 10.6.4 but it won't load in anything but Safe Boot. I went to my week old backup under 10.6.4 still won't load. Something is fundamentally changed on the comp to not let me go back so it's unfixable atm.

    Hope others come up with a way to make it work.
  • Zehwuh Level 1 Level 1 (0 points)
    It's amazing that Apple haven't even replied to the issue.

    Oh well, *time to do the same procedure to fix it again*, edit: nah that didnt work this time, that's just great isn't it Apple? Ignoring your customers with this issue for this long, then breaking the only known fix?

    I wouldn't be surprised if this same issue is in Lion too when it's launched given the amount of feedback we get from Apple here.
  • Wingman2112 Level 1 Level 1 (0 points)
    From a customer service standpoint this is terrible. It basically makes this portion of our computers useless for what should be an easily functioning device.

    How can we raise this as a trouble ticket with Apple?

    I've tried all the fixes listed in this thread and nothing's working. Is there an updated fix?

    Thanks in advance to anyone who can help create a workaround!
  • CristianTM Level 1 Level 1 (0 points)
    I'm having the same problem here, with my Logitech USB headphone.

    Incredible that such issue can persist for that long without fix.

    I have applecare, i guess I'll open a call to their service about it. Anyone already tried it?
  • Zehwuh Level 1 Level 1 (0 points)
    Did you get any reply from the service, if you called yet that is?

    Meanwhile, anyone found a solution to this problem while running 10.6.5? I've tried searching, but can't find anything that actually works...


    This is getting really frustrating now, as I spend a lot of time talking with people over Skype and the likes. If Apple thinks this is working as intended, please just say so, so we can stop hoping it will get fixed. The problem has gone on for too long now.
Previous 1 2 3 4 5 Next