Previous 1 4 5 6 7 8 Next 168 Replies Latest reply: Feb 7, 2016 12:14 PM by domemvs Go to original post
  • Ben Rose Level 1 (50 points)

    I almost bought the Turtle Beach X11 headset until I read the reviews. Apparently there is a constant hissing noise that's audible when the volume is low or nothing else is playing. I use my headphones for VoIP, music, and movies in addition to gaming, and I wear them pretty much all day, so that's not acceptable to me. I'm glad this headset works for others, though.

  • nicolw Level 1 (0 points)

    I am shocked this is STILL ongoing.  When using Ventrilo it causes major problems I have to edit terminal everytime my computer restarts.  The customer service in not resolving or addressing this problem by Apple is terrible.


    I would like to not have to type in sudo commands every time my computer has a software update or is turned off...Please resolve, it has been well over a year now.

  • morph21 Level 1 (10 points)

    Problem introduced in 10.5.7, which was released in May 12, 2009. More than 2 years ago.

  • Boomhowler Level 1 (0 points)

    I have to recommend the griffin imic once again. Works without a glitch for several hours straight with garageband, Skype, teamspeak etc. Have tried it for several hours straight and been using it daily for months now, not a single issue. This on a Mac Pro which has had lots of problems with logitech usb mics since 10.5.7. Simply wonderful.

  • bänzfromlausanne Level 1 (0 points)

    Please disregard my Jul 15, 2011 10:03 AM post. Whether the headset is powered through USB or through the Walward, the issue is there. False hope.

  • IMac_Gav Level 1 (0 points)

    I am experiencing the exact same bloody issues, even after the upgrade to Lion, come on Apple why cant you bloody sort this? The money we pay for these machines and USB headsets wont even work right.


    Come On!

  • drohr Level 1 (0 points)

    Just want to report that I'm having this issues as well with my USB head set, using 10.6.8 and creative USB head set. Sound just dies after using it for like 30min. Problem solves it self by pulling out the head set, killing the applications (problem exists in any that uses the headset). Change USB port, and restart applications.


    REALLY annoying and it doesnt seem to get any notice

  • BenJHannah Level 1 (0 points)

    I have this exact same problem. The solution is that your input will have for some reason changed to 8 Bit. Go into Audio Midi Set Up and make sure it's set to either 16 Bit or 24 Bit.

  • thinkcomp Level 1 (0 points)

    I'm having the same problem. I have a Logitech USB headset and a MacBook Pro (model number 5,5) running Mac OS X 10.6.8. Sometimes audio through the headset works great for an hour, sometimes just for a minute before degrading into static and then choppy audio a second or two later. It's pretty annoying.

  • Minarlb Level 1 (0 points)

    Wow, I was excited about Buying my first mac today (IMAC 27) and then someone told me about this problem and looked into this and seeing that it's been two years and no fix turned me off and I am NOT going to buy a MAC now unless this problem gets fixed.... Will be keeping an eye on it for when a fix comes out by apple.

  • IMac_Gav Level 1 (0 points)

    This is still an issue even in LION - Please can Apple respond and resolve this god forsaken annoying issue. I have a £2500 iMac here that has bloody sound issues and you cant be arsed to resolve it? COME ON!

  • Spacecadetcraig Level 1 (5 points)

    Hello everyone,


    I have some answers (not solutions) for this issue and a response from Apple's engineers regarding the issue.


    After extensive testing, recording the audible issue, sending system captures to Apple and working with Tier 2 support - I've finally recieved a response that they are acknowledging there is a software problem within OS X. They initially told me this was likely hardware issue or third party problem but finally concluded they needed to fix Apple drivers.


    HOWEVER - there is currently no timeline for this fix. In order to show Apple how important this problem is to us all there are 2 things you can do (please do BOTH):


    1) Submit a bug report here:

         - be very detailed!

         - the more bugs apple gets regarding this issue the higher they will prioritize a fix.

         - Apple DOES NOT monitor these forums and will not accept your complaining here as official report.



    2) Call Applecare (if you have coverage) and report the issue.

         - Offer to send them a system capture (a small tool they will send to capture your system details etc.)

         - tell them about the many discussion on thier offical forums where they can get more info

         - offer to assist them in any way possible to have this problem further identified and fixed



    Doing these things will help fix the issue faster. Please take 10-20 minutes of your day to do these things!


    I can confirm that the issue hapenns on ANY Mac post-10.5.7 with virtually ANY (7 different brands tested) third party USB microphone.


    I hope you will all take quick action and help apple solve this annoying problem.


    Thanks and goodluck!

  • Ben Rose Level 1 (50 points)

    Dude, you are my new personal hero. Can I give you money or something? Let's get on this, everyone!

  • Boomhowler Level 1 (0 points)

    I still don't think that this is only an apple-problem. The griffin iMic is working flawlessly both on SL and Lion on a system which have had problems with other USB-devices. I believe that this is due to that Griffin have implemented the sound drivers correctly according to apple's changes while others haven't bothered to change.


    Anyone else who have tried the iMic?

  • morph21 Level 1 (10 points)

    Boomhowler, the problem is not what worked and still works. The problem is what worked and stopped working as of 10.5.7.


    It also may be a combination of internal mac components (chipsets, USB controller, etc.) and the new drivers. Overall, you have a few major points that get everybody frustrated:

    - it all worked prior to 10.5.7, enough proof that this is a driver issue

    - you can't rollback to 10.5.6 drivers for a "patch" anymore

    - if you install Windows on macs capable of the problem goes away. It is exactly the same hardware, to the last piece of silicon.


    Also, older macs still had the two jacks headphone system, one for headphones another for microphones. So you could still choose from a long list of non USB headsets. Newer macs though have that 4 pin jack, and that narrows down the list substancially. Granted you could use an iPhone headphone with microphone to solve the problem, it is the temporary solution I'm using until this is fixed, however, my USB headset had other characteristics that lead me choose it instead of an iPhone earphone.


    That said, I thought of buying the iMic to try, but I simply couldn't take to buy yet another USB sound solution just because uncle Apple decided to screw up.

Previous 1 4 5 6 7 8 Next