1 5 6 7 8 9 Previous Next 160 Replies Latest reply: Apr 9, 2014 11:14 AM by morph21 Go to original post
  • 90. Re: Robotic Static Sounds USB Headset
    Ben Rose Level 1 Level 1 (50 points)

    OK, it's not an Apple-only problem. That doesn't mean it's not Apple's fault. The fact that one USB device works only means that the makers of the device figured out a way around Apple's problem. As the comments on this thread have made clear, there are many devices that don't work and only one or two that do.

     

    Like Morph21 said, telling everyone to buy a Griffin iMic isn't a true solution to the problem. I considered buying it, too, but besides the extra cost of the iMic, I would have to buy a new set of non-USB headphones to plug into it, as I currently have just one pair of headphones that happen to be USB.

  • 91. Re: Robotic Static Sounds USB Headset
    morph21 Level 1 Level 1 (10 points)

    Well, I just did my bugreport. Took me a while since I was on the move and I wanted to include hardware model numbers and detailed information there.

     

    Now, lets just hope for the best.

  • 92. Re: Robotic Static Sounds USB Headset
    Ben Rose Level 1 Level 1 (50 points)

    I just got a reply on my bug report:

     

    "After further investigation it has been determined that this is a known issue, which is currently being investigated by engineering.  This issue has been filed in our bug database under the original Bug ID# 7076979. The original bug number being used to track this duplicate issue can be found in the State column, in this format:  Duplicate/OrigBug#."

  • 93. Re: Robotic Static Sounds USB Headset
    maclypse Level 1 Level 1 (0 points)

    I've been looking around to find answers to why both my USB soundcards give me interference from my microphone - and find reports of interference with input from USB audio devices dating back for YEARS.

     

    I've found something funny though, that no one else has mentioned anywhere:

    I can often turn the interference noises on and off by touching the metal on my apple keyboard, or on the metal casing on my mac mini. It's weirder than ****. Does this happens for all of you as well?

     

    Hope something happens some time soon. The mini doesn't have a microphone input, so unless I can get the USB devices to work, my only remaining option will be to find a bloody pre-amp to boost the signal enough to plug a mic through the line-in port.

     

    Frustrating.

  • 94. Re: Robotic Static Sounds USB Headset
    drohr Level 1 Level 1 (0 points)

    After getting this problem a long time with my creative head set, I actually never thought it could be something with the specific hardware. Always thought it was a software issue in MacOSX.

     

    I just happend to dualboot on my Mac Pro, and actually got the exact same issue in Windows 7.

  • 95. Re: Robotic Static Sounds USB Headset
    Spacecadetcraig Level 1 Level 1 (5 points)

    Most people in this thread don't get the robotic sounds in Windows. Only Mac OS X. You may be having a different issue.

     

    "Static" or "robotic sounds" can be interpreted many different ways. It's possible that some people may be getting some kind of distortion that inst related to software. But, there was a specific change to apple's IOUSB kext driver in 10.5.3 (or thereabouts) that makes this happen. Any OS before that and it's fine.

     

    In fact, the apple rep that was assisting me on the phone (skype via usb mic) was at first like "right...static in your mic eh?..yep - your hardware is the problem.. return your headset" etc etc. After talking with her and submitting lots of info - my mic flipped out during the call (while i was recording it) and then all of a sudden she was like "omg...yeah smething is definitely wrong..let's get this to the engi's!" haha.

     

    Again - it's intermittant - not constant.

     

    And to maclyspe: nope - not a harware / short for most of us. I've tried grounding myself on my mac pro - touching the alluminum on the keyboards, wearing foil on my head.... nothing. Sounds like you have a grounding issue.

  • 96. Re: Robotic Static Sounds USB Headset
    morph21 Level 1 Level 1 (10 points)

    Well, there we go, posted system profiles, even audio recording sample of the problem. After that, here is the answer:

     

    This is a follow up to Bug ID# 10480800.  After further investigation it has been determined that this is a known issue, which is currently being investigated by engineering.  This issue has been filed in our bug database under the original Bug ID# 10557859. The original bug number being used to track this duplicate issue can be found in the Related Problem section of your bug report's Problem Detail view.

     

    It bothers me that the "original" bug has a bug ID bigger than mine... anyway... that is all I got so far. Mine is closed and I can't follow up on the "original".

  • 97. Re: Robotic Static Sounds USB Headset
    Spacecadetcraig Level 1 Level 1 (5 points)

    I am in touch with a senior tech support rep who is keeping me posted. Nothing yet.

  • 98. Re: Robotic Static Sounds USB Headset
    corylg Level 1 Level 1 (0 points)

    I'm having these issues and it is getting extremely frustrating not to be able to use my good microphone / headset as I should be able too.   I'll be calling the applecare line as well.

  • 99. Re: Robotic Static Sounds USB Headset
    fakeh Level 1 Level 1 (0 points)

    I spoke to the people that make the iMic. She contacted their development team and apparently there's zero reason why their hardware wouldn't be effected while other peoples' was. They haven't compensated for this in any way.

  • 100. Re: Robotic Static Sounds USB Headset
    Dr_Vex Level 1 Level 1 (0 points)

    Hi everyone,

     

    I'm having the same problem as everyone else here. Unfortunately, I attempted the terminal kext replacement fix before I realized it no longer works with 64 bit machines. Now I simply have no USBAudio driver loaded and my mic isn't recognized at all.

     

    I know all I have to do is restore the new driver from the backup, but I don't know how to do it. Could anyone post terminal instructions for that?

     

    Thanks!

  • 101. Re: Robotic Static Sounds USB Headset
    Spacecadetcraig Level 1 Level 1 (5 points)

    Dr_Vex,

     

    what mac and version of OS X are you running?

  • 102. Re: Robotic Static Sounds USB Headset
    Spacecadetcraig Level 1 Level 1 (5 points)

    @Fakeh

     

    Apparently the issue occurs when any software that is controlign the mic requests a rate / frequency / quality change. Almost all USB mics support this feature - perhaps iMic doesnt have this "switching" feature.

  • 103. Re: Robotic Static Sounds USB Headset
    SkottKnoble Level 1 Level 1 (0 points)

    So we have 10.7.3 and still no solution to the issue of robotic sounds from usb headsets and ventrilo :-/

  • 104. Re: Robotic Static Sounds USB Headset
    nicolw Level 1 Level 1 (0 points)

    I have been using Mister Joshuas fix

     

    Yet another confirmation that it is not working on 10.6.5

    I had to do a combination of the fixes here, when trying the first fix I had permissions issues.

    So here's what I did. All in terminal (After un-plugging my USB audio device, of course).

    1. Unload the USB Audio Driver:
    sudo kextunload /System/Library/Extensions/AppleUSBAudio.kext

    2. Backup the newer (but broken) AppleUSBAudio.kext:
    sudo cp /System/Library/Extensions/AppleUSBAudio.kext Documents/AppleUSBAudio.kext.backup

    3. Copy the older (but working) AppleUSBAudio.kext
    sudo cp Downloads/AppleUSBAudio.kext /System/Library/Extensions/AppleUSBAudio.kext

    4. Fix the permissions on the file (I used the -Rv, "R" is for recursive (all subfolders) and the "v" is for verbose, so it tells you what it's doing...)
    sudo chown -Rv root:wheel /System/Library/Extensions/AppleUSBAudio.kext
    4a. You should get an output similar to this:
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/CodeDirectory
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/CodeRequirements
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/CodeResources
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/CodeSignature
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/Info.plist
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/MacOS/AppleUSBAudio
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/MacOS
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/Resources/English.lproj/I nfoPlist.strings
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/Resources/English.lproj
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/Resources
    /System/Library/Extensions/AppleUSBAudio.kext/Contents/version.plist
    /System/Library/Extensions/AppleUSBAudio.kext/Contents
    /System/Library/Extensions/AppleUSBAudio.kext

    5. Load the new (old) driver!
    sudo kextload /System/Library/Extensions/AppleUSBAudio.kext

     

    This works for me and I have been doing so for around 2 years now!  I have to do this each time I restart my computer or shutdown but I usually leave it on sleep anyway. 

     

    The driver I download is from the following link http://evo-wiki.cern.ch/twiki/pub/FAQ/AudioProblemMacOSX1057/AppleUSBAudio.kext. zip

    I actually place the driver in the following location  'System> Library>Extensions>'  Sometimes you can get an error message despite the sudo commands so just simply run 'repair file permissions' under disk utility.

     

    I am running snow leopard 10.6.8. and sometimes my USB will not show although I find if i just follow the above commands a second time it will reappear.  Its odd.

     

    I know its not the fix apple should be providing but hopefully it can help those who in the meantime get driven crazy by the robot voice!

1 5 6 7 8 9 Previous Next